Manjaro ARM Beta4 with Phosh (PinePhone)

Previous time i installed fresh was beta2, just updated until the recent boot issue when i decided to reinstall. But now beta4 has regressed in bluetooth recognition speed. Before reinstalling i only needed to press a few times on my keyboard to wake the phone up or enter pin after boot, but now it takes like 10 keypresses before it recognizes input. Also detection when pairing the keyboard took maybe twice as long to get recognized than before.

Also sometimes when waking up from deep sleep the data connectivity indicator stays as a upside down triangle with a question mark, but internet data and phone calls keeps working. I have not seen this previously even though i have been using the phone since the release of braveheart.

[beta4] Update: it seem to look like when the PinePhone is idle for long periods of times (e.g. over night no usage), the cellular modem does not go back on, I had to restart the device.

3 Likes

My findings so far:

  • So Anbox does not seem to work, personally I don’t care much, just wanted to mention.
  • Once I can see the app grid I can’t make it go down to see the desktop, I guess this is intentional.
  • Sometimes after being left alone for a longer period of time, like a night, it takes 5-6 ringings for the phone to wake up, sometimes it is between the 2nd and the 3rd ringing.
  • I can feel that animations are disabled, this is because of the stand-by time?
  • I have the phone laying on my desktop for more than a day now, updated 2 times, still at about 40%: nice job.
  • Once woken up the phones takes appr. 10 seconds to find coverage, I guess this is fine too.
  • Megapixels is not working since Beta2: aspect ratio is bad, green filtering, unusable.
  • In general the phone feels faster, stand-by time is increased greatly, but under heavy usage it can discharge in an hour.

Thanks!

1 Like

I installed the Jan. 2nd. release. I read that Anbox was re-added, but after I flashed it to my pinephone’s eMMC (PostmarketOS CE) I didn’t see it there. I downloaded it and flashed it again to make sure, and didn’t find it. Am I missing something?

@philm I have a quick question, who develops the “Calls” application for Manjaro-arm for the PinePhone?

I am asking, since I have a small UI improvement suggestion:

Adding two additional tabs:

  1. “Contacts” - so it is possible directly from “Calls” to find a desired contact, this is perhaps relatively easy to implement utilizing the already existing “Contacts” interface - but integrate it into “Calls”.

  2. “Favorites” - where it is possible to add up to (for an example) 5-10 contacts, where calling each contact on that list will be as simple as tapping on it (without the need to select the contact, and then tap on the “phone” button from his contact profile, so some kind of quick-call)

Those two additional integrated tabs will make the “Calls” application much more practical and useful.

who should I contact? :slight_smile: I’d love to hear what people personally think

Calls is developed by Purism. You can connect with them via their gitlab: Librem5 / calls · GitLab

1 Like

You may find more info about open issues with megapixels here: Megapixels — sourcehut todo

I’m currently on the unstable branch but I was also experiencing the issue on the testing branch.
Is anyone else having issues with squeekboard crashing and getting the “A problem has occurred and the system can’t recover.” screen?
I don’t know exactly what causes the crash, but one way I can reproduce it is by: rebooting, clicking search apps to bring up the keyboard, open firefox, click the url bar to bring up the keyboard, closing firefox with the keyboard still up, then open firefox again.

I can provide the full logs but here is what I believe is the issue:
manjaro-arm sm.puri.OSK0.desktop[4106]: thread ‘’ panicked at ‘already borrowed: BorrowMutError’, /build/squeekboard/src/squeekboard/src/submission.rs:66:59

I was able to solve the issue by downgrading the squeekboard package to an older version that I had cached; I did this by running this command: sudo pacman -U /var/cache/pacman/pkg/squeekboard-1.11.1+8+gc9f9a3b-1-aarch64.pkg.tar.xz
The versions of squeekboard I have tried are 1.11.1+51+g6e7c0e6-1 1.11.1+46+g4d24af4-1 1.11.1+8+gc9f9a3b-1 but only the oldest version I had in my cache solved the issue (I think this version is available in the arm-stable repo if someone wants it).

1 Like

I was able to reproduce your issue.
Pinephone PmOS-Edition
installed beta4 stable
ran pacman -Syyu and rebooted
switched over to testing and ran pacman -Syyu again

Your reproduction steps worked fine and I was able to crash twice in a row
Sadly Squeekboard wasn’t cached for me, so with some help from a friend we were able to find it in the stable repo as you’ve said. after download and install it works well again.
Why do you not post that in the bugtracker? Do issues with testing not belong there?

in case someone else wonders how one gets a package from another repo (Yes, I’m new to this):
by running cat /etc/pacman.d/mirrorlist, I was able to grab the URL of a mirror.
looking at the URL https://manjaro.lucassymons.net/arm-testing/$repo/$arch, I changed it to
https://manjaro.lucassymons.net/arm-stable/ and looked for the package in community/aarch64/ (searched via F3). When I found it, I appended the package name to the URL https://manjaro.moson.eu/arm-stable/community/aarch64/squeekboard-1.11.1+8+gc9f9a3b-1-aarch64.pkg.tar.xz and downloaded the package:
cd /var/cache/pacman/pkg/
and
sudo curl -O https://manjaro.moson.eu/arm-stable/community/aarch64/squeekboard-1.11.1+8+gc9f9a3b-1-aarch64.pkg.tar.xz
After downloading, I installed it with
sudo pacman -U /var/cache/pacman/pkg/squeekboard-1.11.1+8+gc9f9a3b-1-aarch64.pkg.tar.xz like @rabbitLab mentioned

I’m new to submitting issues so I’m not sure exactly where it would be best to post about, this problem was just frustrating to me because I had to reboot everytime it happened so I thought I should post about it somewhere.
I think the bug tracker linked in the 2nd post of this thread is the right place so I posted about it there.

I’ve to see why squeekboard newr than 1.11.1+8+gc9f9a3b-1 has some issues and crashes. Thx for confirming the issue, guys.

@rabbitLab, can you open an upstream issue for this? Also add every information you may have on this.

Sure, is it alright to post issues there if I’m not sure the bug is reproducible on the Librem 5 (because I don’t have one to test it)? I’ll type something up later today with all the info I have and post it there, or I’ll add my info if someone has already submitted the issue.

I have a “brand new” Pinephone Manjaro Phosh Beta 4 and massive stability issues. The screen always goes black when in use and can be reactivated by logging in again. I suspect that the device is overclocked and therefore tried to set with a u-boot patch to a lower speed. There is a description in the Pinephone forum. Unfortunately it is unsuccessful.

Alternatively, I tried Mobian and Ubuntu Touch. Mobian (phosh) shows the same behavior. UT, however, runs stably (!), but the call function is very unreliable and UT is not well maintained.

The problem is a bit difficult to describe.

My test application for Manjaro Phosh and Mobian is Firefox. This program is the quickest way to find the bug. Firefox starts (after flashing first time) and shows its standard intro. After entering a URL, the page loads and then the screen goes dark. There is no longer any visible reaction. Typing is still accepted, but completely in the dark. Switching off and on shows me the login again. After logging in, the screen goes black again. From this point on, the screen goes dark in almost all programs during interactions (tapping, swiping …). This has been since the first moment and switched on since I got the phone.

Remedy: Blind tap on the lower edge of the black screen to minimize the program. Switching off and on shows the login screen again. After logging in, the screen is on again and the program is minimized in the upper area. I can only close it because opening it again causes a black screen.

So my hope is this thread here. I tested the hardware with the test image from the Pine64 website. All functions of the phone have been completed successfully.

What have I done until now?

I have flashed some * .bin files on the SD card and/or in the internal memory, the highest, medium and lowest speed to see an effect. After flashing (with dd …) with the files from Pinephone website, the phone no longer starts. The LED only blinked red (with Manjaro Phosh Beta 4), with Mobian only green.

In a Manjaro Phosh Image (developer 2021-01-02) I found 3 * .bin files (u-boot-sunxi-with-spl-pinephone-492.bin, u-boot-sunxi-with-spl-pinephone- 552.bin, u-boot-sunxi-with-spl-pinephone-624.bin). I was able to successfully flash the 492 file. However, I cannot see any effect. I still get the black screen.

I flashed it via jumpdrive. “lsblk” showed me the phone memory as “sdb”.

In a root terminal : “dd if = u-boot-sunxi-with-spl-pinephone-492.bin of = / dev / sdb bs = 8k seek = 1

I’m not sure if I did everything right? Any help is welcome. At the moment the phone is unusable.

References (random chrashes):
https://forum.pine64.org/showthread.php?tid=9832
https://wiki.mobian-project.org/doku.php?id=troubleshooting

I had to flash the 552.bin to get my ubports CE pinephone to boot manjaro. The command you ran looks correct, but can you post it exactly as it was in the terminal (without the italics or other formatting). If you can get the phone to boot then the output (after the black screen) of journalctl --boot --priority err could be useful.

I checked systemctl status and it said pinephone-modem-scripts.pinephone-modem-setup.service failed

main process exited, code=exited, status=1/FAILURE

any idea what might be wrong? Everything seems to be working normally except i cannot see the connectivity arrows in the status bar.

Thanks for the answer. I solved the boot problem by using a different SD card.

Not resolved is the black screen problem. I tried all the DRAM patches for Manjaro Phosh and Mobian from 492 to 624 MHz and had more or less success. No patch makes the phone stable. I also bought my son a Pinephone and both came together in one delivery. His phone is stable from the start, so I suspect that the memory chip quality is poor on some devices? Selling an unusable device is not good business. The quality control should definitely get better.

I have no idea. What else could I do?

@4carlos I don’t know a lot about uboot or hardware issues, but your question got me interested so I started trying different uboot files. Since you said UT runs stably you might be able to just use the uboot from ubports (I don’t know if there are consequences to doing this, but it seems to be running fine on my pinephone with manjaro) This is how I got the file: wget -O ‘uboot.zip’ ‘https://gitlab.com/pine64-org/crust-meta/-/jobs/artifacts/master/download?job=build’ The command is referenced in this file so I think it is the one used for ubports: build.sh · master · UBports / Community Ports / PinePhone_PineTab · GitLab
You could also try using newer or older builds of manjaro-arm.

1 Like

I don’t receive text messages (SMS) for about 10 days. Anyone has the same issue?

I had a similar problem (though with mobian). The modem gets clogged up some times.
From the mobian wiki:

For now, if you recieve a bunch of MMSes and they clog up the SMS,

mmcli -m any --messaging-list-sms

lists all of the SMSs that are clogged, and

mmcli -m any --messaging-delete-sms=(id of the mms/sms message)

I deleted all the messages that were identified and that allowed me to get sms messages again.