Manjaro ARM Beta2 with Phosh (PinePhone)

Dude, as400, you need to tone it down a few decibels. Please add to the issues page in order to contribute something constructive and helpful next time.

1 Like

Guys, thank you for this amazing job! We finally see some light at the end of this years-long Android tunnel. I had bought the Pinephone a few months back with UBports but it was not really usable. Now I’m using it with Manjaro as my regular phone.

I have two questions:

  • how do you open an issue on Gitlab as it seems there is no way to sign up? Or is the correct way to report a bug is to post on this forum?
  • as a 7y exp Java/C developer, do you think there is some way to help the development? By what would you start?

Thanks again,

Vincz

1 Like

[quote=“b4thed4wn, post:60, topic:36766, full:true”]
Synchronisation of contacts worked through Google on beta 1[/quote]

If I reject Android and IOS, It’s also the case for Google and all public and free cloud solutions.

For my personal desktop, I use only Xfce, so the I don’t know the Gnome applications and it’s worth in the Pinephone :wink:

You use the Pinephone as your main phone? That’s amazing! I have some questions for you, if you don’t mind?

  • Which DE version do you use on top of ‘Manjaro Mobile’? Phosh Beta 2?
  • How do you deal with the slow wake-up from sleep (CRUST firmware) when you are being called? For me it’s just too slow, making phone calls unusable
  • Is SMS working OK for you?
  • Which chatting/messenging application do you use?
  • Do you use an e-mail client on the phone? If so, which one?
  • Just out of curiosity: which apps do you use the most? :slight_smile:

Thanks in advance for any response!

I went to bed and rethinked some things.

You guys don’t deserve these harsh words. I am sorry for this.

Still, I think it’s better to use stock driver. It’s just working.

2 Likes

Yep, but I must confess that this is still kind of an adventure!

To answer your questions:

  • Which DE version do you use on top of ‘Manjaro Mobile’? Phosh Beta 2?
    Yes I use Phosh. So far no real disagrement, except the fact that sometimes the pin pad is buggy and you have to tap twice to enter a digit to log in;
  • How do you deal with the slow wake-up from sleep (CRUST firmware) when you are being called? For me it’s just too slow, making phone calls unusable
    Indeed, I miss some calls when I’m not at home; generally placing calls is OK however;
  • Is SMS working OK for you?
    Yes no particular issue with SMS. The link with my contacts is not always working, so only the number is displayed; sometimes also it’s not possible open a text message without rebooting;
  • Which chatting/messenging application do you use?
    I’ve set up my own Matrix homeserver;
  • Do you use an e-mail client on the phone? If so, which one?
    I have my own email server (mailinabox) so currently I’m just using the web application on Firefox, which is OK;
  • Just out of curiosity: which apps do you use the most?
    I’d say Firefox. Contacts synchronizes well with Nextcloud (though it is kind of slow), as well as the calendar.
2 Likes

If you have the charger cable plugged in when you boot the phone it first charges at 1A but once the DE starts loading it drops to 0.5A and stays there. Only by plugging in the charger after DE is loaded does the full charge speed return. Is this expected?

Can I create a new user for Phosh, or will it mess everything up?

Take a look at the ‘tweaks’ page in the mobian wiki (can’t include links in my post for some reason, wiki . mobian-project . org/doku.php?id=tweaks)
The section at the bottom tells you how to rename the user.

Just took a look. Failed at step one:

sudo: adduser: command not found

adduser is a debian-ism. Try this instead:

useradd -m -Gsudo temp

to add a temp user with sudo access. Edit: my bad, ‘sudo’ group is also a debian-ism. Wheel is used in manjaro.

useradd -m -Gwheel temp

Hmm… followed steps. Phosh won’t start now though. I guess the username is hard-coded somewhere.

Nov 14 13:48:50 alecto systemd[7530]: phosh.service: Failed to determine user credentials: No such process
Nov 14 13:48:50 alecto systemd[7530]: phosh.service: Failed at step USER spawning /usr/bin/phosh: No such process

I just did the same, and got the same result. Figured I should do so before telling you to do it! Oh well. I may try some more later on today.

Hi @vincz you are always welcome to help out. To post some on our gitlab instance you simply sign-in with your gitlab.com or github.com account. For whatever reasons as soon as we open up regular signups we get a lot of spam and other unwanted things.

In regard of development: most of the stuff happens upstream at the given projects. As a distro we collect and search for patches to get the reported issues fixed. So, our issue tracker is more or less a collection of issues our users found. Then we check if they got already reported upstream and link the reports if we can.

Most of our developers and maintainers are on Telegram easily to been found. Simply ping us there or in this forum.

With beta2 we used the kernel of Samuel. This has the stock driver, which is old. We are currently in progress to switch to the kernel by Ondrej Jirman aka (Megi). This brings a new modem driver called modem-power, which simplifies things and speed up modem wakeup a lot. Also we highered the RAM clock speed from 552 MHz default to 592 MHz to have the modem up from deepsleep in less than 4 ring tones.

And if you want you can go up to 624 MHz to be able to play retro-Games in an decent speed. Partly Blender works then too. So it is a constant work in progress!

2 Likes

Hello, is there any solution on scaling the apps properly in the works? I’ve found that on Plasma the scaling works much better (although not perfect). Also can something be done about the battery usage or would you recommend getting a new battery?

… you can use the application scale-to-fit to force applications to be scaled correctly to the given screen size. Not all Linux apps were coded in the mindset of mobile …

1 Like

Salut,
I use Nextcloud for syncing my list of contact, il works pretty well.
I have 3 Pinephones, 2 Ubports and 1 Manjaro ce community edition.
All my devices run on Manjaro Beta 2 Beta2 (2020-11-14) based on unstable branch after have Mobian tested.

*The biggest issue i met was related on pine64 forum /showthread.php?tid=12089 and solved it by removing the simcard, login works after reboot without simcard.
*Actually, i’m not able anymore to fill new user password or credential for nextcloud account

Hello,

I use my smartphone since few days, 11/11/2020. I spent the day with it, It is no so usable has I thought before.

  • Which DE : (what is ‘DE’ ?) I have installed Manjaro Phosh Beta 1 and update (pacman -Suy) each day.
  • How do you deal with the slow wake-up from sleep : I disable the sleeping mode when I’m far of a power supply.
  • Is SMS working OK for you : I can receive and send SMS.
  • Do you use an e-mail client on the phone? : I’ve expected to use a webmail, but it’s hard even in landscape mode.
  • Just out of curiosity: which apps do you use the most? : the Terminal application.

I’ve installed Vim that is usable. I’ve installed Gvim, Aisleriot and Pysol with the recommended packages, all are not usable, the icon is present but a click on it produce nothing.

But this evening I’m disappointed. From yesterday morning, the Pinophone is active.

This morning I’ve disable the sleep mode for roughly three hours. During this time I’ve missed two calls. I’ve checked the screen of my phone : no alert visible. When the person that call me said that she let two messages, impossible to unlock the phone. After a reboot, I’ve checked the Phone application, two missed messages.

Now the phone is hard to unlock. I’ve rebooted it an other time. The unlock application is not stable, sometimes my code is ignored or I must tape two time the same digit to have a star and two times the Unlock button too.

At this moment, the Pinephone with the Phosh Beta 2 is no more usable. I believe that I must flash again the Pinephone.

Bonjour,

Thank you, but I 've not a cloud service like Nextcloud. Have you an idea to load the contacts from the SIM card or the VCF files ?

Merci par avance.