Manjaro ARM Beta12 with Phosh (PinePhone)

Manjaro ARM Beta12 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our twelfth BETA release for the PinePhone running Phosh!

This image is running the 5.12 kernel from Megi, which is designed for the PinePhone.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta11

  • Pipewire got updated to 0.3.31
  • We added Confy to the profile
  • Most of the Gnome packages got updated to 40.2
  • libinput ins now at 1.18.0
  • libxcrypt got renewed to 4.4.22. See also this issue if you miss to change your password and land on a terminal after rebooting your phone!
  • We updated modemmanager to 1.16.6
  • siglo is now at 0.8.4
  • We use now upstream uboot 2021.04 with needed patches
  • Fixed pacman keyring gpg-keys issue. This also includes the fix for dropping to terminal on first
  • Calls is now at 0.3.4
  • More fixes to eg25-manager
  • libxcrypt got updated to 4.4.22. You’re phone won’t boot unless you have changed your password. This image already switched password-hashes
  • Kernel is now at 5.12.13
  • Mesa got updated to 21.1.3
  • Pacman got updated to 6.0
  • Pamac got updated to support latest pacman version
  • Bluez is now at 5.59
  • Chatty is bumped to 0.3.2
  • eg25-manager got some fixes
  • Firefox is at 89.0.2
  • Mesa is at 21.1.3
  • Phoc is at 0.7.1
  • Phosh got updated to 0.12.0. Use the drop-down box to display also non-adaptive apps!
  • Some additional fixes to Squeekboard
  • regular package updates

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • You may loose the modem often. If that is the case call systemctl edit --full ModemManager and then edit --test-quick-suspend-resume to become --test-no-suspend-resume
  • it may take longer to wake up from deep-sleep mode when a call is incoming. Most of the time that call will vibrate only.
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta12
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta12 here

  • Beta12 (2021-07-07) Download
    • based on stable branch
2 Likes

hello, not receiving sms messages on chat program which used to work on phosh 11. thanks.

-just changed suspend settings in power/battery to 1 hour. pinephone went into an error loop with the small font screen, something like ‘malfunctioning sd card’. rebooted and now the suspend settings are missing from power - settings!!??

-just repeated the above and all worked as it should. i think i may not have exited ‘setting’ properly!? put my sim card back in the blackberry and am receiving sms messages again to confirm that it was not a cell network problem. i’ve been dealing with the pinephone patiently (?) for 3 months and it seems the functionality is moving backwards from where it was on phosh 11 before updates. i think i’ll stick with the old blackberry for the time being, i don’t use my phone everyday but phone and messaging have to be reliable. i appreciate all the hard work from everyone, especially beta users who the bought the phone and are troubleshooting for free. i’ll check back in 3 to 6 months when there is something that runs the basic cell phone functions in a stable manner. right now, i just don’t have the time to troubleshoot this device for hours everyday.

Well, I have to say, continuing to update on the unstable branch, WIFI re-connection seems to be ALOT quicker now. From long periods of the phone being in idle, waking the pinephone up via power button, either the WIFI is connected or takes a mere second or two for it to reconnect.

Want to test out the Bluetooth updates ( saw some updates pertaining to this earlier in the week) and hopefully my BT earbuds work again.

Thanks Manjaro Team. Good stuff

noob here, still on Beta11.
I would like to know about possible progress in the following two areas:

Network Manager still does not fit on the screen, so adding vpn and settings is not yet possible here.
nmtui does not fit on the screen either, so no editing and activating connections here either.
I successfully imported my vpn connections to network manager via nmcli.
I can connect to my vpn manually via commandline but…
When it is running, Network Manager does not recognize the active connection running in terminal.
How do I know which connection is covered by vpn and which is not? For example, would the Anbox connection be covered?
I would like to use Network Manager to connect anything data to vpn by default - hopefully soon? :slight_smile:

Appimagelauncher installed ok from repositories.
Appimages seem to install ok with icon on the home screen but they do not open/run.
For the two I have tried, the output is pretty much identical;
First a warning regarding wayland, then error: failed to execute patched runtime: exec format error.
According to some sources, wayland is a problem for AppImages. Or the other way around…
Are there hopes/plans about when AppImages might run under Phosh/wayland, or am I missing any tricks to make it work?

Thanks for all the progess to date!

Seems it is just an old problem with SMS message queue overflow in the modem. Try to clean it manually:

sudo mmcli -m 0 --messaging-list-sms

You will receive the list of SMS messages with their numbers. Then type

sudo mmcli -m 0 --messaging-delete-sms=%d

where %d should be replaced with some number represented in the list. Repeat the procedure for all numbers. As I see at the first glance, these actions should be done only once after update to Beta12 - for cleaning all SMSs received at the previous version (seems that queue size was just maximal and previous algorithm removed only the last SMS each time).
But as I also see, now at the first glance I can normally receive SMS in suspended state again, so great work!

thanks, i’ve bookmarked this for the next time i reinsert the sim into pinephone.

Hello everyone,
first of all: Dear contributors in the Manjaro community, specifically those contributing to Manjaro ARM for the pinephone. Thank you so, so much for your efforts to bring linux to the mobile phone. I much appreciate it :-)!

I currently cannot send sms. This has been a problem in Beta11 as well - though it DID work before there has been an update. Now, when I send an sms for testing, it first shows that it has been sent, then there is a red cross indicating that it has NOT been sent. I have tried the modem-related stuff suggested in the installing notes and by @Xeno because I suspected that this might be due to an overload. Both didnt work.

I also manually updated chatty because I read in a closed gitlab issue that this has led to chatty working (again). This also didn’t work.

Any help is welcome. I will also post an issue on gitlab, just in case. I don’t know if that is relevant, but my provider is AldiTALK (which is e-plus afaik).

I can send and receive SMS just fine with REWE D1 Prepaid card. I might test it at some point again with LIDL D2 Prepaid card when I find time to do so.

I’m in the same boat; I can send text messages, but cannot receive. I did have working sms messages in Beta9, but not since. I’m in Canada on the TELUS network.

I’ve tried the above fix:

output: error: no actions specified

edit: see response below

Please check once more that command was typed correctly. Also please check that modem is active during activation of the command. I had the same problem with receiving SMS on Beta12, but cleaning the queue helped me.
The same reports are, for example, here: Can send SMS but can't receive SMS with Beta 11..? Please help

1 Like

I tried your fix again and rebooted. I can now send and receive sms messages. @Xeno Thank you.

Hello, My PinePhone gets more usable with every new version of Manjaro Phosh. Thanks for that.

Not sure if the following is a hardware issue or a software issue. When I get called, many times I cannot hear the caller and the caller cannot hear me, or I can hear the caller, but the caller cannot hear me. Sometimes a call is successful, but that is only the case in a minority of calls. Does anyone else recognize this? I’m having this problem since I started using my PinePhone, with Manjaro Phosh Beta 8, always with Anbox active in the background. Can this be an issue with my SIM card? Thanks.

Hello, After the latest update, a few days ago, the autorotate had gone mad. The screen kept rotating. With a bit of luck I managed to switch off autorotate , but that was while my screen orientation was upside down. Noiw I do not dare to switch autoratation on temporarily, hoping to freeze the orientation rotated 180 degrees.
Anyone with the same issue? Is it possible to rotate the screen 180 degrees without enabling autorotate temporarily, i.e. via the command line or by editing a configuration file? Thanks.

After another reboot, the screen has rotated 180 degrees by itself. I did switvh off and on my pinephone a couple of times before. Then it did not help. I’m still interested if someone else had the same issue with autorotate.

I’m having the same issue and reported it on the bug tracker. I noticed that after reflashing Manjaro Phosh auto-rotation works for the first boot, but after rebooting always breaks. Unfortunately I have no solution either, I couldn’t find an easy way to rotate the screen manually so far.

THANK YOU XENO! :grinning: :grinning:

I have had this problem for about a month. Thanks to your post, I no longer have this problem. Thanks for posting it.

I am in need of saving a photo of higher quality than which the camera on the pinephone can product. The pinephone does not recognize a usb-c/usb (regular type-A) sdcard reader (with an sd-card in it) (no sound can be heard). I then connected the usb-dock to the pinephone (with power of course) and I could hear the same type of click sound in the pinephone that which I can hear on my desktop when a thumbdrive is connected. However, the thumbdrive does not appear in ‘Portfolio’ or ‘Disks’ gui programs.

Does anyone know if connecting a usb thumbdrive for easy file viewing (like a photo) should work?

Thanks in advance.

I have experienced similar issue. For me, I fixed it by going into the setting program/app → Sound and increased ‘System Sound’ to a higher level. For some reason, the system sound was getting reduced to zero. Something to try if you have not resolved this issue yet.

maybe try a Nightly build

I solved the usb thumbdrive issue I describe above by the following.

First, I had to plug in the usb-c thumb drive right side up. It is connected the pinephone the other way, it is not recognized.

Second, I had to manually mount the usb-c thumbdrive using the command line.

I am hopeful that a future update will automagically mount a usb-c thumbdrive and eliminate the need for manual mounting. In the meantime, I am quite happy to manually mount a usb-c thumbdrive to transfer files to the pinephone.