Manjaro ARM Beta 24 with Phosh (PinePhone / PinePhonePro)

Manjaro ARM Beta24 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our twenty fourth BETA release for the PinePhone running Phosh!

image

Those images run the 5.18 kernel from Megi.

Features:

  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus (only PinePhone)
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta23

  • Kernel is now at 5.18.0
  • Chatty got updated to 0.6.4
  • We updated the ALSA UCM profile for PP
  • Pipewire is at 0.3.51
  • callaudiod got updated to 0.1.4
  • gnome-calls is now at 42.0
  • most Gnome packages got updated to 42.1
  • Firefox is at 100.0.2
  • Pamac got updated to support Gnome 42
    • libpamac got needed AUR fixes
  • Phosh and Phoc support now gestures
  • Mesa got updated to 22.0.4
  • Systemd is at 251

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • Cameras are not accessible to users on PinephonePro
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.

Download:

Device Phosh
PinePhone Beta24
PinePhone Nightly

About the device:
PinePhone:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.

Order

Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root

Donate!

Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


Bugtracker

If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta25 here

  • Beta24 (2022-06-05) Download
    • based on stable branch
  • Dev (2022-06-20) Download
    • based on unstable branch
    • Pipewire got updated to 0.3.52
    • Chatty is at 0.6.6
    • Firefox got renewed to 101
    • Gnome packages are now at 42.2
    • Kernel is now at 5.18.3
    • Mesa is at 22.1.1
    • Pamac and libpamac got renewed
    • Phosh gets its second beta release of 0.20.0
    • Phoc is at 0.20
    • systemd is updated to 251.2
    • xorg-xwayland is at 22.1.2
  • Dev (2022-06-28) Download
    • based on unstable branch
    • Chatty is at 0.6.7
    • Kernel got updated to 5.18.6
      • this includes also fixes for PPP cameras to make them work with ppp-cam testing app
    • update of glibc-locales including C.UTF-8
    • Gstreamer is at 1.20.3
    • Networkmanager got updated to 1.38.2
    • PulseAudio is renewed to 16.1
    • Megapixels is at 1.5.0
    • Mesa got updated to 22.1.2
    • Phosh got renewed to 0.20.0-beta2 and Phoc to 0.21.0-beta1
    • Squeekboard bumped to 1.18.0
      • introduced a regression with Terminal App (kgx/gnome-console), or not
  • Dev (2022-06-29) Download
    • based on unstable branch
    • Kernel got updated to 5.18.7
      • PPP: Add support for applying Type-C plug orientation correctly to Rockchip Type-C PHY from the DWC3 USB driver.
      • PPP: Enable processing the highest resolution of the IMX258 sensor via RKISP10.
    • Phosh got more MRs added
    • Gnome-Console replaces kgx
    • ModemManager got updated to 1.18.10
    • MegaPixels is at 1.5.1
    • js91 may break Gnome-Weather, so we have to see on how we deal with that
1 Like

Really happy to see a new “stable” release after such a long time. :slight_smile: The new phosh gestures are nice on the pro, and its generally overall very smooth. There notification bar swipe down is a bit glitchy in landscape mode though, for PPKB users, its going to be difficult. Seems like it doesn’t adjust to the change in height correctly, making it hard to swipe up, and cutting off notifications.

What is this scale-to-fit feature that you mentioned?

Thanks by the way for this amazing job :smiley:.

I second that! I’m very happy to see a new release! It’s working very well. There is only one main issue I’ve been having and it’s happened on a few releases thus far. Whenever I am playing music via Lollypop sometimes Phosh crashes or the (OG) Pinephone will spontaneously reboot. It’s very strange and I have no idea what could be causing this behavior. So far it’s happened about 3 out of the 4 times I’ve used the app just yesterday. Maybe it just doesn’t like my music. :slight_smile: Has anyone else experienced this?

Scale-to-fit is a command via the terminal that you can use to better scale certain apps to be more mobile friendly. It doesn’t work on all apps (I believe devs need to add the functionality in an app but I’m not sure) but it’s very handy if an app doesn’t fit the mobile screen very well. To use it, simply type the command and then the name of your app, like this: scale-to-fit Chrome. If done correctly, it should come back with a response that says scale-to-fit is now true.

1 Like

I’ve noticed that one of things left to polish in Phosh in Pinephone is that some apps just seem out of bounds, like @LinuxFan1 mentioned in his post.

I was trying to understand how this works. Is this just a problem of how Phosh represents windows or a problem of apps themselves?

Take as a Manajro example, Pamac. In my Pinephone when I open Pamac and click some app to install I get an out of bound window. Is this a Pamac issue or a Phosh issue?

Hello, i tried to start Beta24 of Phosh for PinePhone from SD card 32 GB …after 10min.

After installing this release fresh i am no longer able to update the modem firmware, adb says protobuf.30.so not found, and this seems to be a long-standing problem. I found this weird since i updated the firmware a month ago to version 0.6.5 but i guess the old library was there from previous version of manjaro that i had been updating?

It would be nice to get this fixed at some point, if arch is not doing it maybe android-tools could get promoted to manjaro repo with the fix?

After installing this release, my PPP boots into a black screen with no way to recover but reflashing. I have tried installing the phosh build multiple times and had to go back to arch, because manjaro is just broken. Arch has the same problem by the way, but only if one updates the install (the release is from 2022/05/02)

I found this issue on the bugtracker which seems to resemble my issue:
gitlab(dot)manjaro(dot)org/manjaro-arm/issues/pinephone/phosh/-/issues/258

I though I had a solution to the no audio on suspend issue but turned out to be a bust so i just deleted my previous posts.

today’s first stable update brings a very annoying bug: previously the OSK would only hide the uppermost buttons (arrows) in firefox, making it annoying to type in addresses.

With this update the same is true with even the terminal. As soon as you tap on the text part of the app or try to open a new terminal tab, the OSK resizes and hides the arrows. Making using the terminal an absolute pain.

edit: clicking the globe button and selecting text input language: terminal seems to bring the buttons back. Weird inconsistency.

This is passed my skill level but I am dying to see the fix they have for Mobian on the Pro. It gets suspend and call audio working nearly perfect.

I have tested it on my Pro using install-able .deb packages to go on top of Mobian, that being said Mobian is way far back with the Phosh interface, still using tap gestures and the icons are old looking.

Is it already possible to install manjaro with fde on the pp?

testing branch with phosh/phoc 0.20 seems to make the UI noticeably faster.

Not exactly release related but any news on GPS?

Your image is not on the stable branch, as only testing and unstable have the update to Squeekboard 1.18.0, which brings in that regression: Terminal layout switches to en_US on focus within kgx (#341) · Issues · World / Phosh / squeekboard · GitLab

Edit: seems it is not a bug but a feature: layout switches as soon as you tab in text part or try to open a new tab (#158) · Issues · GNOME / Console · GitLab

It happens on stable once updated, i double-checked just now by re-flashing beta24, ensuring it works as expected, then updating, and seeing the issue.

sha1sum Manjaro-ARM-phosh-pinephone-beta24.img.xz
602843553b7edabce617dfa49782d47731bf7d39

OK, then share the package list what got updated on your end. Based on the issue I reported, squeekboard is not the issue here. Might be Phosh or Phoc. So share your /var/log/pacman.log to see what got updated on your end.