Manjaro ARM Beta 21 with Phosh (PinePhone / PinePhonePro)

Manjaro ARM Beta21 of Phosh for PinePhone!

The Manjaro ARM project is proud to announce our twentyfirst BETA release for the PinePhone running Phosh!


Those images either run the 5.16 kernel from Megi, which are is designed for the PinePhone or 5.16 kernel by Mobian, which supports the PinePhonePro.


  • Firefox uses a dedicated configuration and plays videos on Youtube pretty well
  • Camera app with access to back and front camera, including autofocus
  • Auto-Rotate function and manual rotate
  • Welcome wizard for easy setup of the device
  • We have now a working Torch in the quick-access-menu
  • Prime phone functions working, including resume from deep-sleep and free speaking
  • Recording of audio works
  • Most applications got added to scale-to-fit
  • Haptic feedback functions are given
  • Optimized keyboard layout for terminal
  • Maps working with geolocate
  • Volume buttons working
  • Sensors fully functional
  • Easy access to Bluetooth, Wlan, Rotate and Mobile functions via quick settings
  • Default branch is arm-stable. This can be changed by editing /etc/pacman-mirrors.conf
  • usage of callaudiod for better audio experience with calls
  • This image uses a Crust enabled uboot

Changes since Beta20

  • Kernel got updated to 5.16.2
  • switched to Pipewire
  • PipeWire is now at 0.3.43 including some additional upstream patches to make switching of audio-profiles work
  • Phosh and Phoc got additional patches
    • we support now complex passwords at lockscreen
    • initial VPN support got added
    • supports to dismiss notifications via swipes
  • alsa-ucm-pinephone gained more adjustments for the PinePhonePro
  • chatty is now at 0.6.0-beta
    • this version of Chats updates the database schema
    • History of SMS/MMS need to been cleaned, else the the app will crash
    • you may move the file ~/.purple/chatty/db/chatty-history.db.xxxx (where xxxx is a unix timestamp) to a backup directory of yours
  • Calls got renewed to 42alpha0
  • megapixels is at 1.4.3
  • phoc 0.11.0 uses now wlsroot 0.15.0
  • eg25-manager gained more audio improvement for the PinePhonePro and handles now modem firmware flashes much better. Preparation for fwupd
  • gnome-calls 42alpha0 got additional UX improvements added
  • pinephone-manjaro-tweaks fixed an issue with upgrading the Plasma-Mobile Factory image of PinePhone Beta Edition to be able to update via Discover
  • squeekboard got a new stable release as in 1.15.0
  • Mesa is at 21.3.4
  • Xorg-Server is at 21.1.3
  • mmsd-tng is now at 1.7
  • siglo is at 0.9.6
  • callaudiod got renewed to 0.1.3 including more enhancements for pipewire and tracks and exports current states
  • Bluez is now at 5.63
  • Gnome parts are now at 41.3
  • Firefox got updated to 96.0.2
  • Systemd is now at 250.3
  • Python got updated to 3.10
  • Uboot for the regular Pinephone got updated to 2022.01
  • We dropped Telegram including Qt5 and Qt6
  • We use now a more mobile friendly version of Gnome-Clocks

A detailed list of package changes can be found here.

Currently broken:

  • GPS may not work as it should

Known issues

  • Chatty may crash with experimental features like MMS enabled. You may disable them via gsettings set sm.puri.Chatty experimental-features false if that is the case
  • UI becomes unresponsive after a while.
  • Doing a recording may result in noisy audio savings
  • Lots of apps are still missing or are not mobile friendly yet.


Device Phosh
PinePhone Beta21
PinePhone Nightly

About the device:
Perhaps you’re in a line of work where security is a must, or a hard-core Linux enthusiast, or perhaps you’ve just got enough of Android and iOS and you’re ready for something else – the PinePhone may be the next Phone for you. Powered by the same Quad-Core ARM Cortex A53 64-Bit SOC used in our popular PINE A64 Single Board Computer, the PinePhone runs mainline Linux as well as anything else you’ll get it to run.

The purpose of the PinePhone isn’t only to deliver a functioning Linux phone to end-users, but also to actively create a market for such a device, as well as to support existing and well established Linux-on-Phone projects. All major Linux Phone-oriented projects, as well as other FOSS OS’, are represented on the PinePhone and developers work together on our platform to bring support this this community driven device.


Pinephones Beta Edition are still on stock. Visit the Pine64 Store

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

The PinePhone should recognize the SD card as a bootable device and boot from it.

The premade users are:
User: manjaro
Password: 123456

User: root
password: root


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


If you face issues with this editon, please open a new issue on our bug-tracker

Development Changelog

We will list our progress to Beta22 here

  • Beta21 (2022-01-24) Download
    • based on stable branch
  • Dev (2022-01-28) Download
    • based on unstable branch
    • Pipewire got updated to 0.3.44 including the needed fixes to make audio profile switching work
    • Chatty got renewed to 0.6.0.
    • Firefox is now at 96.0.3
    • Calls got its first Beta1 of 42 release series
    • Mesa is now at 21.3.5
    • We added some more fixes and improvements to Pamac
    • Phoc is now at 0.12.0 and uses wlroots 0.14.1
    • Phosh got updated to 0.15.0
    • Squeekboard is now at 0.16.0
  • Dev (2022-02-02) Download
    • based on unstable branch
    • Chatty and Calls gained UI improvements and SMS/MMS enhancements
    • We updated the device profiles for Pinephone(Pro)
    • More fixes went into Pamac to have a better AUR support
    • Phosh gained some UI polish and small fixes
    • squeekboard adopted more the overall design/look
    • Kernel is now at 5.16.5
  • Dev (2022-02-07) Download
    • based on unstable branch
    • Kernel got updated to 5.16.7
    • Pipewire is at 0.3.45
    • Chatty gained more MMS fixes
    • Calls got some more fixes in regard of SIP
    • More small AUR fixes for Pamac got added
    • Phosh gained some improvements with power management
    • Phoc got small fixes in regard of keyboard managmenet added

Why is this on this thread and not plasma?

Sadly even this beta seems to lose mobile data occasionally, and while plasma version restarts the modem correctly since moving over from ofono, phosh does not do it and need manual disable/enable in settings. This is doubly sad since it was not an issue in few versions up to some updates past beta 17 release.

Nice update I like especially the vpn function and I feel audio is more stable and better. I updated from beta 20 and since the update (Pinephone) the display is not working anymore on some apps like telegram nheko, keepassxc. Is there any way I can make them work again with the touchscreen ? Really need for daily driving.

Thanks for building this awesome distro!

On both editions we use eg25-manager to control the modem. Did you tried different modes like 3G vs 4G or force a mode?

I did the update with pacman -Syu + some clean up in the packages, following the detailed package list diff, most notable ones were :

  • installing pipewire-pulse is nicely removing all the pulseaudio related packages
  • removing telegram-desktop is the enabler to remove all the qt5-* dependencies

I had a black screen + reboot during the kernel post install step, I had to delete the lock file and resintall it after the reboot

no i have not made such force decisions (plasma does not even seem to have them as option). For some reason with phosh i need to disable-enable the data connection after every boot, and then occasionally disable and re-enable it when it is lost. This is automatic on plasma (but spamming huge amount of enable/disable notifications), and beta ~16-17 on phosh but after 1 or 2 updates it started failing again, like before ~beta16. Data on plasma did not work at all before latest release switching to modem manager.

edit: i have biktorgj’s modem firmware, so it might be the cause if others don’t find the same.

It depends which version of that alternative firmware you have …

latest non testing

Yocto 3.4: Bugfixes

Thanks for the new update! I am still struggling with call waiting. Problem has persisted since beta 18 or so. When on a call and another comes in i loose the ability to talk to the call i am on and i can not answer the new call. Is there anyway to turn off call waiting and just be notified I missed a call for now?

Thanks so much for your hard work

chatty 0.6.0-beta wasn’t working well for me. The screen would come up, but it would crash after a few seconds. I tried gsettings set sm.puri.Chatty experimental-features false, but that had no effect.

I ended up downgrading to 0.5.0-beta4 from a prior install.
sudo pacman -U /var/cache/pacman/pkg/chatty-0.5.0beta4+5+g8ae677d-1-aarch64.pkg.tar.zst . After recovering the chat history by stripping the x’s off of ~/.purple/chatty/db/chatty-history.db.xxxxxxx, things went back to normal.

Those apps are probably broken because Manjaro unfortunately ships phoc with a patch that updates wlroots to 0.15 and this seems to break the wayland backend for qt apps (which at least Telegram is and the other apps you mention too I think). That patch is not yet merged upstream, so Manjaro should drop that patch until it properly works. I reported this here. Easiest way to get around this for now is to downgrade phoc to phoc-0.11.0+28+gf4f80af-1. You could probably also edit the PKGBUILD and drop the patch yourself to get a most recent working version.

Just got the PinePhone Pro delivered and using Manjaro Phosh beta 21 (on internal storage) and though most of the experience is smooth, the lockscreen and app launcher (when scrolling) stutter quite badly when using a wallpaper that is as low a resolution as 640x960.

Also, I’m curious if you know of a way to switch to x11 on the device instead of Wayland?
I’d like to see if the stutter goes away in x11, also I would like to try to run the software ‘Synergy’, but it only works with x11.

I have the same Problem qt apps are simply unusable right now. Can you tell me, where you find the earlier package version of phoc. i do not have it in my local directory.

Thanks for your reply and the details. I hope this will get merged soon. I cant find the version on my phone, same as Planter. Not sure if there is another way to downgrade.

reported issues should been fixed via [manjaro-packages] [BoxIt] Memo (ARM)


Thank you Philip for the quick fix! :raised_hands:

There seems to be an incompatibility between this build and manjaro-arm-flasher. I use etcher to flash PHOSH on my SD card, and then use manjaro-arm-flasher from there to flash PLASMA updates to the eMMC. Below are the details I initially logged in the PLASMA thread; not the best place in hindsight.

EDIT: Applied a few updates today (including phoc/phosh) hoping it might help my issue, but manjaro-arm-flasher aborted with the same details when run from the terminal; including after a reboot and after reinstalling manjaro-arm-flasher (via pamac GUI).

Of you want to flash an image to the eMMC you may use gnome disks, which should work.


Thank you @philm, that worked very well!

First time I used Gnome Disks to “recover an image to disk”, and its “expand disk” after restore was super fast; much faster than KDE Partition Manager on my desktop.

1 Like

Is waydroid broken for anyone else? Trying to start it flushes dmesg with error messages.