Manjaro ARM 21.04 released!

As usual updated GNOME and Sway images for community supported devices can be found here: Manjaro-ARM Community · GitHub


does sway profile update? 1.6 released few days ago.

As it was just released 4 days ago I doubt it hit the stable repos by now…

Thanks for your hard work!

1 Like

It seems that the correct name is manjaro-arm-installer, couldn’t find “flasher” in the repos.

Flasher is only in the ARM repos.

Ok, that explains it.

how do i build sway image for n2?

  1. Install manjaro-arm-tools.
  2. Reboot.
  3. Run sudo getarmprofiles.
  4. Run sudo buildarmimg -d on2 -e sway
  5. Wait until it finishes.
  6. You now have a Sway image for the Odroid N2 in your /var/cache/manjaro-arm-tools/img/ folder.

I haven’t had received any feedback for devices beyond the Pinebooks and Raspberry Pis so far, but if we can get it working on your device properly I would be glad to update the ManjaroARM Community build bots to also build images for the n2/n2+ in the future…

1 Like

Just dusted off my sons unused pi4 and decided to give kde a spin on it. Really impressed with how well it runs. Gone straight onto unstable, and happy to test anything anytime it’s needed


have a look here, how to build your own Manjaro

[Wiki] How to contribute to Manjaro ARM

fresh install sway-rpi4-20210424, every disappear but wallpaper on screen.

its an issue in bluetooth module of waybar: [ARM Stable Update] 2021-04-27 - Firefox, KDE Frameworks, RPI Imager, Uboots and Kernels - #13 by appelgriebsch

workaround: open .config/waybar/config and comment the line for bluetooth module

30 │ // "bluetooth",

1 Like

Hi Strit!

Thanks for working on Manjaro ARM!

By using the meson-sm1-sei610.dtb, I am able to boot the vim3 20.12 Manjaro ARM images on my T95 Max Plus but I am not able to boot the 21.04 images. What has changed since? There seems to be some new boot splash or something?

Do you have any plans to support any TV boxes? Even if you don’t, it would be great if you could make a couple of small additions to the vim3 kernel build so that it could support some TV boxes like mine better.

Coreelec say my box should be using sm1_s905x3_4g.dtb but this seems to be missing from the vim3 kernel packages so it would be cool to see that as an option and I’d also like to be able to use the LED panel either as a clock or to show the CPU temp during builds. Android dmesg on my T95 MP tells me it uses the fd655 kernel module for this but I’m not sure that is a thing in vanilla Linux so we might need to add this:

I’ve kinda got the onboard wifi working already but slowly as Manjaro thinks my wifi is a brcmfmac4330 but according to Android I should be using the broadcom 40183b2 driver / firmware. It would be great to see that packaged with the vim3 kernel too, if there are no legal issues in doing so.

Hi again!

The T95 MAX Plus started to reset whenever I connected a USB device less than a week after I got it so I sent that back and got a X96 Air which is another S905X3 based TV box but, despite actually being slightly cheaper, this has more ports (1 extra USB 2 and optical audio) and is better build quality. The included Android is infinitely better than the one on the T95 MAX Plus and I was able to boot the vim3 MATE 21.04 image using meson-sm1-sei610.dtb, unlike on the T95MP where I had to revert to 20.12.

I’ve not tried any alternate dtbs yet but with meson-sm1-sei610.dtb the wifi works great (MUCH better than on the T95MP) but the ethernet does not and nor does analogue audio, although I’ve yet to have a proper go at fixing that.

take a look:

Installing Manjaro Arm on X96 Air P3 TV Box - ARM / Technical Assistance - Manjaro Linux Forum

1 Like

Hi Tiber

Yes, I have seen that thread. I have downloaded the latest LibreELEC AMLGX ‘box’ image but it contains roughly the same (number of) dtbs that are included with linux-aml and doesn’t have one for sm1_ac213_4g.

I have another thread on this forum that I created yesterday where I asked if anyone has tried building the CoreELEC / amlogic kernel and using it under Manjaro? It is quite old now, 4.9.x, and I expect its dts files won’t be of much use to a 5.x mainline kernel but I don’t really know anything about dts and how much it has changed over the last 4 years or whatever. That kernel does have a dts for my box, an X96 Air Q1000 / sm1_ac213_4g.

1 Like

I start my X96AIR-box as described here:

use these files as mentioned:

Try it.

Forget CE, they use newest Kernel 4.9 from may 21, but the used .dtb do have another structure.