Manjaro ARM 20.08 released!

Manjaro ARM 20.08 released!

We are proud to announce the release of Manjaro ARM 20.08!

Currently we have download images for: Raspberry Pi 4, Rock Pi 4B, RockPro64, Khadas Vim 1, Khadas Vim 2, Pinebook and the Pinebook Pro.

Manjaro ARM is proud to also now be the default installation on the Pinebook Pro from Pine64.
We have put in a lot of work to get to this point and we are excited that we have been accepted by the creators of this laptop, as a great OS option.

New application for flashing images

We have been working on a new GUI app to make it easy for users to flash a Manjaro ARM image on to an SD card or eMMC card.
Simply install manjaro-arm-flasher and launch the app “Manjaro ARM Flasher” from your menu. This will download and flash the image of your choice.
You can also manually run the application (if you are not running Manjaro ARM) by downloading this python script, make it executable with chmod +x manjaro-arm-flasher and then run it with sudo ./manjaro-arm-flasher. It requires python-blkinfo 0.1.3 to be installed, which can be installed with pip install blkinfo.
This software is still in early development and does not include all the features we want yet.

First Time setup

This release sports the First Time setup for all images, also via SSH. This means that at first boot, you will be asked about the following:

  • keyboard layout (except on pinebook, that is fixed to us layout)
  • username
  • additional user groups (optional)
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • hostname

Then the setup script will set these settings and reboot to the login screen.



KDE Plasma




Device XFCE KDE Plasma i3 Sway
Raspberry Pi 4 20.08 20.08 20.08 20.08
Pinebook Pro 20.08 20.08 20.08 20.08
Pinebook 20.08 20.08 20.08 20.08
Rock Pi 4B 20.08 20.08 20.08 20.08
RockPro64 20.08 20.08 20.08 20.08
Khadas Vim 1 20.08 20.08 20.08 20.08
Khadas Vim 2 20.08 20.08 20.08 20.08

Torrents are also available!


  • New packages from upstream and Manjaro ARM.
  • Manjaro now uses a branch based repo structure. Meaning you can now switch between arm-stable, arm-testing and arm-unstable branches by editing /etc/pacman-mirrors.conf.
  • All new images now use a 2 partition layout and use extlinux.conf where applicable. Devices not using extlinux are Raspberry Pi 4, Odroid N2 and Khadas devices.
  • Introducing the manjaro-arm-flasher tool, which can be used to download and flash an image to any drive.
  • Added back logout confirmation in Plasma.
  • XFCE 4.14
  • KDE Plasma 5.19
  • The Raspberry Pi images can now also be booted from USB Sticks, if you have updated your EEPROM to the latest release.
  • Added Odroid N2+ to our device line-up. Be aware that the N2 and N2+ uses different images. The N2+ can run the N2 images without issues, but the N2 cannot run the N2+ images.
  • Added Rock Pi 4C to our device line-up. Be aware that the 4B and 4C uses different images.

Updating from 20.06:

  • Enabled Logout Confirmation in Plasma settings.

Known issues:

  • No audio cards on Odroid C2, Odroid C4, Odroid N2(+), Khadas Vim 3 and Roc-CC.
  • Bootsplash does not work on Raspberry Pi devices.
  • Lid Close trigger on the Pinebook Pro does not work on the XFCE edition.

Supported Devices:


  • Khadas Vim 1 (maintained by @spikerguy)
  • Khadas Vim 2 (maintained by @spikerguy)
  • Pinebook
  • Pinebook Pro
  • Raspberry Pi 4 (tested on B)
  • Rock Pi 4B
  • RockPro64

With Manjaro ARM Installer (in addition to the above devices): (Download it here)

  • Khadas Vim 3
  • Khadas Edge-V Pro
  • LibreComputer ROC-RK3328-CC
  • Odroid C2
  • Odroid C4
  • Odroid N2
  • Odroid N2+
  • Pine64-LTS
  • Pine64+
  • Pine-H64
  • Raspberry Pi 3 (tested on B)
  • Rock64
  • Rock Pi 4C

What about other devices?

Manjaro ARM no longer supports the armv7h architecture. So if you have/use an armv7h device, you should be looking at other distro’s. Some could be:

  • Arch Linux ARM
  • Armbian
  • Raspbian (for the raspberrypi)
  • Ubuntu Mate
  • Parabola

The armv7h repo has been removed from the repo server and mirrors.

We won’t be making images for all the supported devices. If your desired image for your desired supported device does not exist, please use manjaro-arm-installer to install it to an SD/eMMC card.

We already started releasing Alpha images for the PinePhone and PineTab.


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


So to install onto a PBP EMMC I would flash any recent image to an SD card, Boot from the SD card, install and run the installer script, and select the image and EMMC device to install on. Is that the correct way to install a new image?

The 20.08 image will be available in the Manjaro ARM Flasher tool soon. I just need to get the last couple of images done. :stuck_out_tongue:

1 Like

Dumb question but my 20.06 installation should pickup the 20.08 changes through the updater, correct?

1 Like

Is it sway/wlroots patched to use two monitors in this release? See failed assertion on rbp4 with multiple monitors · Issue #1943 · swaywm/wlroots · GitHub

We use upstream packages from Arch Linux ARM. So I would guess, no.

1 Like

How can I get my hands on the sway theme? I upgraded from 20.06 and had previously installed sway manually.

The default configuration is part of this gitlab repo: overlays/sway/etc · master · manjaro-arm / applications / arm-profiles · GitLab.

You will need to check the files in /etc/sway as well as /etc/skel/.config to get the same look and feel. There is a in /etc/skel that describes the configuration a bit.

EDIT: depending on your installation you will need to add additional packages for it to work - mainly: mako, wofi, wlogout and waybar

1 Like

The vim in this version is built with lua5.3, but lua has been updated to version 5.4, which will cause SpaceVim errors.
Please replace vim with a version built on lua5.4.
This is the text translated by Google Translate. There may be grammatical errors. Please understand.

vim is a package we get from Arch Linux ARM, and it’s not been updated there in about 2 months.

Arch Linux ARM uses the PKGBUILD from Arch Linux, which has been flagged out of date for over 2 months.

alright, I got it.
I tried to build vim a few days ago, but there are still some minor problems.
Anyway, thank you for your answers.
Have good day。

I have another question, why not integrate Chinese fonts in the system?
When the current system is opened for the first time, the Chinese text is a square, and it returns to normal after installing the wqy-microhei font. Why not integrate wqy-microhei in it?
Solving this problem will help the spread of manjaro-arm.

I never heard of this font. Does it work by default if you just install the package, without changing settings?

Yes, run pacman -S wqy-microhei in the terminal to install the font. After installation, reboot Raspberry Pi to display Chinese correctly.

1 Like

Nice. I will add it to all the DE profiles. :slight_smile:



The trim is active on the odroid c4 external storage and the emmc module, nice.
Not tested with a sd card.
Is the trim function something to do with the kernel ?

[nlc4@c4 ~]$ systemctl status fstrim.timer
● fstrim.timer - Discard unused blocks once a week
     Loaded: loaded (/usr/lib/systemd/system/fstrim.timer; enabled; vendor preset: disabled)
     Active: active (waiting) since Sun 2020-08-23 13:09:55 CEST; 24h ago
    Trigger: Mon 2020-08-31 00:48:38 CEST; 6 days left
   Triggers: ● fstrim.service
       Docs: man:fstrim

août 23 13:09:55 c4.test.2020.05.14 systemd[1]: Started Discard unused blocks once a week.
[nlc4@c4 ~]$ lsblk --discard
sda                 0        4K       4G         0
└─sda1              0        4K       4G         0
mmcblk0             0        4M    49,5M         0
├─mmcblk0p1   1554432        4M    49,5M         0
└─mmcblk0p2   4046336        4M    49,5M         0
mmcblk0boot0        0        4M    49,5M         0
mmcblk0boot1        0        4M    49,5M         0
zram0               0        4K       2T        
[nlc4@c4 ~]$ uname -a
Linux c4.test.2020.05.14 5.8.3-2-MANJARO-ARM #1 SMP Sat Aug 22 21:00:07 CEST 2020 aarch64 GNU/Linux
[nlc4@c4 ~]$ 

stop in reached target bluetooth and stop :frowning: in manjaro KDE and XFCE
Why Why WHy??? Raspberry Pi 4 8BG Ram all ok boot but stop after line reached target bluetooth.

I get black screen upon reboot on the Pinebook Pro. Ran the commands to update uboot (after identifying the correct drive via lsblk), then rebooted the laptop. When the power LED turns green the screen just stays black. Just downloaded a fresh copy of Manjaro 20.06 and tried updating… same outcome.

Hm. Double check your /boo/extlinux/extlinux.conf file to make sure it is correct.

I had a message about that during installation… I think


sudo mv /boot/extlinux/extlinux.conf.pacnew /boot/extlinux/extlinux.conf