Manjaro-architect is not working

Hi there.

Just got the manjaro architect iso to install ( manjaro-architect-20.0.3-200607-linux56.iso ) and I’m having some issues.

I enter with manjaro/manjaro credentials, run setup and I get a “manjaro-architect: command not found” message.
I tried to use pacman to install or update, but I get errors on gpg keys.
I tried several things I found online ( with the hkp or hkps keyserver ) but nothing works.
Always getting errors.

Any idea what’s wrong here?

most troubleshooting I see, suggest to install archlinux-keyring, but that fails as well

I’m out of ideas really.

@antouank You use an outdated mirror while the updates got mirrored. Choose another updated mirror before running setup.

For example:

sudo pacman-mirrors -c Germany

I have no problems here.

thanks for the reply.

I restarted, run the command to update mirrors, then run setup, and I get this.

slightly different errors now if I try to get the archlinux-keyring

Please post text instead of a picture.

I’d love to, but I’m trying to install it on a laptop. I cannot get the terminal contents on text.

You can use manjaro-architect on any Manjaro edition, don’t need to limit yourself to a CLI only system like the Manjaro Architect Edition ISO. (Unless your GPU doesn’t work.)

However… that is strange now after ~5 times rebooting and running setup again… i get the same error. Weird… The setup sucks at appending archlinux gpg-keys… Next run, it works again…

my use-case : I have an old laptop, I want to connect 2-3 usb cameras on it, and run motioneye os in docker to act as cctv ( and I want a couple of docker containers to do some nginx proxy ).

I don’t need any graphical interface, the laptop will be with the lid closed most of the time.
So CLI is perfect, and it saves resources.

Any alternative I can use? I love manjaro, I’d like to use a CLI version of it.
Should I go for i3 instead?

1 Like

@antouank What @eugen-b means is that on every desktop version is a the same CLI “Manjaro Architect” installed. Therefore it is easier to share text in the terminal. You can install with Manjaro-Architect on any desktop version. “Manjaro Architect”-Version is just only CLI.

1 Like

bit confused.

so should I get another ISO, let’s say XFCE, so on the live boot I can start a terminal and run “manjaro-architect” from there? to share the text content?
but will I be able to install a CLI only version on the laptop if I get an XFCE ISO?

Yes… Since the “Architect” is just a script, it works on any version and yes it is preinstalled on any ISO. There is a desktop shortcut with the name “Manjaro Architect”.


Yes, or you can even run manjaro-architect from an installed system and thus use the already downloaded packages from /var/cache/pacman/pkg

1 Like

that worked, I can launch the architect now! thank you

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.