manjaro architect do not starting

Hi Guys!

It's horrible!!
I have installed an architect manjaro at the first time.
But it do not want to start!
I know to create an efi entry like

sudo efibootmgr --create --disk /dev/sda --part 1 --label "Precise - GRUB2" --loader \EFI\ubuntu\grubx64.efi

but i never can read anywhere
how to look the directory infrastructure of /dev/sda1

ofthe I read the name from gohlib,
and he want fallow infos

#$ sudo efibootmgr -v
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0003,0000,0004,0001
Boot0000  Windows Boot Manager	HD(1,GPT,c8af238a-03e3-4c8f-a54d-fd46dc72b7c3,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...9................
Boot0001  UEFI: Built-in EFI Shell	VenMedia(5023b95c-db26-429b-a648-bd47664c8012)..BO
Boot0003* Linux Boot Manager	HD(1,GPT,c8af238a-03e3-4c8f-a54d-fd46dc72b7c3,0x800,0x32000)/File(\EFI\SYSTEMD\SYSTEMD-BOOTX64.EFI)
Boot0004  Android-IA	HD(1,GPT,c8af238a-03e3-4c8f-a54d-fd46dc72b7c3,0x800,0x32000)/File(\EFI\BOOT\BOOTX64.EFI)
Boot0005* UEFI: Imation Nano Pro PMAP, Partition 1	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x0,0x132980,0x2000)..BO




#$ sudo parted -l
Modell: Imation Nano Pro (scsi)
Festplatte  /dev/sda:  8015MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags: 

Nummer  Anfang  Ende   Größe   Typ      Dateisystem  Flags
 2      643MB   647MB  4194kB  primary               esp


Modell: MMC HCG8a4 (sd/mmc)
Festplatte  /dev/mmcblk0:  62,5GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags: 

Nummer  Anfang  Ende    Größe   Dateisystem     Name                  Flags
 1      1049kB  106MB   105MB   fat32           EFI system partition  boot, esp
 2      106MB   8696MB  8590MB  linux-swap(v1)
 4      8696MB  62,5GB  53,8GB


Fehler: /dev/mmcblk0boot0: unbekannte Partitionstabelle

                                                                          
Modell: Generisch SD/MMC-Speicherkarte (sd/mmc)
Festplatte  /dev/mmcblk0boot0:  4194kB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: unknown
Disk-Flags: 

Fehler: /dev/mmcblk0boot1: unbekannte Partitionstabelle

                                                                          
Modell: Generisch SD/MMC-Speicherkarte (sd/mmc)
Festplatte  /dev/mmcblk0boot1:  4194kB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: unknown
Disk-Flags: 




#$ sudo blkid
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/mmcblk0p1: UUID="F1A3-DDA4" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="c8af238a-03e3-4c8f-a54d-fd46dc72b7c3"
/dev/mmcblk0p2: UUID="acf1c1f5-034e-42ef-bf80-c3306e2bd523" TYPE="swap" PARTUUID="c4c50ac7-f3f6-1541-a188-7893e353fd59"
/dev/mmcblk0p4: UUID="I8iXLe-EicN-LJYW-ufiu-gouV-Sjuf-PMmfvk" TYPE="LVM2_member" PARTUUID="e157afe9-0cb6-1242-92cf-a84f64a312d6"
/dev/sda1: UUID="2019-08-06-08-59-55-00" LABEL="MJRO1804" TYPE="iso9660"
/dev/sda2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="0D1C-C256" TYPE="vfat"
/dev/mapper/LVM_part-lvol_root: UUID="2c2dd41e-fedb-4db9-9547-e6393e164dfc" TYPE="ext4"
/dev/mapper/LVM_part-lvol_home: UUID="b5a7b512-5164-4276-8385-f4da498f759b" TYPE="ext4"
/dev/mapper/LVM_part-lvol_data: UUID="cafc84ee-3804-4836-bffa-3a57577ba01b" UUID_SUB="2c5438b5-b961-44da-8923-80b69fa73122" TYPE="btrfs"





#$ findmnt -s
TARGET SOURCE                 FSTYPE OPTIONS
/      /dev/mapper/root-image auto   defaults




#$ df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
dev             1,9G       0  1,9G    0% /dev
run             1,9G     92M  1,8G    5% /run
/dev/sda1       614M    614M     0  100% /run/miso/bootmnt
cowspace        256M       0  256M    0% /run/miso/cowspace
overlay_root    2,9G     23M  2,9G    1% /run/miso/overlay_root
/dev/loop0       53M     53M     0  100% /run/miso/sfs/livefs
/dev/loop1      501M    501M     0  100% /run/miso/sfs/rootfs
overlay         2,9G     23M  2,9G    1% /
tmpfs           1,9G       0  1,9G    0% /dev/shm
tmpfs           1,9G       0  1,9G    0% /sys/fs/cgroup
tmpfs           1,9G     12K  1,9G    1% /tmp
tmpfs           1,9G    1,8M  1,9G    1% /etc/pacman.d/gnupg
tmpfs           387M       0  387M    0% /run/user/1000
/dev/sda2       4,0M    136K  3,9M    4% /mnt/sda2





#$ findmnt -s
TARGET            SOURCE    FSTYPE  OPTIONS
/run/miso/bootmnt /dev/sda1 iso9660 ro,relatime,nojoliet,check=s,map=n,blocksize=2048


#$ findmnt /mnt/sda2 
TARGET    SOURCE    FSTYPE OPTIONS
/mnt/sda2 /dev/sda2 vfat   rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro




#$ ls -l /mnt/sda2/efi/
insgesamt 2
drwxr-xr-x 2 root root 2048  6. Aug 10:56 boot

#$ ls -l /mnt/sda2/efi/boot/bootx64.efi
insgesamt 1
-rwxr-xr-x 1 root root 135168  6. Aug 10:56 bootx64.efi
 
#$ ls -l /run/miso/bootmnt/
insgesamt 4104
dr-xr-xr-x 1 root root    2048  6. Aug 10:56 boote[0m
-r--r--r-- 1 root root    2048  6. Aug 10:59 boot.catalog
dr-xr-xr-x 1 root root    2048  6. Aug 10:56 efi
-r--r--r-- 1 root root 4194304  6. Aug 10:56 efi.img
dr-xr-xr-x 1 root root    2048  6. Aug 10:56 manjaro

I hope anybody can help me!?
THX
alex

Hi

I have had lots of problem making Installation/Architect work properly. But the effort is worth it as Manjaro is so lean. It comes down to ONE simple thing in all my cases. btw I use i3 with LARBS addon (thanks Luke) on sddm as of tradition.

There are som trouble before one reaches full function. I have done it a couple of times and each time I get to the same one conclusion (number 1 below).

  1. Default desktop manager "LIghtDM" does not function to my likings. After install complete and system rebooted (when it goes blank and blinking) enter tty2 (alt+F2) and log in as root. Stop and Disable lightdm (systemctl stop lightdm AND systemctl disable lightdm). Install, enable and start sddm (pacman -Suuyy sddm AND systemctl enable sddm AND systemctl start sddm)
    That made my day.

  2. This is more hints to Manjaro developpers:
    a. speed up mirror list ranking by have optional flag -t and -f (pacman-mirrors -f 15 -t 1 as example)
    (question: if I run above command in shell does this mean I need not run it through setup?)
    b. make not lightdm default in setup, but let choose among options.
    c. include possibility to unmount in case one gets the message "partitions must be mounted first" (that happens often when for example when one has already mounted vfat efi and the goes "done" and setup asks for UEFI place)
    d. I have tried to place manjaro on GPT but it seems dos is preferred (?)
    e. if formatting tools only GPT/UEFI is not recommended than take them away.

HI buddy, does the manjaro on GPT working as per now? For me not yet!

Regards,
Sere Smith https://dltutuapp.com/tutuapp-download/ | https://kodi.software/

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by