Manjaro 23 Randomly reboots or freezes

My new Asus Zephyrus G15 randomly reboots when locked and sometimes freezes during normal use previously my second NVME used to randomly disappear but that has been fixed with a bios update hopefully
I use Manjaro 23 KDE Kernel 6.5.5-1
My laptop is Asus ZEPHYRUS G15 with AMD CPU and NVIDIA GPU
The driver installed is vedio-hybrid-amd-nvidia-prime, video-linux, video-modset & video-vesa
with ROG-Control-Center
before that, I tried Bumblebee but it only showed NVIDIA driver, not the hybrid, and the problem hasn’t been affected
Although I tried Manjaro 22 before same issues

Please Help

Hi @zeph, and welcome!

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Please also note and heed: Forum Rules - Manjaro

Hope you manage!


:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

```
pasted text
```

Or three (3) tilde signs, like this:

~~~
pasted text
~~~

This will just cause it to be rendered like this:

Portaest sed
elementum
cursus nisl nisi
hendrerit ac quis
sit
adipiscing
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.


:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

1 Like

ok
can anyone assist me with my issue?

you should remove this…


provide system info as instructed in mirdarthos post…

1 Like
mhwd -l -d                                                                                     ✔ 
--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:01.1/0000:01:00.0 (0300:10de:2520)
  Display controller nVidia Corporation GA106M [GeForce RTX 3060 Mobile / Max-Q]
--------------------------------------------------------------------------------
  > INSTALLED:

   NAME:        video-hybrid-amd-nvidia-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    8
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 



  > AVAILABLE:

   NAME:        video-hybrid-amd-nvidia-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    8
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-hybrid-amd-nvidia-470xx-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    7
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-nvidia
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Closed source NVIDIA drivers for linux.
   PRIORITY:    5
   FREEDRIVER:  false
   DEPENDS:     -
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 
   VENDORIDS:   10de 

   NAME:        video-nvidia-470xx
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Closed source NVIDIA drivers for linux.
   PRIORITY:    4
   FREEDRIVER:  false
   DEPENDS:     -
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 
   VENDORIDS:   10de 

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 

   NAME:        video-modesetting
   ATTACHED:    PCI
   VERSION:     2020.01.13
   INFO:        X.org modesetting video driver.
   PRIORITY:    1
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 

   NAME:        video-vesa
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        X.org vesa video driver.
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 


--------------------------------------------------------------------------------
> PCI Device: /devices/pci0000:00/0000:00:08.1/0000:07:00.0 (0300:1002:1681)
  Display controller ATI Technologies Inc 
--------------------------------------------------------------------------------
  > INSTALLED:

   NAME:        video-hybrid-amd-nvidia-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    8
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 



  > AVAILABLE:

   NAME:        video-hybrid-amd-nvidia-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    8
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-hybrid-amd-nvidia-470xx-prime
   ATTACHED:    PCI
   VERSION:     2023.03.23
   INFO:        Hybrid prime solution for NVIDIA Optimus Technology - Closed source NVIDIA driver & open source amd driver.
   PRIORITY:    7
   FREEDRIVER:  false
   DEPENDS:     video-linux 
   CONFLICTS:   video*nvidia* 
   CLASSIDS:    0300 0302 0300 
   VENDORIDS:   10de 1002 

   NAME:        video-linux
   ATTACHED:    PCI
   VERSION:     2018.05.04
   INFO:        Standard open source drivers.
   PRIORITY:    2
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 0380 0302 
   VENDORIDS:   1002 8086 10de 

   NAME:        video-modesetting
   ATTACHED:    PCI
   VERSION:     2020.01.13
   INFO:        X.org modesetting video driver.
   PRIORITY:    1
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 

   NAME:        video-vesa
   ATTACHED:    PCI
   VERSION:     2017.03.12
   INFO:        X.org vesa video driver.
   PRIORITY:    0
   FREEDRIVER:  true
   DEPENDS:     -
   CONFLICTS:   -
   CLASSIDS:    0300 
   VENDORIDS:   * 


Warning: no configs for USB devices found!

Please guide me on what more info you need exactly.

This at least:

inxi -Fazy

And maybe also this:

sudo dmesg | grep -i error

And I’m already thinking its maybe this:

https://wiki.archlinux.org/title/Ryzen#Random_reboots

and this:

https://wiki.archlinux.org/title/Ryzen#Soft_lock_freezing

He did:

Said post:

inxi --full --admin --filter --width                                                           ✔ 
System:
  Kernel: 6.5.5-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.5-x86_64
    root=UUID=a1ce8ef0-89fe-4391-930e-d7de80c4b5fb rw quiet splash
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ROG Zephyrus G15 GA503RM_GA503RM v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: GA503RM v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: GA503RM.315 date: 07/31/2023
Battery:
  ID-1: BAT1 charge: 79.3 Wh (99.0%) condition: 80.1/90.2 Wh (88.8%)
    volts: 17.1 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S
    serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: AMD Ryzen 7 6800HS with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404101
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 1389 high: 2755 min/max: 400/4785 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 1534 2: 1504 3: 400
    4: 400 5: 2006 6: 1828 7: 400 8: 1639 9: 1406 10: 2004 11: 2246 12: 400
    13: 1685 14: 2755 15: 1620 16: 400 bogomips: 102243
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-23 pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 ports: active: none empty: DP-9,HDMI-A-1,eDP-2
    bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-2: AMD Rembrandt [Radeon 680M] vendor: ASUSTeK driver: amdgpu
    v: kernel arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22
    pcie: gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, DP-5, DP-6, DP-7, DP-8 bus-ID: 07:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 56.0 C
  Device-3: IMC Networks USB2.0 HD UVC WebCam driver: uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 13d3:56eb
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: amdgpu,nvidia
    unloaded: fbdev,modesetting,nouveau,radeon alternate: nv,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.65x15.00")
    s-diag: 777mm (30.58")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x1540 built: 2020
    res: 2560x1440 hz: 165 dpi: 189 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: max: 2560x1440 min: 640x480
  API: EGL v: 1.5 hw: drv: nvidia drv: amd radeonsi platforms: device: 0
    drv: nvidia device: 1 drv: radeonsi device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: radeonsi inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: amd mesa v: 23.1.8-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (rembrandt LLVM
    16.0.6 DRM 3.54 6.5.5-1-MANJARO) device-ID: 1002:1681 memory: 500 MiB
    unified: no
  API: Vulkan v: 1.3.264 layers: 8 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3060 Laptop GPU driver: nvidia v: 535.113.01
    device-ID: 10de:2520 surfaces: xcb,xlib device: 1 type: integrated-gpu
    name: AMD Radeon Graphics (RADV REMBRANDT) driver: mesa radv
    v: 23.1.8-manjaro1.1 device-ID: 1002:1681 surfaces: xcb,xlib
Audio:
  Device-1: NVIDIA GA106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 8
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-2: AMD Rembrandt Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 07:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: ASUSTeK
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt pcie: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 07:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 07:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.5.5-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.80 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-4: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
Network:
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 port: e000 bus-ID: 03:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: MEDIATEK MT7922 802.11ax PCI Express Wireless Network Adapter
    vendor: Foxconn driver: mt7921e v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 14c3:0616 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
Bluetooth:
  Device-1: Foxconn / Hon Hai Wireless_Device driver: btusb v: 0.8 type: USB
    rev: 2.1 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-3:3 chip-ID: 0489:e0e2
    class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Drives:
  Local Storage: total: 2.75 TiB used: 957.89 GiB (34.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:6 vendor: Western Digital model: WD PC
    SN735 SDBPNHH-1T00-1002 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 70626000 temp: 54.9 C scheme: MBR
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 2B2QEXM7 temp: 53.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 290.6 GiB size: 284.98 GiB (98.06%)
    used: 103.12 GiB (36.2%) fs: ext4 dev: /dev/nvme1n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 610 MiB size: 608.8 MiB (99.80%)
    used: 288 KiB (0.0%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 9.98 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme1n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 64.0 C mobo: N/A gpu: amdgpu temp: 58.0 C
  Fan Speeds (rpm): cpu: 1700
Info:
  Processes: 364 Uptime: 2h 35m wakeups: 9 Memory: total: 16 GiB note: est.
  available: 14.87 GiB used: 5.7 GiB (38.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1586 pm: pacman pkgs: 1542 libs: 487 tools: pamac,yay pm: flatpak
  pkgs: 44 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.30

is that ok?

It’s still not everything asked:

Start reading, friend. You’ll find people much more willing to help, if you do your part. If, for whatever reason, you have difficulty doing so, explain that. People willing to help are also usually more understanding than not.

Edit:

Work through this thread:

Considering you also have an AMD CPU, it might be related, if not the same thing.

I applied your suggestion by “disabling C6” and it will take a couple of days of testing to confirm if there are no more crashes.
But anyway thank you for being patient with me and my ignorance of community roles.

1 Like

You’re welcome!

I suspect you mean rules, not roles. And ignorance can be rectified with education, a willingness to learn, not thinking you know everything and everyone is supposed to bow to your will. So these should help:

Yeah “rules” is my mistake, but “everyone is supposed to bow to your will” Is that a sarcastic way of telling me to read the rules?

Nope, but if the shoe fits…

:stuck_out_tongue_winking_eye:

I meant that that is the attitude by some people, whether online or IRL. They are just entitled.

2 Likes