I've almost gone crazy with the system random freezes!

I was having very similar issues on my system. I ran a memory test using a bootable USB drive and found all sorts of errors in the memory. Shutting down the system, removing the memory and reinstalling the memory fixed the issue.

May or may not help in your case, but you can try it and see what happens.

This :point_up: sounds like an excellent plan. If you do, make :100: sure that the contacts are clean.

Also, the log are spammed with:

ACPI group/action undefined: button/right / RIGHT

And I don’t know if it’ll make any difference, but at this time, I’m guessing you’re willing to try it, and it doesn’t seem like it could hurt. So try Disabling the key events as per below:



I also see many qbittorrent entries in the logs, so I’ve got to ask: does the problems occur if qbittorrent isn’t running?

Edit #2:

I also noticed this error:

10月 07 21:32:37 ling-20ym kded5[1262]: Service  ":1.81" unregistered

a Bit of searching for it led to this page, where the last post states:

Downgrade to 5.14.16 and then no issue remains.

So, I guess try with an older kernel?

For 5.10:

sudo mhwd-kernel --install linux510

It’s SLTS, so still good until January 2031.

I’m also burning to use the latest, but forced to stick to 6.1, because my PC doesn’t wake fro suspend on anything newer. So I’ll continue to test newer versions, but I’m OK for now.

I have noticed that there is a test mode in my boot menu, so I gave it a try. Here are the results of the test:

Memory testing seems fine, but I’ll still try reseating the memory when I get home. Thank you very much for your advice!

Thank you very much for your efforts to help me resolve my issue! I will try each of the solutions you provided.

I have now disabled ACPI’s recognition of the arrow keys. However, I haven’t been able to close qbittorrent yet. After that, I will try not using qbittorrent and see if the system still freezes.

Regarding the issue of downgrading the Linux kernel, I need to provide some additional information:

  1. In fact, I installed Manjaro when it was version 22, and at that time, the kernel should have been 5.x (I’m sorry, I can’t remember the exact kernel version). There were no options for power configuration back then (if I remember correctly, there was no option to choose between performance or power-saving modes).
  2. At that time, I also installed Optimus Manager to manage GPU switching because my laptop’s Type-C port is directly connected to the dedicated GPU. If I wanted to connect an external monitor, I had to use the dedicated GPU for video output. Since then, occasional freezes have occurred, but they were infrequent and rarely happened.
  3. This time, I reinstalled Manjaro (completely wiping the system), and during the installation process, I did not encounter this issue. Even when I was configuring some system software and KDE, it did not occur.

Oh, I have a new discovery. This link mentions a bug related to the C6 state of AMD’s Ryzen processors that can lead to freezes. This might help me solve the problem, and I will give it a try.

1 Like

I believe the issue should be resolved! When I disabled the C6 state of the Ryzen processor using this method, everything is working perfectly, and I feel incredibly comfortable. Just a day ago, I was even considering giving up on Linux! I’ll summarize the method as follows:

yay -S disable-c6-systemd
sudo modprobe msr

Then edit file: /etc/modules-load.d/modules.conf

sudo nano /etc/modules-load.d/modules.conf

Add the following line to the file:


Then reboot your computer, input the following cmd:

sudo systemctl enable disable-c6.service
sudo systemctl start disable-c6.service

If you see the following content in the Konsole output:
You should reinstall the software disable-c6-systemd
That all, hope this method can help you, who is tirelessly working in front of the screen!
This method comes from: Ryzen随机卡死问题
github for disable-c6


Odd that needs a package …






Though there is this:

So it seems possible that for some reason or another the package may be needed. Though I have not seen such an example, and the reference is a bit cryptic.

I think this may be because AMD’s default boot parameter support on Linux isn’t great… After all, this issue has been around for 6 years and still appears on the latest CPUs. So, the only option seems to be to disable the C6 state through a different method during boot. Given that someone has tried configuring this parameter without success, I will try it later today and observe if any issues arise. When I’m at home, this problem almost always occurs, but interestingly, it rarely happens when I bring the computer to the office. Perhaps it’s because the power consumption isn’t as “low” at the office. :upside_down_face:

I have not had to apply such fixes on my 5600u
Though I did take care to apply this:
(under “advanced” bios options that need to be unlocked as shown in the link)
Which is about not being able to enter sleep correctly, but I suppose it could have other implications.

I hava try to add processor.max_cstate=5 to GRUB_CMDLINE_LINUX, but it’s not useful. C6 is still enable.

When done, did you update initial ramdisk?

sudo mkinitcpio -P

And then update grub?

sudo update-grub

oh, I just run one of them

sudo update-grub

I will try another

like this:

# sudo zenstates -l                                                                                                                                                                            P0 - Enabled - FID = 80 - DID = 8 - VID = 35 - Ratio = 32.00 - vCore = 1.21875
P1 - Enabled - FID = 5B - DID = E - VID = 60 - Ratio = 13.00 - vCore = 0.95000
P2 - Enabled - FID = 60 - DID = 10 - VID = 66 - Ratio = 12.00 - vCore = 0.91250
P3 - Disabled
P4 - Disabled
P5 - Disabled
P6 - Disabled
P7 - Disabled
C6 State - Package - Enabled
C6 State - Core - Enabled
# history                                                                                                                                                                               
 1323  sudo mkinitcpio -P
 1324  sudo update-grub
 1329  sudo systemctl status disable-c6.service
 1330  sudo systemctl disable disable-c6.service
 1331  sudo zenstates -l

I think that method is really ineffective :upside_down_face:

Why? Seems fine for me. The systemd service should run at every boot, AFAIK:

sudo systemctl enable --now disable-c6.service

What I mean is that just configuring processor.max_cstate=5 does not work, but only using disable-c6.service does. So I turned off disable-c6.service in order to test processor.max_cstate=5.
Oh, by the way, after I executed sudo mkinitcpio -P, the startup screen was no longer the interface I configured. It was replaced by a small circle, but the shutdown interface still took effect. Is there a solution for this?

I honestly don’t know. a Better idea would be to ask on the forum.

If using only disable-c6.service works, then stick to it…

at least on my system i decided software was a bad way to do this since my b650 has an option to disable cstates in the power efficiency section, cheers

Was the point of your comment to encourage the OP to check his BIOS for a similar setting; as a possible workaround?

But unfortunately, my laptop’s bios does not have advanced functions and can only display some very low-level parts.

The likelihood of recent system freezes has reduced significantly, but it still occurs at night. It seems that disabling C6 through software during boot isn’t a complete solution.

Through some further searches, I found the following articles: ADM Ryzon processor random “freeze” issue, AMD Ryzen CPU random “freeze”, AMD Ryzen 2700X + CentOS 7 random freeze problem.

Based on various descriptions in those articles, the solution is as follows:

  1. If your BIOS supports disabling CPU power management, you should do so in the BIOS.
  2. Add idle=nomwait to the kernel parameters.
  3. Add processor.max_cstate=1 intel_idle.max_cstate=0 to the kernel parameters.
  4. After updating the kernel parameters, manually execute sudo update-grub to update the configuration.

You can check the max_cstate value with the following command before making changes; the value is 9 by default.

cat /sys/module/intel_idle/parameters/max_cstate

Modify the kernel boot parameters by using sudo nano /etc/default/grub.

You can view the kernel boot parameters using cat /proc/cmdline.

1 Like