Manjaro 21.07 live usb doesn't boot/System breaks after update

I have read some similar problems and the solutions that were provided either didn’t work or I couldn’t do what was mentioned so I thought it would be better if I started a new thread.
So, I tried to boot from the live usb using the 21.07 gnome version and while the initial options with the drivers and such appeared and after my selection the ‘‘checks’’ it usually does started, in the end it got stuck(Same thing happened with the 21.07 gnome minimal LTS kernet version). After that I tried the 21.07 kde plasma version which did the same thing. Then I went on to previous releases, specifically 20.2 gnome, which I was able to install just fine, but after updating the system it broke and couldn’t boot at all. Is there something I can do to make it work, or even updating from an older version without it breaking?
CPU:AMD Ryzen 7 1700
By the way, I’m new here and I can’t really do much without details.

inxi output(from gnome 20.2):

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=b984252e-e8bd-4dd4-a553-d55281b5f8c3 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: X370 Taichi serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P4.40 date: 02/07/2018 
  RAM: total: 15.63 GiB used: 1.43 GiB (9.1%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001129 
  L2 cache: 4096 KiB bogomips: 96024 
  Speed: 1498 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 
  1: 1697 2: 1779 3: 1338 4: 1277 5: 2565 6: 2578 7: 1279 8: 1279 9: 2563 
  10: 2866 11: 1278 12: 1278 13: 1278 14: 1278 15: 1278 16: 1278 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate irperf lahf_lm lbrv lm mca mce 
  misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt 
  nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI 
  driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 2d:00.0 
  chip ID: 10de:1c03 
  Display: x11 server: 1.20.10 compositor: gnome-shell driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 2d:00.1 chip ID: 10de:10f1 
  Device-2: AMD Family 17h HD Audio vendor: ASRock driver: snd_hda_intel 
  v: kernel bus ID: 2f:00.3 chip ID: 1022:1457 
  Device-3: Microsoft LifeCam VX-2000 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 3-4:4 chip ID: 045e:0761 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: e000 bus ID: 27:00.0 chip ID: 8086:24fb 
  IF: wlp39s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: kernel 
  port: d000 bus ID: 2a:00.0 chip ID: 8086:1539 
  IF: enp42s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Local Storage: total: 2.05 TiB used: 8.02 GiB (0.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M81000G size: 931.51 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: S5Z42105 scheme: MBR 
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
  ID-3: /dev/sdb vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 1B6Q scheme: GPT 
  Message: No Optical or Floppy data was found. 
  Message: No RAID data was found. 
  ID-1: / raw size: 931.51 GiB size: 915.89 GiB (98.32%) used: 8.02 GiB (0.9%) 
  fs: ext4 dev: /dev/nvme0n1p1 label: N/A 
  uuid: b984252e-e8bd-4dd4-a553-d55281b5f8c3 
  Alert: No Swap data was found. 
  ID-1: /dev/sda1 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-2: /dev/sda2 size: 701.50 GiB fs: ntfs label: 1TB Storage 
  uuid: B04863A2486365D6 
  ID-3: /dev/sdb1 size: 499.0 MiB fs: ntfs 
  label: \xce\x91\xce\xbd\xce\xac\xce\xba\xcf\x84\xce\xb7\xcf\x83\xce\xb7 
  uuid: 403AB4703AB46516 
  ID-4: /dev/sdb2 size: 99.0 MiB fs: vfat label: N/A uuid: DCB5-6A2D 
  ID-5: /dev/sdb3 size: 16.0 MiB fs: <superuser/root required> label: N/A 
  uuid: N/A 
  ID-6: /dev/sdb4 size: 232.29 GiB fs: ntfs label: N/A uuid: 9A60B82E60B812CD 
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 1-9:2 info: Intel Wireless-AC 3168 Bluetooth type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aa7 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
  Hub: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 1d6b:0002 
  Device-1: 3-2:2 info: Corsair CORSAIR M55 RGB PRO Gaming Mouse 
  type: Mouse,HID,Keyboard driver: hid-generic,usbhid interfaces: 4 rev: 2.0 
  speed: 12 Mb/s chip ID: 1b1c:1b70 serial: <filter> 
  Device-2: 3-3:3 info: China Resource Semico USB Keyboard 
  type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
  speed: 1.5 Mb/s chip ID: 1a2c:4b81 
  Device-3: 3-4:4 info: Microsoft LifeCam VX-2000 type: Video,Audio 
  driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s 
  chip ID: 045e:0761 
  Hub: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 
  System Temperatures: cpu: 43.0 C mobo: N/A gpu: nvidia temp: 52 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 363 Uptime: 4m Init: systemd v: 246 Compilers: gcc: N/A Packages: 
  pacman: 1156 lib: 312 flatpak: 0 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.08 

Thank you in advance for your responses!

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. Boot this version and give us an inxi --admin --verbosity=7 --filter --no-host --width as that would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.


Yeah, you have a Ryzen 7. Just wait a few days until Manjaro Pahvo 21.1 is released.


  • Install the Gnome 20.2 version without doing any updates
  • Install both kernels 5.10 LTS and 5.14 Stable
  • Reboot into one of those two (take the other one if the first doesn’t work)
  • Remove kernel 5.9
  • do the upgrades


1 Like

Well…that didn’t go so well :laughing:
The other kernels would get stuck during the boot(at least I think they did, waiting 5-10 minutes each time) and in the end I tried selecting the previous to boot and try something else but then this one wouldn’t boot either. I don’t thing I did something weird.
Anyway, thanks, I’ll wait for 21.1 and in the meantime I’ll play with this one a bit.

1 Like