Manjaro 20.2 gnome edition release candidate

New release incoming, please test.

New features in Gnome edition:

  • gnome 3.38
    • much improved application grid
    • performance enhancements
    • improved fingerprint support
    • some redesign in gnome application interfaces
  • New tiling options in gnome-layout-switcher
    • material-shell, touch friendly and efficient tiling interface
    • pop-shell, unintrusive and intuitive tiling system (enabled by default)
  • OEM-style installation with gnome-initial-setup. Installing Manjaro to your friends computer is easier than ever
  • improved terminal fonts (read: better icons in ranger and better looking powerline if you enable it)
  • improved bmenu for system management in terminal
  • plymouth for boot animation (optional graphical password dialogs coming later). Enabled only for installed system, live system still shows the console output.

Download you iso here:

8 Likes

Anyone else suffering from slow mirrors/slow pacman download speed? Getting around 50-80kbps and I have tried almost all the options of pacman-mirrors
–fasttrack, India, Bangladesh, --continent, --geoip… Even reset it as well

More Info: I have tried this in Qemu/Virt Manager and the host machine is Manjaro KDE where the speed is around expected 5-6 MBps

Yup…I have selected Germany for now

try this sudo pacman-mirrors --fasttrack 0 --timeout 30 && sudo pacman -Syyu this will check all the mirrors and then refresh pacman to use the fastest. for me ones that are outside my contry are faster then the ones near me

1 Like

Hi to everyone! In my case the gnome calendar has a bug. When i am switching to a different year than 2020 closes unexpectedly. I have my gmail synced.

2 Likes

Gnome now defaults to Wayland, however, Brave Ad Notifications is now broken. (using Manjaro Community Brave package).

Using X11/Xorg - Brave Ad notifications working again.

Fedora Wayland using Brave is working correctly, so this appears to be a related to Manjaro Gnome Wayland.

(Note: I have posted on the Browser section about the issue, and posting here for completeness).

I installed the rc on my ThinkPad X1 Extreme Gen 2. I noticed the differences right from the 1st screen of the installer. The installer is now more in PopOS/Fedora style. It looks great on the 4k screen and it’s simpler and faster than the previous version of installer.

Most of changes are positive to me. I quite like the Layout Switcher. But under Modern layout, when I open Files or Terminal, the app title on top bar shows “Unknown” instead of app name. I think this is a bug.

1 Like

I think the new install looks great.

On all the other releases tlp service was already enabled. On this release tlp service is disabled. Don’t know if there is a reason for.

If I am doing a fresh install, should i use 20.2rc1 or 20.1.2 iso???

Tlp should be disabled on the live system, but not on the installed system. Is it disabled for installed system as well?

I would use the rc. If you want to use stable branch, you change branches afterwards.

if i do ‘pacman-mirrors --get-branch’ in the rc1 installation it says stable branch…so why should i change branch afterwards?? isn’t it already in stable??

yep! Installed the gnome desktop. Got through the amazing looking new installer too.
But TLP service is also disabled when installed. When I install the latest Manjaro Gnome, not this release candidate but the official latest TLP is enabled.
But with this one it is disabled.

@oberon it seems that there is a bug in the new version of manjaro-tools. Services in systemd_disable_live get disabled also for the installed system, it seems.

After reading this post, I checked TLP service and found it’s disabled.

❯ systemctl status tlp    
● tlp.service - TLP system startup/shutdown
     Loaded: loaded (/usr/lib/systemd/system/tlp.service; disabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: https://linrunner.de/tlp

yeah saw this too. So probably it is already in stable branch i think

1 Like

Yeah, I also had the same issues while upgrading to 20.2 from 20.1
Slow download speeds in all mirrors

I installed the RC on my Lenovo Yoga Slim7 AMD Ryzen 4800u laptop. After enabling amdgpu module, 2 baclkight service not loading warnings disappeared. It also fixed the problem that brightness settings could not be saved with Manjaro on this laptop. Now everything works great with Manjaro Gnome on this laptop .

How you fixed not saving brightness

Edit /etc/mkinitcpio.conf:

MODULES=(amdgpu)

Regenerate the initramfs:

sudo mkinitcpio -p linux59
1 Like