Making grub menu visible at the boot and adding windows

I installed Windows alongside Manjaro. Now its defaultly booting Manjaro and if i want windows i have to open boot selection menu via pressing F9 after i press power button. I want to add Windows to grub menu and make the menu visible at startup.

Open the file /etc/default/grub in an editor, and change the following line… :arrow_down:


… into… :arrow_down:


Then, farther down in the file, find the line that reads… :arrow_down:


… and change that into… :arrow_down:


When you’re done, save the file, and then run the following command in a terminal… :arrow_down:

sudo update-grub

That should do it. :wink:


I already did this by looking other posts on forum. Grub is not detecting windows and not showing up in startup.

Hold “Esc” key while booting.

I tried that too. Not showing Windows, only manjaro

Usually when grub-update (or os-prober actually) doesn’t detect Windows is because Windows and Manjaro are installed in different UEFI/BIOS modes. One is in BIOS and the other is in UEFI. Can you check in what state is Windows installed? To check your Manjaro, you can execute:

test -d /sys/firmware/efi && echo efi || echo bios

When you have only one OS (Manjaro) in grub, it is not going to show up by default. But as soon as you have more options, it is going to show up. So this is problem is going to solve by itself when you can add your Windows boot.

1 Like

the command you wrote gave the output “efi”, i will check windows too and inform you about that

After i run 5.14 kernel and reboot. It suddenly started to show windows in grub. All problems solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.