Maintainer(s) wanted

if i may suggest,
it’d be nice that the installer give the option to create a swap partition when choosing automatic disk partitioning.

Not a bad idea. Until it is implemented, I suggest using graphical partitioning tools like gnome-disks or gparted for the partitioning.

1 Like

I feel obligated to answer here and volunteer. Not only that I think the architect is the best way to install Manjaro, I just had a look into its sources today for what I need to do to add proper ZFS support as well as functions to automate the install via CLI or config files to use it with Ansible. @Chrysostomus I joined the Manjaro Gitlab. Anything besides what I want to add and change that needs to get looked at currently?

11 Likes

Awesome! I’ll add you to the maintainers of the repo. Do you have telegram handle? And your gitlab username?

Send you a private message.

1 Like

Is this related to why the Architect Edition was removed from the Downloads page? I was trying to find out why Architect was removed, and this seemed to be the most relevant result outside of some false positives.

What does this mean if I were to download the ISO for Manjaro Architect 20.0.3, install it to a new computer, and then fully update via Pamac? Theoretically, it should work like normal and bring me up to the equivalent system as if I had installed from the 21.0 ISO?

I have to stop you there. I found it to be the best way to install any distro that balances the flexibiliy and control that a power user desires with the user-friendliness of a “step by step” installation. :wink:

2 Likes

You can also take any Manjaro iso and run the following commands to get the most recent stable architect installer started:

git clone https://gitlab.manjaro.org/applications/manjaro-architect.git

cd manjaro-architect  

git checkout 0.9.34

sudo pacman -S base-devel --noconfirm

sudo pacman -S f2fs-tools gptfdisk manjaro-architect-launcher manjaro-tools-base mhwd nilfs-utils pacman-mirrorlist parted --noconfirm

makepkg -si --noconfirm

cd ..

rm -rf manjaro-architect

setup

Since it was decomissioned not too long ago, compatibility should still be there.

3 Likes

Related but not the whole story. We had issues in manjaro-architect edition with stuck keys on tty, which could end wiping out users hard drive without warning. We could not release an iso with that issue naturally, so the manjaro-architect iso was horribly outdated and gained other issues as time passed. The version in other isos worked just fine. However, @philm wanted to drop those because manjaro-architect was going almost unmaintained (still working though, but not new features or bug fixes).

Many unnecessary steps. Just do

 sudo pacman -Syu manjaro-architect

It’s still in the repos, just not on the isos by default.

5 Likes

Oh yeah… that happens all the time when running the architect iso on virtualbox. Qemu has no problem and on my local pc there was no problem like that either when i remember correctly.

I fully agree… i tried to fix something there and it ended in doing it manually. It was really difficult and time consuming to change there a simple line of code. But in general it is a great tool and I appreciate it.

If I have time, I could also do some testings and suggestions to the code. But in my opinion it have to be rewritten from scratch in a more maintainable manner.

1 Like

If still needed, I’d be willing to help! I’m using Architect right now (installing packages) for a new system–and oh does it need some work.

Great! Talk to @anon553421 about it?

I agree. Also, the rewrite should have much more limited scope. I’m hoping I will have time to do it in the future. Right now calamares needs some love.

The problems I had in the install (if needed for reference):

  • manjaro-architect: command not found (resolution: resolve package conflict during pacman run via pacman -S glibc manjaro-architect)
  • Somehow the system I installed wouldn’t boot…

@badboyhalocat Could you please provide me more information what sequence of actions you have choosen and which bootloader you wanted to install? I will see if I can reproduce the failure.

I’ll try to repro it in a VM real quick.

left at grub prompt
no kernels in /@/boot… unable to boot manually

Thank you for all this information. When mkinitcpio and further installation steps fail it is probable that you won’t be able to boot. mkinitcpio generates the initial ramdisks your computer uses to initialize the system. I created an issue on gitlab and will look into it.

Would you like the VM image?

Here’s the VirtualBox image.

The one thing I was looking to do with Manjaro Architect was to install Manjaro with ZFS as root, which I think it can do.

The regular installer does not have an option of ZFS, and I do not like Btrfs for root – did this on Ubunbtu and it’s a mess, big time.

What are the plans for fully supporting ZFS on Manjaro? I am very much looking to ditching Ubuntu completely, and that would only sweeten the deal!