Macbook Wifi not working

Hi thanks for the reply!! <333
Sorry to trouble you for more instructions! but can you please tell me what to do exactly? like the commands i need to type in?

Open the Add/remove software (the gui of the pamac package manager), search for ‘b43-firmware’, install it and reboot .

It’s an AUR (Arch User Repository) package, so if it doesn’t show in the Add/remove software you have to enable support for Third Party AUR repository:
Open Add/remove software >> click on the 3 vertical dots >> pick ‘Preferences’ >> type in your password >> pick ‘Third Party’ tab >> Enable AUR support and search again for ‘b43-firmware’.

1 Like

Hi I have installed this firmware successfully and rebooted. However, the Wi-Fi is still not showing in the networks :persevere:

This is how it looks right now:

  Device-1: Broadcom NetXtreme BCM57765 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 01:00.0
    chip-ID: 14e4:16b4 class-ID: 0200
  IF: enp1s0f0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Broadcom BCM4331 802.11a/b/g/n driver: N/A modules: bcma pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:4331
    class-ID: 0280
  WAN IP: <filter>

Also I see there is option for adding connection in the system settings. Do I need to add it manually?

Again, thanks so much for the replies!!

Hello @Lalo,

this N/A says that no driver is loaded for your wifi device.

Perhaps the right driver isnt installed or blacklisted. Can post the output from this command:

grep blacklist /etc/modprobe.d/*

Hi @kisun !

Thanks for the reply!

I have typed in the command and this is the output:

grep blacklist /etc/modprobe.d/*                                                                                            1 ✘ 
zsh: no matches found: /etc/modprobe.d/*

Can you run the following commands one after the other.

sudo modprobe -r wl
sudo modprobe b43 allhwsupport=1

That should switch wifi on. To make it permanent open /etc/modules-load.d/modules.conf and add b43 underneath:

# List of modules to load at boot

Now open /etc/modprobe.d folder and create empty document and name it b43.conf, open it and make it look like this:
options b43 allhwsupport=1
Reboot and it should work.

Yes it worked!
Thank you!! <333

You’ll have to execute the 2 steps to make it permanent but well done.

Hi again! Sorry went out and just saw the edits!

I tried to type in the command:


But the output was:

zsh: permission denied: /etc/modules-load.d/modules.conf

Thank you for the updated edits!

Can you use your file browser for this? Sorry, I’m on xfce, I don’t know if this works in kde.
Step 1: Go to /etc/modules-load.d folder, right-click on it and ‘Open as administrator’? That should allow you to edit the modules.conf file and add ‘b43’ at the bottom.
Step 2: Open /etc/modprobe.d folder, right-click >> ‘create new document’, name it ‘b43.conf’, open it and add ‘options b43 allhwsupport=1’.

If the above doesn’t work you can do all this in a terminal, use:
Step 1: use
sudo nano /etc/modules-load.d/modules.conf
to open the modules.conf file, edit it and add ‘b43’ at the bottom.

Step 2 : To create the b43.conf file inside the /etc/modprobe.d folder use:
sudo touch /etc/modprobe.d/b43.conf
Then open the new file with:
sudo nano /etc/modprobe.d/b43.conf
and edit it to make it look like this:
options b43 allhwsupport=1

Hi again! And thanks for all the continued and updated replies!

I have followed all the steps and I have checked the files are already in where they are and with the new edits. However, the Wi-Fi still doesn’t show automatically upon booting.

The manual turning it on still works.

Check again, what’s the output of
cat /etc/modules-load.d/modules.conf

cat /etc/modules-load.d/modules.conf                                                                                          ✔ 
# List of modules to load at boot

cat /etc/modprobe.d/b43.conf

rebooted and checked again:

cat /etc/modprobe.d/b43.conf                                                                                                  ✔ 
options b43 allhwsupport=1

cat /etc/modules-load.d/modules.conf                                                                                          ✔ 
# List of modules to load at boot

That’s as it should be, maybe b43 is blacklisted. Show the output of
cat /etc/modprobe.d/blacklist.conf

cat /etc/modprobe.d/blacklist.conf                                                                                            ✔ 
cat: /etc/modprobe.d/blacklist.conf: No such file or directory

ls /etc/modprobe.d

ls /etc/modprobe.d                                                                                                          1 ✘ 

Hmm, no blacklist.conf and no broadcom-wl.conf that may have it blacklisted it, I’m afraid that’s as far as I can help here. I’m on a 2009 mbp with the same settings working fine but on 5.10LTS kernel.

Maybe try the 5.15LTS kernel, the 6.1LTS is quite new. Install via Control Centre >> Manjaro Settings Manager.