Lost wireless (bcm4312) after 2020-12-30 update

wireless worked through many updates (and many kernel changes starting with 4.4 to 5.4) until last . . .

hope the following information helps with identify issue:

from dmesg:
wlan0: Broadcom BCM4315 802.11 Hybrid Wireless Controller 6.30.223.271 (r587334)

from lspci:
0b:00.0 Network controller: Broadcom Inc, and subsidiaries BCM 4312 802.11b/g LP-PHY (rev 01)

from journalctl: wl 0000:0b:00.0 wkp11s0: renamed from wlan0

and eventually followed by litany of error msgs starting with:
ERROR @wl_set_mode:

Solved using the this post

1 Like

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    Solution
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.

:crossed_fingers: