Log out immediately returns to login

Whenever I use the Log Out button in the panel, the screen dims momentarily an then returns with a Log In box. I’m expecting the system to shutdown completely.

The Power Manager settings are set to Shutdown when power button is pressed; and Do Nothing on Sleep, Hibernate, and Battery Button.

Other than trying combinations of these settings, which hasn’t solved the problem, I don’t know what else to do. How can I get the Panel shutdown button to work as they do in my older Manjaro system?

This does not make sense to me.

You select “Log Off”

The system logs off.

If you want to Shutdown then select “Shutdown”.

What happens when you press the “Shut Down” button?

You probably messed up which buttons to show, there are 2 logoff variants. Right click and change it

To change the Log Out button right-click the button and select ‘Properties’
And select Shut Down Action Button to replace Log Out
xfce:xfce4-panel:actions [Xfce Docs]

Pressing the Shutdown button returns to Login without shutting down. Pressing Shutdown again just returns to Login again. It’s in a loop. I can log back in, and enter “shutdown -h now” in the terminal and it shuts down completely, as expected.

nikgnomic, right-clicking on the button has the same effect: returning to Login immediately.

If you cannot access Action Buttons preferences via right-click menu the preferences can also be accessed via the Items tab in xfce4-panel --preferences

I’m right-clicking on menu items and everywhere else and I’m not getting to Preferences.

He meant rightclicking the manjaro logo aka start button.

I tried that and I don’t see any Action Button preferences.

I was referring to the Action Buttons on the panel rather than the buttons in Whisker Menu


I don’t think this is what you’re talking about, but for what it’s worth here’s a list of commands that may be related(?)

I’ve been using Manjaro for several years and have installed it on two or three systems. Until this latest installation, everything has just worked – so I haven’t had to do much troubleshooting, debugging, and fixing. I’m surprised I’m having so much trouble this time.

Just for fun, I tried booting up my Windows laptop from the same Manjaro USB stick that I’ve been using for this new system. The login and power/shutdown buttons all appear to be working normally. Could this problem have anything to do with this installation going onto a solid state drive instead of a HDD? Just making some wild guesses at this point.

…or UEFI (a mystery to me) vs. BIOS?

I just now tried rebooting the new system from scratch, from the USB stick. This time, the shutdown, restart, and logout buttons seem to be working! I wonder if something is going wrong in the install to disk process?

Another scenario of lightlocker or not?

From what I’ve read about lightlocker, it could be related. Can lightlocker be removed?

The thing was that not very long ago lightlocker was Removed from the default xfce ISO’s
But, some configuration files referencing it were left on the XFCE profile.

See for example this thread:

(sorry I cant go looking very hard at how it sits at gitlab just now)