Local Network File transfer question

im actually doing my Filetransfers from my Laptop to my PC (both devices using KDE btw.) with a application named Warpinator, but always when i want to use it, i have firstly disable my firewall to get a proper connection, because i was unable to create a successfull rule to establishing my connection, i don’t get it why its so difficult to just open the firewall for a single application.

So i have 2 questions around this Topic.

1.Are there are better ways, maybe a solution that was already intregated with Manjaro/KDE already?

If not…

2.How can create a rule for my Laptop and PC for Warpinator?

That showed up in Firewalld only as Python3.11 application.

please delete your ip-addresses in your own interest

It was only my Local Network IP, i thought its only dangerous to post in public my Internet IP?

i’m using ssh in my local network for transferring data from one pc to the next. have you tried using ssh?

Warpinator works fine, besides the 2 points… that i have to disable my firewall and its a third party application.

I never used ssh yet, im not even know what this is… is it integrated in Manjaro?

Does it also has a simple UI for easy file choosing (drag+drop) function?

it’s a way more easy.you use your file-manager, create the connection and voila you’re in and you handle it as it is local on your disc.
yes, it should already be installed, but you have to activate it.
may you post the output of

systemctl status sshd
1 Like
$ systemctl status sshd
○ sshd.service - OpenSSH Daemon
     Loaded: loaded (/usr/lib/systemd/system/sshd.service; disabled; preset: disabled)
     Active: inactive (dead)

Does it also require a firewall rule for access?

Sorry but you’re 3 years on the forum. Isn’t it time you start reading some tutorials, docs, etc?

The documentation of this program lists the necessary ports you need to open. Why did you not checked the docs first?


first step is to enable and start the ssh-daemon on all your computers that you want to connect

sudo systemctl enable sshd && sudo systemctl start sshd

check again with the

systemctl status sshd
1 Like

$ systemctl status sshd

● sshd.service - OpenSSH Daemon
     Loaded: loaded (/usr/lib/systemd/system/sshd.service; enabled; preset: disabled)
     Active: active (running) since Sun 2023-09-17 21:30:53 CEST; 14s ago
   Main PID: 3427 (sshd)
      Tasks: 1 (limit: 19111)
     Memory: 2.1M
        CPU: 5ms
     CGroup: /system.slice/sshd.service
             └─3427 "sshd: /usr/bin/sshd -D [listener] 0 of 10-100 startups"

Sep 17 21:30:53 koboldx-z170 systemd[1]: Started OpenSSH Daemon.
Sep 17 21:30:53 koboldx-z170 sshd[3427]: Server listening on port 22.
Sep 17 21:30:53 koboldx-z170 sshd[3427]: Server listening on :: port 22.

okay, you did this on the computer let’s say this is computer A. have you started the service on your other computer let’s say computer B too ?

Yeah, PC and Laptop both has it activated now.

okay let’s try the first connection.
your sitting on computer A. you want to connect to computer B where your name is kobold and the computer B’s name is whitch.
so try to connect

ssh kobold@whitch

your asked to create a entry in known_hosts. say yes, then you are at th login of computer B. login with your password and report if this was succesful

You need to open port 22 to use ssh.

Whatever firewall you’re using, you have to allow incoming connections on the receiving server.

(Why do you even have a firewall installed?)

So i can also use

ssh PC@Laptop

i don’t understand what you mean.

The “PC” is the username on the receiving server where what want to connect to, the “Laptop” is the local name of that device.

It was recommend from a Linux Guide… what is wrong to using a firewall?

I used warpinator and lanxchange…they are kind of buggy.
Maybe samba?
SCP / SSH is of course also a valid solution.

Anyway, i just wanted to note that opening ssh on public interface is a huge security risk - be sure to open the port or start the service only in the local network. If it is a desktop behind a router it is ok, but if it is laptop used in cafes, airports etc. not so ok.

1 Like