LiveUSB stuck on Reached target Graphical Interface (AMD iGPU)

I was trying to install Manjaro on my new desktop using a live USB that I flashed with Balena Etcher. The Live boots, but I get stuck on “Reached target Graphical Interface”. I believe this is related with the fact that I am using the 7950x integrated GPU (until my discrete GPU is delivered).
I can use other ttys to login and the live system works properly except for the GUI.

mhwd -l(which should be for PCIe card only, though) lists video-linux, video-modesetting and video-vesa

inxi -Fazy, on the other hand, in the Graphics sections, says:
Device-1: AMD Raphael Driver: N/A arch: RDNA-2 code: Navi-2x [...] Display: server: v: driver: N/A gpu: N/A Message: GL data unavailable
How can I solve this issue? Fast Boot and Secure Boot are both disabled.
Thank you in advance for your help.

Did you select the free driver at the grub screen?

Yes, I tried with both free and proprietary drivers, but for some reason the situation does not change. I am trying to reflash the ISO using Rufus from my laptop just to check if I did something wrong. Maybe there are some GRUB options I need to remove/add?
I have been browsing forums and wikis to find suggestions, but so far none worked.

Thank you for your time!

Edit: flashing the ISO with rufus did not improve things. I double checked secure and fast boot settings in the UEFI and it all seems fine. SATA mode is AHCI.

also ahci needs to be enabled
secure boot disabled
fast startup disabled in windows if you are using it
use ventoy to flash the iso…

however you have a very recent hardware, so thats probably the main reason you cant boot…
try adding the nomodeset parameter in the grub menu

I tried your suggestions, but unfortunately to no avail. As you say, the hardware is very new and that may be the problem. Is there a way to install the driver from the live system?

In any case, thank you.

If you can get into a TTY, then I suppose so. Try:

sudo mwhd --install --auto pci 0300 free

Hope it helps!

but you said you cant boot into the live usb?
and there is nothing to install, the driver is being provided by the kernel, and since manjaro and a lot of distros dont ship their isos with the latest kernel - 5.19 even the 6.0, you cant boot this new hardware with the 5.15, which is the latest LTS kernel shipped with manjaro iso…

download the latest iso with the 5.19 kernel, you have more chances of booting the live usb with it…
download both the and the iso.z01
but be warned those could be unstable, so if the booting and install was succesfull, change the branch to stable


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.