Live xfce usb isn't connecting to the internet

Live xfce usb isn’t connecting to the internet. I’m not finding instructions anywhere on how to fix this, and I’m trying Manjaro for the first time. To complicate things, my computer just stopped booting from the hard drive in the distro I was using (Solus), so I can’t just make a new live USB to try.

Here’s what happened with the problem booting from the hard drive, in case it has some bearing on the internet problem. I booted once from the Manjaro live USB, then quickly decided to reboot from the hard drive, to do some things in Solus before checking out Manjaro. Things were buggy:

  1. Thunderbird was running from when the machine had been hibernated. (Yes, a complete shutdown would have been nicer, so I’m wondering if the hibernation is the culprit.) But online/offline toggle was buggy, the mouse pointer had a spinning circle, and it was hard to switch mail folders.

  2. Firefox wouldn’t start. I was told that it was already running, but the task manager showed no processes for it.

  3. Transmission was open, from downloading the Manjaro torrent last night. I don’t normally use Transmission, so I don’t know how Solus reacts to waking up from hibernation when it is open.

I shut down the computer from the screen, but then wasn’t able to complete a reboot.
For the purpose of this post, I’ve just tried another reboot from the hard drive. Here’s what I see on the screen:

Generating “/run/initramfs/rdsosreport.txt”

Entering emergency mode. Exit the shell to continue.
Type “journalctl” to view system logs.
You might want to save “run/initramfs/rdsosreport.txt” to a USB stick or /boot after mounting them and attach it to a bug report.

:/# [blinking cursor]


What set me off on this adventure was trying to get a webcam working in Linux. I’ve been thinking of switching from Solus anyway, so before giving up on the webcam, which wasn’t working in Solus, I decided to try it with distros that are known to have great hardware support. Manjaro was my first choice for such a distro. If the webcam works with Manjaro, I’ll install Manjaro and give it a try for a while.

Wait.
How did you boot the USB if the system wasnt shutdown?

Then the rest of your post…

Booting a manjaro USB wont touch your other installation or files.
Not unless you forcibly did something, used a program like gparted, or attempted an install.
Otherwise … simply booting from a Manjaro USB (which still I dont understand how you did without shutting down) will not in any way affect your solus. Any problems you have with solus are just that - a solus problem.

I think there is more missing from this story.

Anyways … so … the thread title is about network connection.
I dont really see any information in your post about that.
Is that still what you want help with?

I suggest you take a look at this:

1 Like

Thanks for the reply. To answer your question about the shutdown, I had left the Manjaro USB connected to the computer when I hibernated it last night. In case the terms for the different ways of powering down are different in Solus than they are here, I mean the option where the computer saves the state of the machine, then completely powers off. I had intended to go back into Solus when I first turned on the computer today, but it booted from the USB stick instead. After that, each switch between Manjaro and the sad state of my Solus installation has involved completely shutting down the computer. I do realize that booting from a USB doesn’t affect what’s on the hard drive unless the user goes out of their way to write something to it, which I haven’t done. Still, I thought that too much information was better than too little, and I didn’t want to just say that I tried Manjaro and I couldn’t go online, when other things had happened that might have had a bearing on the situation.

So yes, I’m looking for help in establishing an internet connection. I was assuming that the Manjaro USB would connect to the internet automatically. If I’m mistaken about that, how am I supposed to connect? If I’m not mistaken, then how do I troubleshoot the issue? My computer is a Dell Optiplex 380. The network card is a Broadcom Netlink BCM57780 Gigabit Ethernet PCIe. The network interface is loopback.

By the nature of the problem, I can’t easily provide the screenfuls of system info that the guidelines ask for; I’m using my phone in this forum.

I was able to get online in Linux Mint, so nothing seems to have gone wrong with the hardware. The problems in Solus seem to be a coincidence. For now, I’ll be moving on to try other distros, but it would be great to be able to get Manjaro working, too.