Live USB will not boot. common_interrupt: 1.55 no irq handler for vector

Installing Manjaro on a new computer, and new issues arise!

I am trying to install Manjaro XFCE on a HP Pavilion g7 from late 2011. Whenever I boot the live USB environment, this message shows up:

[0.00something] __Common interrupt: 1.55 no irq handler for vector

The system then continues to boot and the verbose looks OK. Then it goes to a black screen with only a typing marker. After a short while of that, the screen turns off, while the computer is still on.

I have tried booting both with proprietary and with open source drivers, as well as updating to the latest BIOS firmware from HP to no avail.

I have found a few similar threads on the Manjaro and Ubuntu forums, but they are usually about systems that are already installed, and the solutions don’t seem to apply in this case with a live USB. I’ve tried booting with some of the suggested arguments from those threads, but I might not have done it correctly for all I know.

These are the details on the computer: HP Pavilion g7-1305sw Notebook PC Product Specifications | HP® Customer Support

1 Like

I have already encountered many of those threads. I have tried pressing ‘e’ on startup (in the live USB’s Grub) in order to try boot options suggested in other threads such as



acpi_osi=Linux acpi_backlight=vendor

None of it has made any difference, and since this is a live environment, I don’t see what else I can do.

just try “noapic”

If I add “noapic” on the linux-line of the boot paramters, I get the following error:

ERROR: ‘/dev/disk/by-label/MANJARO_XFCE_2021’ device did not show up after 30 seconds…
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can’t access tty: job control turned off

Still no luck, but thought I’d post an update on my research so far.

I found this similar thread, but the solution does not work in my case.

I played around booting only with only one modeset activated at a time. Activating only nouveau.modeset or booting only with nomodeset yields a result that is different to the default, but still unable to boot:

[FAILED] Failed to start Light Display Manager

Then 3 more lines succeed, then nothing more.

I tried installing Ubuntu, hoping for more luck. The regular live USB has similar issues to Manjaro. The safe graphics mode is able to boot, although it displays a warning about missing UMS. I am not familiar with the concept, but based on a quick search, this seems to check out with the fact that the BIOS of this computer is displayed at an extremely low resolution. Not sure what to do with the info though.

All that safe graphics mode does in Ubuntu is adding nomodeset to the boot parameters. Indeed, the installed Ubuntu system boots, as long as nomodeset is added to the boot parameters.

After creating this thread, I’ve noticed that the similar errors as in the first post appear on startup of another HP laptop I have running Manjaro, so this might be a problem related to their configuration. That computer is still able to boot however.

My solution for now will be to stick with Ubuntu with a custom grub config on this particular computer.

Same problem for me with live boot, but all distros have the same problem. Even ubuntu on safe graphics doesn’t want to work. I have no clue on how to use manjaro and I don’t know how to use the grub menu and set pci=nomsi, noaer either. If anyone knows how to explain that to my non Linux brain, I will be very grateful.

pc specs:
Toshiba satellite c855d with amd e1-1200, radeon hd 7310(newest driver), 6 gigs of ram(ddr3 1066mghz), and 250 gig pny ssd. The bios is on the latest version.

What I did was:

  • Boot into the grub menu (where you can choose whether to boot the live USB, run memtest, etc.)
  • Highlight the option you are going to boot from (probably the first one)
  • Press e
  • Find the line that says something like linux /boot/vmlinuz...
  • Add your boot parameters somewhere on that line. Right after where it says ‘quiet’ seems to be a good place.
  • Press F10 to boot with the parameters you entered.