Live USB boot stuck at load/save RF kill switch status

I am trying to boot from a live USB to install Manjaro on my HP laptop, but it freezes on boot at : ‘[ OK ] Started Load/Save RF Kill Switch Status’. I have UEFI - secure boot disabled, fast boot disabled and boot order set to boot from USB first. The weird thing is that my other laptop boots into Manjaro live perfectly fine using the exact same USB stick.

Any ideas what’s going on here and how to fix it?

this happened to me some years ago, and after long and painful researches I discovered that, apparently, different brands of USB pendrives use different ways to “write data”, and that’s why some PC manifacturer goes along with brands that are otherwise troublesome elsewhere.
Now, I perfectly understand that this could seem straight out of science fiction, and I lack the technical background to provide evidence to this statement, however:

  • back when I researched the issue, I found thousands of pages of extremely technical dissertations that detailed the physics of “why this happens”
  • I simply changed brand of the pendrive and it worked for me

to summarize: just change brand of pendrive, and best of luck! :slight_smile:

I Fixed it. The problem went away just by using another USB port. Still very weird that this happened though, it’s a brand new laptop and I never noticed an issue with that specific USB port before.

Who would’ve guesses this was the issue, after hours of searching for the cause! Thanks to all who responded :slight_smile:

Just wanted to add that the problem came back, but this time was ‘fixed’ by using the other port again! Looks like I have to switch ports every time in order for it to boot. Weird.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.