Live plasma iso can't boot from Ventoy

I’ve just downloaded and copied the latest plasma live iso to my ventoy usb stick, but sadly it failed to boot:


I’ve verified that the sha256 matches the one displayed on the website.

Most other iso’s boot just fine from my years old ventoy setup, though I haven’t tried any other recent Manjaro iso. One from 2021 I still had lying around boots to tty but fails to start the desktop environment and doesn’t recognize my laptop’s ssd.

Please do not post screenshots of text

When you boot from a ventoy stick - use the Grub2 boot mode.

You may also need to update your ventoy binaries - this can be done without reformatting the stick

ventoy update /dev/<usb-stick>

thanks for your reply and sorry for the picture of my screen, didn’t know how to show the problem otherwise…

ventoy upgrade done:

# ventoy -u /dev/sda

      Ventoy: 1.0.98  x86_64

Upgrade operation is safe, all the data in the 1st partition (iso files and other) will be unchanged!

Update Ventoy  1.0.52 ===> 1.0.98   Continue? (y/n) y
esp partition processing ...

Update Ventoy on /dev/sda successfully finished.

I’ll try again with that and report back.
But about that Grub2 boot mode: what is that and where to find and activate that? Do I need to change some ventoy config file for that or is it something I can / need to select while booting from my ventoy stick?

When you select an iso - you get a choice to boot two different modes - on my USB it is number two after selecting the ISO.

1 Like

When you launch an ISO with Ventoy you’re given a choice; something like:

  1. Normal
  2. Grub2 mode

That’s all it refers to.


Or, as @linux-aarhus wrote at the same time. :sweat_smile:

thank you for your replies! I’m writing you from my live manjaro system, though now sadly the installation to the integrated ssd failed:

I want to install to an luks encrypted btrfs partition, maybe that’s the problem?

Or the problem could be that my efi partition is only 260mb big since that’s what my laptop came with and I’m afraid changing that would distroy the ms windows installation…

That size is acceptable when using grub

I retried the installer with leaving the LUKS partition closed, now it complains:

Root partition /dev/nvme0n1p5 is LUKS but no passphrase has been set.

Based on experience - do not attempt to create a LUKS encrypted setup while dual botting Windows - I don’t know why - it is error prone.

1 Like

well… thanks for sharing your experience, but for me that’s an essential feature and I had Manjaro installed on the same hardware before, also with luks+btrfs…

I guess maybe I need to let the installer format the luks+btrfs setup, I had hoped I could keep the existing setup…

This time calamares tried to “mount -t luks” and was surprised it didn’t work…

you can - but you need to open the container manually and reassign the installer to to it - but if you were using lvm - then your home would likely be lost - and you are back at square one.

When using encryption you should really not expect to be reusing anything …

yes, well I finally gave up, copied all the subvolumes I wanted to keep to an external usb btrfs disk and let the manjaro installer recreate a new luks+btrfs partition in place of my old setup. currently I’m using this newly installed system and setting up rsync jobs to run through the night to copy stuff back from the backup into my new home subvolume.

I’ll drop this here for the benefit of passers-by:

If you are using a Ventoy USB to install Manjaro directly from a Manjaro ISO, it can be easy to create the USB with a Master Boot Record (MBR) partitioning scheme by mistake.

This will often cause a failure to boot/install a UEFI OS.

The commands I’ve given below will create a Ventoy USB and force GPT to be used in the process. These are the procedures I personally use in creating a Ventoy USB; given in case someone finds the information useful.

  • An 32GB capacity USB should allow ample space to store several ISOs of your choice, however; anything less than 8GB capacity should probably not be considered.

Using the examples below, you will install the Ventoy system to a clean USB with:

  • a GPT partitioning scheme (required for UEFI)
  • Secure Boot disabled (on the Ventoy USB)

Ventoy is available from the official Manjaro extra repository:

sudo pacman -S ventoy

Type ventoy (without arguments) to see usage information:

Usage: CMD [ OPTION ] /dev/sdX  
  -i  install Ventoy to sdX (fails if disk already installed with Ventoy)  
  -I  force install Ventoy to sdX (no matter if installed or not)  
  -u  update Ventoy in sdX  
  -l  list Ventoy information in sdX  
 OPTION: (optional)  
  -r SIZE_MB  preserve some space at the bottom of the disk (only for install)  
  -s/-S       enable/disable secure boot support (default is enabled)  
  -g          use GPT partition style, default is MBR (only for install)  
  -L          Label of the 1st exfat partition (default is Ventoy)  
  -n          try non-destructive installation (only for install)

Write the Ventoy system to an empty USB drive;
use /dev/sdX to target the device itself, and not a partition:

sudo sh ventoy -i -r 100 -S -g -L VOLUME /dev/sdX
  • Enable -s or disable -S Secure Boot.
  • Substitute VOLUME for a volume label name to use.
  • Substitute /dev/sdX for the location of your USB device.
  • Preserve some space on the target device (example allows 100mb).

Update the Ventoy system on an existing Ventoy USB;
ensure the updated Ventoy version is available in Manjaro; and then:

sudo ventoy -u /dev/sdX
  • The Ventoy USB update process is non-destructive.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.