Listen to line-in while keeping a working mic

I’m running into this problem, I want to send my phone’s audio into my headphones. Wired my phone’s headphone jack into my PC’s line-in.
Then after some research into pulseaudio’s module-loopback I managed to get it working and I could listen to my phone’s audio via the headphone connected to the PC.

Then I hit a snag, my computer started reading Line-in as my microphone and even changed the setting in my audio config. I changed it back so I could use my mic on a discord call and the Line-in is effectively unused.

How would I go about to keep my mic working for discord calls and make it so I’m the only one listening to what’s sent via line-in?

You might have an audio control in ALSA to allow monitoring of the Line In
there may also be a setting for turning loopback mixing on and off

please post response to this command to show audio devices

aplay -l

find the card number for the Analog Onboard audio
(most systems have card 0 = HDMI and card 1 = Analog audio, but it varies)

Post the response to this command to show audio controls for the card

amixer --card=1

Result of “aplay -l”

[hugo@hugo-pc ~]$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC887-VD Analog [ALC887-VD Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC887-VD Digital [ALC887-VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0

And the result from “amixer --card=1” is:

[hugo@hugo-pc ~]$ amixer --card=1
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 33 [52%] [-31.00dB] [on]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 0 [0%] [-64.00dB] [off]
Front Right: Playback 0 [0%] [-64.00dB] [off]
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control ‘Front’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘Front Mic’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
Simple mixer control ‘Surround’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 64
Mono:
Front Left: Playback 64 [100%] [0.00dB] [on]
Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘Center’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘LFE’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 64
Mono: Playback 64 [100%] [0.00dB] [on]
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Line Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘IEC958 Default PCM’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 46
Front Left: Capture 38 [83%] [22.00dB] [on]
Front Right: Capture 38 [83%] [22.00dB] [on]
Simple mixer control ‘Capture’,1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 46
Front Left: Capture 0 [0%] [-16.00dB] [off]
Front Right: Capture 0 [0%] [-16.00dB] [off]
Simple mixer control ‘Auto-Mute Mode’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Enabled’
Simple mixer control ‘Channel Mode’,0
Capabilities: enum
Items: ‘2ch’ ‘4ch’ ‘6ch’
Item0: ‘2ch’
Simple mixer control ‘Input Source’,0
Capabilities: cenum
Items: ‘Front Mic’ ‘Rear Mic’ ‘Line’
Item0: ‘Rear Mic’
Simple mixer control ‘Input Source’,1
Capabilities: cenum
Items: ‘Front Mic’ ‘Rear Mic’ ‘Line’
Item0: ‘Front Mic’
Simple mixer control ‘Loopback Mixing’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Disabled’
Simple mixer control ‘Rear Mic’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Rear Mic Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]

That’s about it, I managed to achieve somewhat the desired effect by using discord on my phone, however that has some other issues, such as it heating up the phone and the call taking priority over the audio of everything else.

1 Like

You have 2 controls in this card for loopback mixing the Line input

If you use ALSA loopback controls audio from Line In can be mixed direct to Headphone or Speaker output without passing through PulseAudio.
This does not delay audio like using the PulseAudio loopback, and PulseAudio cannot mistake Line in for for the microphone

Use this command to turn on the Line In loopback and set level to 90%
(change it to 100% once you are sure it won’t be too loud)

amixer --card=1 sset 'Line' 90% unmute

Then use this command to turn the loopback on

amixer --card=1 sset 'Loopback Mixing' Enabled

and this command to turn it off

amixer --card=1 sset 'Loopback Mixing' Disabled

You can also go to alsamixer --card=1 to adjust ALSA settings
Or install a GUI mixer like gnome-alsamixer or qasmixer

2 Likes

Works great, thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.