LightDM starts on half of the boots, and then doesn't work the other half! GDM works every time. Confused

Sometimes when I boot my machine, LightDM works perfectly. Other times I boot the machine and it just goes to a blank black screen. It’s like 50/50 whether the machine will start up.

With GDM the machine starts every single time.

It’s a stock Manjaro XFCE on an Acer laptop with Intel 520 integrated graphics.

Stock LightDM theme. Installing a different theme and setting it in the LightDM config file didn’t seem to do anything, as in it didn’t fix the problem or even appear to even change the theme!

As far as I know, there are no nvidia graphics on this machine.

I’d prefer to use LightDM if possible.


No one? I had to boot the machine 4 times today before LightDM actually worked. I’m the only one? No one has any ideas? I can’t even check the log because once it finally works the log only shows that it worked, with no errors of course.

Hi @loomis!
You’re not alone, I’ve had your same issue and I found a solution in the ArchWiki that worked for me. I hope it works for you too!

It may happen that your system boots so fast that LightDM service is started before your graphics drivers are properly loaded. If this is your case, you will want to add the following config to your lightdm.conf file:


I was having the same problem after reinstalling the Cinnamon edition. Several days of trying everything I could find by searching brought no joy (a lot of it was only relevant to Nvidia systems - I’m on AMD, and I didn’t see zfrancesco’s solution - will try that first if it happens again.)

What seems to have sorted the problem out for me is following the (unrelated?) advice on reinstalling GRUB in the 10th March news post. (forum won’t let me include a link - probably because this is my first post on here and they don’t trust me.)

I can’t claim this is a definite fix due to the slightly random occurrence of the issue (like loomis; it seemed to be about 50%) but I haven’t had it happen for the last few days.

I faced the same problem, if i understand your problem the right way → Tuxedo Pulse 14 Gen1 - #18 by spikerguy
There is also a issue open on GitHub → Not showing any login screen · Issue #165 · canonical/lightdm · GitHub

1 Like