Lightdm.service is down after update i3w

i am using i3w and dual monitor, recently updating my package and the OS, after reboot my screen went black but still able to give command on it ( yyt4 )

Error it show:

[FAILED] Failed to start Light Display Manager
[FAILED] Failed to start pkgfile database update

Note: apologize i have no idea how to output this log, so i use screenshot, will change up after knowing how, Please click next on this photo

sudo lightdm --test-mode -debug

sudo systemctl state lightdm

x lightdm.service - Light Display Manager
      Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
      Active: failed (Result: exit-mode) since Sat 2021-09-25 20:11:28 ACST: 5min ago
      Docs: man:lightdm(1)
     Proccess: 936 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
    Main PID: 936 (code=exited, status=1/FAILURE)
              CPU: 29ms

sysmtemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
sysmtemd[1]: Stopped Light Display Manager
sysmtemd[1]: lightdm.service: Start request repeated too quickly.
sysmtemd[1]: lightdm.service: Failed with result 'exit-code'.
sysmtemd[1]: Failed to start Light Display Manager.

xorg.conf output

inxi -Gazy

     Device-1: NVIDAI TU116 [GeForce GTX 1650 SUPER] driver: N/A
     alternate: nouveau bus-ID: 25:00 chip-ID: 10de:2187 class-ID: 0300
     Display: server: 1.20.13 driver: loaded: N/A failed: nvidia
     tty: 240x67
     Message: Advanced graphics data unavailable in console. Try -G --display

sudo mhwd -li

> Installed PCI configs:
                          NAME                                  VERSION                 FREEDRIVER                                          TYPE
                     video-nvidia                          2020.11.30                    false                                                      PCI

Warning: No installed USB configs !

i tried to reinstall this package with
sudo pacman -S lightdm-gtk-greeter
sudo pacman -R pkgfile

sudo systemctl enable lightdm.service
sudo systemctl start lightdm.service

but noting happen, i dont know how to fix this problem, i also found out, the video-nividia is false, will this be the problem core ? please let me know about, will be very greatful.

duel :verb = battle
Maybe try to set them in dual harmony instead … :grin:

But your mhwd -li shows that

is installed, but not working. Something might have gone wrong when the video driver was installed. Install them this way:

sudo pacman-mirrors -f5 && sudo pacman -Syyu && sudo mhwd -f -i pci video-nvidia

lightdm is the display manager and lightdm-gtk-greeter is only the greeter - are two separate packages, and by default Manjaro i3wm is using the lightdm-slick-greeter that uses the lightdm-settings (another important package)

In order to use the lightdm-gtk-greeter you also have to install the lightdm-gtk-greeter-settings - otherwise will not work. Is all documented Install Display Managers - Manjaro

1 Like

@pobrn hello mate, can you help me look into my problem, i saw in other post you helped them to slove this one.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.
  3. You cannot ping anyone as you’re new here.
  4. You’re probably running XFCE, so I’ve reclassified your question to the XFCE subcategory so someone else can help you as I’m on KDE, but anyone would need the inxi above and the output to journalctrl in text format. No screenshots please!


Got it, i will repost and remodify my post, sorry is my first time here. thanks for the tips

1 Like

sudo is not needed for systemctl commands

To check lightdm.service for errors

systemctl status -l --no-pager lightdm

@nikgnomic hello could you check here, Lightdm.service is down after update i3w

i will delete this one later, cause seem like i post in the wrong support. thanks ya

my response applies to the other post too

I do not want my face booked so I have not looked at the screenshots

1 Like

Moderator Message:

I’ve merged your 2 posts into one.

We understand that you’re very new here, but for the future, please don’t post 2 questions in 2 different categories for the same issue as that is considered cross-posting which is against the rules

  • Although I’m a moderator on this site, this is not an official warning: just helping you to become a more productive member of this forum.


1 Like

haha got it, i edit it back, thanks for letting me know.

i tried to install them in the code you give me, but it out put this error

warning: too many errors from, skipping for the remainder of this transaction
error: failed to symchronize all databases (invalid url for server)

all alot more same error, so i just output one.

i tried to clean the cache and update but same error.
sudo pacman -Sc

atucally i dont know what lightdm-gtk-greeter does, i install it cause i though it was a package that didt install right that cause this problem, should i remove it ?

so what should i do now ?

the code you give is output the same text as systemctl state lightdm, i update the question on top, so you can look into it, apologize i am not sure how to output this log, so i am hand typing this error out.

XD Got it, i remove the other one, thanks for helping me out, sorry didt notice i got merged 2 post. yeah i am trying to get use to it here fast as possible.

Refresh the mirrors with:
sudo pacman-mirrors -f5
then do the install …
You could even do it more properly like:
sudo pacman-mirrors -f5 && pamac update
so we are sure you are up to date with the system.

Oh, well … is the fancy username and password login screen

Seriously, is up to you what greeter you want to use. If you installed i3wm from ISO, then you mixed things up a bit … if you installed over another DE, what that DE was? If KDE Plasma, then SDDM has to go, if was Gnome then GDM has to go … if you want to use another DM and a different greeter.

Error output:

Failed to synchronize database
Noting to do
Transaction successfully finished

after the sudo pacman-mirrors -f5 and i update with sudo pacman -Syyu, it output the same errors for warning too many errors.

should i do something with this first ?

[FAILED] Failed to start pkgfile database update

ohh well haha i am ok with normal login screen that came from the OS, should i remove the package lightdm-gtk-greeter ?

In order to move to the next step, yes, that would be the first issue to take care:
sudo pacman-mirrors --continent --interactive
and only select working mirrors
then move to
pamac update

that is?

sudo is not needed for systemctl commands

command suggested with or without sudo returns an error

$ systemctl state lightdm
Unknown command verb state.

state is not a recognised command verb – man systemctl

haha i found out what happen on the update part, my connection somehow went down, when jump to manjaro, but fixed it and the package update is done but last part went error again.

sudo pacman-mirrors and sudo pacman -Syyu is update

but this one sudo mhwd -f -i pci video-nvidia

:: Synchronizing package databases. . .
core downloading
extra downloading
multilib downloading
error: target not found : linux59-nvidia
Error: pacman failed!
Error: script failed!

also this error was not showing anymore

[FAILED] Failed to start Light Display Manager
[FAILED] Failed to start pkgfile database update

so what next ?

Got it, the error show the same as it was not active but with bogdancovaciu help, now it seem to have some movement, but the last part somehow show error again.

Please boot a supported kernel or a LTS one and remove the EOL one. What kernels you have installed?
mhwd-kernel -li

What kernel you are currently booted into?
uname -a

If you are on a different kernel than 5.9 then you can run:
sudo mhwd-kernel -r linux59

Then we can move on. At this point all this became a x, y and z issue :laughing:

mhwd-kernel -li
The following kernels are Installed in your system: *linux59

uname -a
Linux monster-ms7c96 5.9.16-l-MANJARO #1 SMP PREEMPT Mon 21 22:00:46 UTC 2020 x86_64 GNU/Linux

yeah i think is 5.9 but once i ran the sudo mhwd-kernel -r linux59
Error: You can't remove your current kernel

haha it stopped here, some post said this, but havet tried it, waiting for your instruction XD

The CLI version mhwd-kernel does not allow removing the running kernel

# mhwd-kernel -r linux511
Error: You can't remove your current kernel.

If you are installing another kernel then you can add rmc

mhwd -i linux510 rmc