Lightdm not running after fresh Manjaro Cinnamon install

I just did a fresh install of Manjaro Cinnamon (latest full ISO downloaded yesterday), the installation went well.

But at first reboot the machine booted in console mode with no GUI and I found out that lightdm was not running and disabled.

sudo systemctl enable --now lightdm fixed it, but I wonder if this is “normal” or if I missed something or is there some kind of an install bug ?

TIA for any clue.

certainly not normal behaviour … which version of the ISO did you install? 21.3.7 ?
I will check a little later today what might be going on …

lightdm.service is indeed disabled on a fresh install, really odd. I am investigating what the problem is …

only thing I know sofar is that the issue is not present on the 21.3.6 ISOs, so please for now use those for installation. I will downgrade the download links for now…

@Jim.B Can you reproduce this on your Cinnamon spin?

I now finally figured out that apparently there is a problem in the version of Calamares that the Cinnamon profile was using - by accident it was set to using the git version of the installer.
I am rebuilding updated Cinnamon ISOs now.


In Cinnamon edition after fresh install units lightdm and NetworkManager are disabled,so after install i must manually enable them.

All systemd initial processes are disabled!!
not only these two it just load the kernel and ask you for login credentials

can you make script to fix the already installed system like a patch or something I have this post 3 days ago and since then I was customizing and installing software of my needs

so any advice is appreciated!!

The ISOs have been updated and the issue is solved now:

Not that I know of. But it looks like I will be rebuilding the iso’s just in case. Thanks for the heads up.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.