Light display manager failed to start

So I already made this post on the Manjaro subreddit, but anyway the thing is I recently installed an amd driver on my computer and when I booted it up it didn’t display anything other than a message saying that the light display manager had failed to start.

Also I used tty to try and reinstall the video drivers and it didn’t work, only showing a message saying that the video-modesetting config file is invalid.

Any help would be appreciated!

Hi :wave:

This is a little bit meager information. I don’t think anybody here has a glass ball.

Please provide more information:

  1. cat /var/log/Xorg.0.log and cat /var/log/Xorg.1.log
  2. Files in /etc/X11/xorg.conf.d/
  3. journalctl -b -0 --no-pager


How exactly do I use these commands that you sent.

I navigated to the the folder and typed the journal command and got spammed by logs

Ok so you are new to linux… now slowly:

  1. Use if possible a install disk and boot it
  2. open a terminal and type manjaro-chroot -a and type 1
  3. then copy paste the commands line by line there
  4. Open a browser and paste the links here

I’ll make it it easy for you:

cat /var/log/Xorg.0.log | curl --upload - 
cat /var/log/Xorg.1.log  | curl --upload -
for x in $(ls /etc/X11/xorg.conf.d/); do curl --upload /etc/X11/xorg.conf.d/$x$x; done
journalctl -b -0 --no-pager  | curl --upload -

Good success :wink:

Ok I will try to boot into a live usb tomorrow, because i don’t have any usb or discs available right now.

Also do I need to boot in a live media or can I do it in tty?

Here are the links (for some reason the xorg.conf.d could not be uploaded)

h ttp://
h ttp://
h ttp://

Also just remove the spaces in http i did this because the forum did not let me send links

Yeah, removed " at the end… now it works.

This file is empty… try to use -1 instead of -0 for the previous boot.

Ok here you go

h ttp://
h ttp://
h ttp://

I think that the boot log is empty because the journalctl is not being recognized as a command

Any new information about the situation?

Please also this output:

mhwd -l && mhwd -li

h ttp://

Here you go

As i thought… remove video-modesetting and video-vesa and reinstall video-linux.

mhwd -r video-modesetting
mhwd -r video-vesa
mhwd -i -f video-linux

You can’t use all of that stuff without a proper configuration. video-linux is enough. it contains all free drivers.


Ok I did all of the commands, should I reboot now?

Ok It worked! Thank you!

Also is there something more to do or is that it?

Just don’t install them again… inform yourself what a specific driver does before installing. On Linux you have to think before doing unlike on windows :wink:

Ok I will be more careful next time I install drivers, I mean i don’t even know why I did that in the first place.
Anyway is there a way I can pay for your help? (I know that the forum is free, I just would like to compensate for the help).

1 Like

Thank you for your offer and I am really flattered that you appreciate my help, but the money would be better invested in Manjaro development and and the free services it offers.


1 Like

Ok! It’s only fair to give back to the developers that provide this awesome operating system, and it’s community :slightly_smiling_face:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.