Libva-vdpau-driver VS libva-nvidia-driver

What is the difference between

libva-vdpau-driver
and
libva-nvidia-driver
?

I have only installed the former and the installations are conflicting.
I am using an Nvidia card with the proprietary driver and am experiencing screen tearing on Firefox, not elsewhere.
Should I switch to try to solve my issue?

Here you go: Hardware video acceleration - ArchWiki

Hm so then I don’t understand running CUDA vs. non-Cuda…
Will installing the latter (with CUDA) and removing the former be helpful for my FF-tearing issues?
Cudos.

Does libva-vdpau-driver provide HW acceleration in Firefox on your system?
When I tried it, it didn’t work. It’s outdated and not recommended to use.

libva-nvidia-driver does work but you’ll need to configure a lot of parameters manually.

I haven’t experienced any screen tearing though. So can’t say if switching driver would help you in that regard.

1 Like

Unsure how to check.

I have a failure log in about:support though, relating to vaapi:

Failure Log
(#0) Error	vaapitest: ManageChildProcess failed
(#1) Error	GFX: RenderThread detected a device reset in PostUpdate
(#2) Error	Failed to make render context current during destroying.
(#3) Error	Failed to create EGLSurface!: 0x3003
(#4) Error	Failed to create EGLSurface. 1 renderers, 2 active.
(#5) Error	Failed to create EGLSurface!: 0x3003
(#6) Error	Failed to create EGLSurface. 2 renderers, 0 active.
(#7) Error	Handling webrender error 3
(#8) Error	Fallback WR to SW-WR

My system was installed in May of 2023 and it seems to have been default by then.
(Nvidia driver installed by mhwd @ cli)
Maybe others have the same issue/outdated driver?

(and yeah I’m really careful changing a running system, much costumizaition looks-wise.)

Been looking at this. See:

https://www.reddit.com/r/AlienwareAlpha/comments/idfxz7/comment/g2989sq/?utm_source=share&utm_medium=web3x&utm_name=web3xcss&utm_term=1&utm_content=share_button

1 Like

Yeah almost feeling like the Windows Youtuber. :yum:

1 Like

The easiest way to check if HW acceleration is working:

  • play video having resolution at least 720p in Firefox
  • run nvidia-settings, select your GPU and look at the value of Video Engine Utilization. If that value is more than 0, then acceleration works
1 Like

Ok, thanks. It’s 0%

It means HW acceleration doesn’t work. Try to install and configure libva-nvidia-driver.

You don’t, by any chance, have a hybrid system?

1 Like

I have onboard GPU but it’s unused. 16 × 11th Gen Intel® Core™ i7-11700K @ 3.60GHz

When you say “unused”, you mean turned off in UEFI or something else?

I think I have deselected it in Uefi-BIOS, yes.
Nothing plugged in there either.

Your system has a pretty powerful iGPU that is capable of handling any video.
Why do you want to use NVIDIA dGPU for that purpose?

iGPU has only 2 outputs, I attach 3 screens and 1 TV to my (errr, very “cheap” in 2021-2024) GPU.

Installed: libva-nvidia-driver

Thank you after several reboots the screen tearing issue seems to be gone. (Unless upon screen auto switch off, then I have to relogin to make it go).

However, the video Video Engine Utilization stays at 0% be that for Ff-yt videos >=720p or any video that I play with VLC/Smplayer up to 4K.
So maybe my GPU can’t do this at all? CPU also goes up when I play these vids.

Might want to check the codecs supported by your device vs what yt (or whatever else) is using.
In my case my AMD is just a little too old for AV1, so I keep that disabled.
This may be possible from within an account or something, but I dont have one of those.
I use enhanced-h264ify – Get this Extension for 🦊 Firefox (en-US)

For smplayer you may want to check its settings as well.
In my case I use gpu-next.

1 Like

You might also try disabling graphics hardware acceleration in Firefox.

  • Go to SettingsAdvancedGeneral (tab).
  • Uncheck Use hardware acceleration when available.
  • Restart Firefox.

Cheers.

1 Like

No HW acceleration still? Provide output of:
inxi -Gz
sudo cat /sys/module/nvidia_drm/parameters/modeset

and what’s selected in your SMPlayer Preferences → General → Video → Output driver

1 Like
inxi -Gz                                                                      ✔  at 19:45:54   
Graphics:
  Device-1: NVIDIA GP107GL [Quadro P620] driver: nvidia v: 550.67
  Display: x11 server: X.Org v: 21.1.12 driver: X: loaded: nvidia
    gpu: nvidia s-res: 9600x2160
  API: EGL v: 1.5 drivers: kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.67
    renderer: Quadro P620/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib
sudo cat /sys/module/nvidia_drm/parameters/modeset                           ✔  at 19:46:00  
[sudo] password for: 
N


SMPlayer is at Default there. I had set Performance > | Performance | Hardware decodeding
to nvdec-copy after the above 2 posts and I did get some small percentages in nvidia-settings Video Engine Utilization then finally, however just for videos up to HD, the rest seems to be done by the CPU.

Thanks I installed that however I have a newer CPU ( i7-11700K ) so that shouldn’t be an issue?