Libreoffice 7.0.4 startup is VERY slow

Hi everyone, my installation of libreoffice from the official repository is REALLY slow(two minutes at best). It’s not just when opening docs but starting the software as well. I tried to reinstall, but it did nothing.

Here my specs:

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.2-2-MANJARO
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 3700X 8-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: GeForce GTX 1080 Ti/PCIe/SSE2

Okay, more detail is needed. I’m using an i3-4130 processor with 8GB RAM so you should be a fair bit quicker…

I actually chose to have WPS for my main office suite… not that I do much, but it’s enough for me - writer documents look great, save to .docx and give no headaches and it works perfectly with my old spreadsheet too. I haven’t tested it myself, but I hear freeoffice is also pretty tasty.

WPS takes less than 2 seconds to appear and works well… wps-office [installed] doing a quick search brings up freeoffice as a top answer also which is comparable (with minor differences - it really depends on your use case perhaps).

That’s not a solution, but a possible workaround if you’re in need. I’m not sure who uses Libre - some might even use the snap or appimages, but I wanted a break from those menus.

Ok, let’s play:

trizen office


6 extra/libreoffice-fresh-af 7.0.4-1
Afrikaans language pack for LibreOffice Fresh
5 extra/libreoffice-fresh 7.0.4-1
LibreOffice branch which contains new features and program enhancements
4 extra/libcdr 0.1.6-2
CorelDraw file format importer library for LibreOffice
3 extra/hplip 1:3.20.11-2 [installed]
Drivers for HP DeskJet, OfficeJet, Photosmart, Business Inkjet and some LaserJet
2 extra/goffice 0.10.48-1
A GLib/GTK+ set of document-centric objects and charting library
1 extra/freeoffice 2018.980-1
A complete, reliable, lightning-fast and Microsoft Office-compatible office suite with a word processor, spreadsheet, and presentation graphics software.

=>> Select packages to install

I love that entry ‘fresh-af’ means fresher than fresh, fresh as f@ck? Let’s go with number 5.

:: Pacman command: /usr/bin/sudo /usr/bin/pacman -S extra/libreoffice-fresh
[sudo] password for ben:
resolving dependencies…
looking for conflicting packages…

Packages (30) clucene- libabw-0.1.3-2 libatomic_ops-7.6.10-2 libcdr-0.1.6-2 libcmis-0.5.2-6 libe-book-0.1.3-7 libepubgen-0.1.1-2 libetonyek-0.1.9-2 libexttextcat-3.4.5-2 libfreehand-0.1.2-3 libixion-0.16.1-5 liblangtag-0.6.3-2 libmspub-0.1.4-8 libmwaw-0.3.17-1 libnumbertext-1.0.6-1 libodfgen-0.1.7-2 liborcus-0.16.1-5 libpagemaker-0.0.4-2 libqxp-0.0.2-4 librevenge-0.0.4-3 libstaroffice-0.0.7-1 libvisio-0.1.7-3 libwpd-0.10.3-2 libwpg-0.3.3-2 libwps-0.4.12-1 libzmf-0.0.2-8 lpsolve- rasqal-1:0.9.33-4 redland-1:1.0.17-8 libreoffice-fresh-7.0.4-1

Total Download Size: 154.93 MiB
Total Installed Size: 668.13 MiB

:: Proceed with installation? [Y/n]

Fairly hefty, but easy enough to clean up if I don’t like it, right?

Ok, installed - then launch writer from the menu and I must say it does look like a bit of a pig with freezing progress bars - I had to open conky to watch RAM, it looked like I’d run out it was so slow. Never worked like this before (I think I last had it about 3 months ago).

Theme looks okay, but looks like I’m running an intel atom here. Closing it and relaunching, it still took a good 14 seconds to paint paper on the screen in writer from my 860 EVO (which launches GIMP from cold in under 2 seconds).

Winner here - WPS (because it’s already installed).

Clean up: ❯ trizen -Rns libreoffice-fresh :: Pacman command: /usr/bin/sudo /usr/bin/pacman -Rns libreoffice-fresh

Sorry, no solution from me - I’m done here. I wonder if this is an issue with Java runtime - but I must admit I don’t care enough to work hard at this.

I’m sorry but I’m not interested in that software.

Neither was I until LibreOffice started to mess up - both the stable (still) and fresh options look like they need a CRAY to run properly.

You didn’t tell us which storage device are you using.
For comparison with my system which is older and less powerful (Ivy Bridge, Intel Core i5-3210M, SSD 860 EVO 500GB, 16 GiB DDR3)

I tried to check the exact launch time from terminal:

time libreoffice --writer  --nologo
Warning: failed to read path from javaldx

real	0m1,964s
user	0m1,368s
sys	0m0,142s

It just takes less than 2 seconds to startup.
Anyway I’m using Libreoffice 6.4.7-7.

Share the output of inxi -Fazy

 time libreoffice --writer --nologo
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.

real    2m47.540s
user    0m0.089s
sys     0m0.029s

I’m using a SSD Samsung 970 EVO Plus

1 Like

Install the libreoffice STILL
For now we still in 6.x.x series

Already tried, it takes the same amount of time
actually, it takes more (5 vs 3mins).

    time libreoffice --writer
    Icon theme "ubuntu-mono-dark" not found.
    Icon theme "Mint-X" not found.
    Icon theme "elementary" not found.
    Icon theme "ubuntu-mono-dark" not found.
    Icon theme "Mint-X" not found.
    Icon theme "elementary" not found.

    real    5m23.898s
    user    0m2.120s
    sys     0m0.360s

wait what why ?
do your / partition is in a ssd ?

Yeah. I don’t know what happened, but I removed the STILL version with all the relative (not used elsewhere) libraries and that made the trick.

time libreoffice --writer --nologo
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
real    0m2.788s
user    0m1.469s
sys     0m0.192s

Or that’s what I’d have hoped for, it broke again


w a i t w h a t
Good then :rofl:

Well, it broke again so… I’m even more confused now ahahah

Ok try reinstall libreoffice?

Just tried that, it’s still broken

But i have some question
You used the still version or the frech version
Try just to delete libreoffice and this depencyces
and try sudo pacman -S libreoffice-still

This is a story no one would expect, full of terrible bugs and mythical creatures. A story of heroes and tyrants, of gods and devils.

First I tried by changing the java version to 14. That didn’t work.
Then I uninstalled fresh and installed still, but same as before.
I -Rs still and then installed fresh. A miracle, it worked! I ran a few tests, and then it just GTFO’d me.

I tried the same steps but it didn’t work.
I also tried to remove libreoffice without the dependencies, but it didn’t work either.

New record, 5m40s!

time libreoffice --writer
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.
Icon theme "ubuntu-mono-dark" not found.
Icon theme "Mint-X" not found.
Icon theme "elementary" not found.

real    5m40.083s
user    0m3.137s
sys     0m0.674s
1 Like

Why is your LibreOffice looking for these icon themes?
Are you sure you are using the repo package and not a Flatpak/Snap?

Here’s mine with the repo package of libreoffice-fresh:

[strit@odin ~]$ time libreoffice --writer --nologo
javaldx: Could not find a Java Runtime Environment!
Warning: failed to read path from javaldx

real    0m4,870s
user    0m2,457s
sys     0m0,353s
1 Like

Do a backup of ~/.config/libreoffice and then delete ~/.config/libreoffice
You can always revert if you lost some personal setting.

Yeah, I install through pacman. I’m not sure either on why.

@D.dave I tried just that but nothing changed. I also reinstalled.

The command I used: sudo pacman -Rs libreoffice-fresh && sudo pacman -S libreoffice-fresh

Once you get the issue figured out, LibreOffice can be made to look more modern by going to Tools > Options > Advanced and Enable Experimental features.

Then from Menu > User Interface > Groupedbar
Looks line this: