Lenovo Yoga 500-14ISK Touchscreen not detected

I have a Lenovo Yoga 500-14ISK. The touchscreen works in Windows but isn’t showing up in Manjaro via lsusb, lspci, or inxi. Please help. I am familiar with Linux and bash, but I haven’t messed around with low level configuration and files before.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


Please post the output of the following commands:

sudo timeout 3 libinput debug-events
ls /sys/bus/{acpi,i2c,hid}/devices/
1 Like

@Fabby The output to inxi --admin --verbosity=7 --filter --no-host --width is:

  Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=627b3b47-b880-4200-8cf4-2d279a3a7786 rw quiet splash apparmor=1 
  security=apparmor resume=UUID=2a228369-5b99-4713-9ae0-6efe56039559 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 80R5 v: Lenovo Yoga 500-14ISK 
  serial: <filter> Chassis: type: 10 v: Lenovo Yoga 500-14ISK serial: <filter> 
  Mobo: LENOVO model: Lenovo Yoga 500-14ISK v: SDK0J40679 WIN serial: <filter> 
  UEFI: LENOVO v: D3CN39WW date: 06/26/2018 
  ID-1: BAT0 charge: 30.2 Wh (62.5%) condition: 48.3/52.5 Wh (92.0%) 
  volts: 11.7 min: 11.4 model: LGC L15L3PB0 type: Li-poly serial: <filter> 
  status: Discharging 
  RAM: total: 3.64 GiB used: 2.62 GiB (71.9%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: EA cache: 
  L2: 3 MiB bogomips: 19204 
  Speed: 680 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 680 2: 647 3: 748 
  4: 638 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300 
  Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Lenovo driver: nouveau 
  v: kernel bus-ID: 01:00.0 chip-ID: 10de:1299 class-ID: 0302 
  Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver: 
  loaded: nouveau note: n/a (using device driver) - try sudo/root 
  display-ID: 0 resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d70 class-ID: 0403 
  Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:0e0f class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi 
  v: kernel port: d000 bus-ID: 02:00.0 chip-ID: 8086:3166 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: c000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 
  bus-ID: 1-8:3 chip-ID: 8087:0a2a class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 476.94 GiB used: 21.68 GiB (4.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDSC2KW512G8 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 004C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 369.46 GiB size: 362.59 GiB (98.14%) 
  used: 21.33 GiB (5.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 627b3b47-b880-4200-8cf4-2d279a3a7786 
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%) 
  used: 25.6 MiB (5.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: 2ABA-9241 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 5.87 GiB used: 334 MiB (5.6%) 
  priority: -2 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 2a228369-5b99-4713-9ae0-6efe56039559 
  ID-1: /dev/sda4 maj-min: 8:4 size: 101.12 GiB fs: ntfs label: N/A 
  uuid: 3414C4D714C49D6C 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-8:3 info: Intel Bluetooth wireless interface type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 8087:0a2a class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 39.0 C mobo: 39.0 C gpu: nouveau temp: 41.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 256 Uptime: 42m wakeups: 8 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1257 pacman: 1252 lib: 305 flatpak: 5 
  Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06

@pobrn The output to sudo timeout 3 libinput debug-events is:

-event2   DEVICE_ADDED     Power Button                      seat0 default group1  cap:k
-event7   DEVICE_ADDED     Video Bus                         seat0 default group2  cap:k
-event8   DEVICE_ADDED     Video Bus                         seat0 default group2  cap:k
-event0   DEVICE_ADDED     Lid Switch                        seat0 default group3  cap:S
-event1   DEVICE_ADDED     Sleep Button                      seat0 default group4  cap:k
-event4   DEVICE_ADDED     Ideapad extra buttons             seat0 default group5  cap:k
-event3   DEVICE_ADDED     AT Translated Set 2 keyboard      seat0 default group6  cap:k
-event6   DEVICE_ADDED     ETPS/2 Elantech Touchpad          seat0 default group7  cap:pg  size 98x61mm tap(dl off) left scroll-nat scroll-2fg-edge click-buttonareas-clickfinger dwt-on
-event16  DEVICE_ADDED     SPA8000B (AVRCP)                  seat0 default group8  cap:k

The output to ls /sys/bus/{acpi,i2c,hid}/devices/ is:

ACPI0003:00  device:25	device:4c    IDEA0100:00  INT3472:06   LNXTHERM:00
ACPI000C:00  device:26	device:4d    IMPJ0003:00  INT3472:07   LNXTHERM:01
device:00    device:27	device:4e    INT0000:00   INT3F0D:00   LNXVIDEO:00
device:01    device:28	device:4f    INT0800:00   LNXCPU:00    LNXVIDEO:01
device:02    device:29	device:50    INT0E0C:00   LNXCPU:01    MSFT0101:00
device:03    device:2a	device:51    INT3394:00   LNXCPU:02    PNP0000:00
device:04    device:2b	device:52    INT339B:00   LNXCPU:03    PNP0100:00
device:05    device:2c	device:53    INT33A1:00   LNXCPU:04    PNP0103:00
device:06    device:2d	device:54    INT33A2:00   LNXCPU:05    PNP0A08:00
device:07    device:2e	device:55    INT33A3:00   LNXCPU:06    PNP0B00:00
device:08    device:2f	device:56    INT33D1:00   LNXCPU:07    PNP0C02:00
device:09    device:30	device:57    INT33D3:00   LNXPOWER:00  PNP0C02:01
device:0a    device:31	device:58    INT33D6:00   LNXPOWER:01  PNP0C02:02
device:0b    device:32	device:59    INT33E1:00   LNXPOWER:02  PNP0C02:03
device:0c    device:33	device:5a    INT3420:00   LNXPOWER:03  PNP0C02:04
device:0d    device:34	device:5b    INT3420:01   LNXPOWER:04  PNP0C02:05
device:0e    device:35	device:5c    INT343D:00   LNXPOWER:05  PNP0C04:00
device:0f    device:36	device:5d    INT343E:00   LNXPOWER:06  PNP0C09:00
device:10    device:37	device:5e    INT3440:00   LNXPOWER:07  PNP0C0A:00
device:11    device:38	device:5f    INT3441:00   LNXPOWER:08  PNP0C0D:00
device:12    device:39	device:60    INT3443:00   LNXPOWER:09  PNP0C0E:00
device:13    device:3a	device:61    INT3444:00   LNXPOWER:0a  PNP0C0F:00
device:14    device:3b	device:62    INT3445:00   LNXPOWER:0b  PNP0C0F:01
device:15    device:3c	device:63    INT3446:00   LNXPOWER:0c  PNP0C0F:02
device:16    device:3d	device:64    INT3447:00   LNXPOWER:0d  PNP0C0F:03
device:17    device:3e	device:65    INT3448:00   LNXPOWER:0e  PNP0C0F:04
device:18    device:3f	device:66    INT3449:00   LNXPOWER:0f  PNP0C0F:05
device:19    device:40	device:67    INT344A:00   LNXPOWER:10  PNP0C0F:06
device:1a    device:41	device:68    INT344B:00   LNXPOWER:11  PNP0C0F:07
device:1b    device:42	device:69    INT3471:00   LNXPOWER:12  PNP0C14:00
device:1c    device:43	device:6a    INT3471:01   LNXPOWER:13  PNP0C14:01
device:1d    device:44	device:6b    INT3471:02   LNXPOWER:14  PNP0C14:02
device:1e    device:45	device:6c    INT3471:03   LNXPOWER:15  VPC2004:00
device:1f    device:46	device:6d    INT3472:00   LNXPOWER:16  XXXX0000:00
device:20    device:47	device:6e    INT3472:01   LNXPOWER:17  XXXX0000:01
device:21    device:48	device:6f    INT3472:02   LNXPWRBN:00  ZIC0201:00
device:22    device:49	device:70    INT3472:03   LNXSYBUS:00
device:23    device:4a	ETD0633:00   INT3472:04   LNXSYBUS:01
device:24    device:4b	FPNT_DIS:00  INT3472:05   LNXSYSTM:00


1-0052	i2c-10	i2c-13	i2c-16	i2c-3  i2c-6  i2c-9
i2c-0	i2c-11	i2c-14	i2c-17	i2c-4  i2c-7  i2c-INT33D1:00
i2c-1	i2c-12	i2c-15	i2c-2	i2c-5  i2c-8
  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.`

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m a moderator here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. We won’t charge you more :moneybag: if you make longer posts that combine all required information into one. :grin:

  4. Do you have a compelling reason to be on 5.13 Stable?

  5. That seems rather old: have you tried updating your UEFI firmware yet???


Could you also run

head /sys/bus/acpi/devices/*/modalias


hey sorry im new to markdown formatting. yes im sorry for not providing adequate information but i had no idea how to use inxi and whenever i previously tried using it, i ended up with way too much information about my computer i couldnt make heads or tales of. my UEFI firmare, which i presume means my BIOS version, hasn’t been updated by Lenovo since 2016. this laptop was launched in 2014-16 if my memory serves me right. as for 5.13 stable, I have absolutely no idea. I just installed manjaro, ran sudo pacman -Syu, and started using the laptop. i don’t know what kernel headers etc are, i don’t know how to change kernel versions. all i know is that uname -r shows the kernel version.

UPDATE: I spent half an hour trying to use it in Windows, the hardware is malfunctioning never mind. thanks regardless, fabby and pobrn

Topic closed as the hardware was malfunctioning (Windows had the same issues)