Lenovo T440 trackpad issue: sometimes not working on resume from sleep .. workaround (or maybe fixed?)

Have been experiencing intermittent issues with the trackpad not working on resume, sometimes after a number of sleep cycles and sometimes every time. This also results in a refusal to sleep when in this state.

This has been an issue with at least the past few kernels. I’m on the latest 5.7 now.

Having run sudo modprobe -r psmouse && sudo modprobe -a psmouse all seems good … the trackpad sprang to life & the machine sleeps and wakes normally (an essential feature for me).

Reason for posting is to see if anyone else has (had) this issue and if my above “fix” worked long-term (it’s easy enough to reissue if it doesn’t though).

Cheers!

Have the same issue on my t440s. I’ve found this:
‘adding the psmouse.synaptics_intertouch=0 kernel parameter solves the issue permanently (Tested on T440s’)
here: Touchpad Synaptics - ArchWiki

But unfortunately I have no idea how to add psmouse.synaptics_intertouch=0. Put it here: /etc/sysctl.d/99-sysctl.conf - but it does not work; guess I misunderstood something.

So for now I use shutdown instead of suspend or hibernate when closing the lid.

I will try your solution and see how long it will work.

If you know how to use psmouse.synaptics_intertouch=0, please let me know.

Prost!

I’m not sure either on the kernel parameter stuff, yet. However, the machine has now had about 20 sleep and resume cycles without issue. I’m currently running a system upgrade & will see what happens then.

Will your fix work after a shutdown?

I’m about to find out! Will let you know just after 21:00 GMT if the first suspend/resume has worked & will update this thread again at the end of the night when I get back.

I might need to reapply the fix though as have just completed the system upgrade & rebooted. Will let you know if that’s the case. My machine typically gets 4 suspend & resume cycles per night when I go out. :wink:

First sleep & wake is fine. I’ve now tried this on multiple occasionsns this morning and the trackpad kas re–awakened every time so far, with the machine also sleeping (practically instantly) as desired… If it gives another 3 or 4 today and still holds up tomorrow for another session, I’ll consider it a likely success.

In order to add boot parameters, you need to edit /etc/default/grub and add the options to GRUB_CMDLINE_LINUX

Moved to #support:laptop from #desktop-environments:Plasma as this is a laptop hardware issue, not a Desktop Environment issue

Thanks if this is indeed the case (which it may well be) but as I read it, it’s a Plasma bug which has persisted for a while, This is why I placed it in the KDE Plasma section.

Also, seems to be working after the 3rd sleep/wake (didn’t resume on the third venue last night due to some issues at the last venue).

Oh, I wasn’t aware. Is there an open bug report?

Not sure but will check, in the morning when I can see a bit better! I do know from previous research that this has been complained about before so will post here what I can find on it. Cheers :slight_smile:

… Edited again for tyoos & missed bits … I can’t see … :blush:

I’m tempted to do a series of sleep & wake cycles in the morning but Custard has decided the mouse is her domain tonight so sorry if there was an extraneous post just now.

ETA: as long as I have control of the keyboard, Custard is one of my Feline companions!

FETA: Having been suitably trampled and having done a number of sleep/wake cycles, all appears to be well, so far. Everything connects; no worries about mouse, KB or other external peripherals. Trackpad seems to work fine.

Thx for that hint. Unfortunately the above-mentioned parameters doesn’t work.

Tried:

Effect: Touchpad works but it works bad. Best solution for me seems to be shutdown also mentioned in arch-wiki. :frowning_face:

Update: Tried again

psmouse.synaptics_intertouch=0

this time with update-grub and restart. Now ist works :smiley:

1 Like

Aha! Now let’s see if it persists across sleep and wake cycles. It seems to have done so on my machine; tried a number of times during the night and the machine slept & woke promptly with no issues following the update & reboot, without re-issuing the modprobe commands.

This had been a persistent (and for me at least, rather inconvenient) issue.

Sorry I forgot to add that you have to run update-grub after editing boot options. Glad you figured it out :slight_smile:

No Prob - your hint ‘etc/default/grub’ was great. Happy that it works. :slightly_smiling_face:

1 Like

Go for a long term test now :wink:
By the way, I use cinnamon and I guess I read our touchpad issue is a non solved Kernel-Bug.

I certainly will be doing so. Will let you know how this goes! So far so good, though.

Fine!

But one additional question: Do you have any “cursor jump issues” on your t440?