Lenovo Ideapad + Manjaro (only OS) -> Can't enter BIOS

Hey everyone,

a few days ago I finally received my Notebook (Lenovo Ideapad 5 with AMD Ryzen 4600) with Win 10. I already used Linux Mint before so I installed it and deleted Win 10 (big mistake) to just have Linux Mint on my device. After having several problems I decided to just install another distro -> Manjaro 20.3 (also single boot). Everything works alright so far but I still want to test a few other distros (might try Linux Mint again?) but I just can’t enter the BIOS settings and boot from USB. After holding FN + F2 while starting the Notebook I enter the “Novo Button Menu” where I have 4 Options:

  • Normal Startup
  • BIOS Setup
  • Boot menu
  • System Recovery

Everything does the same thing… NOTHING but booting normally into Manjaro.
After starting the Notebook and pressing ESC I entered the Grub(?) menu. With Linux Mint I could go to the BIOS from there, with Manjaro I can’t (just start Manjaro or Manjaro revovery mode).

All in all, I want to change my OS but it seems that I can’t enter the BIOS and boot from USB.

So what could I do? Uninstall Manjaro and have nothing on the SSD? If yes how?
Can I maybe do something via terminal e.g. change boot loader, restart and boot from usb?

Hope someone can help me haha
Thanks!

https://support.lenovo.com/pe/en/solutions/ht500207

  • Select Boot menu in “Novo Button Menu” and choose the usb drive.
  • Press F12 and select the usb drive.

May i ask which problems you have? Maybe these ones can be solved?

https://wiki.archlinux.org/index.php/Lenovo_IdeaPad_5_15are05

Thanks for answering!

The Problem in short is, that I can neither enter BIOS nor Boot from USB Drive.

All options from the “Novo Button Menu” do nothing. If I click on “Select Boot Menu” my Notebook just boots up Manjaro like if I start the notebook normally. Nothing more, nothing less. Same with every other option.

That is strange… maybe it starts very quick? According to the lenovo site typeing F12 should do the trick to enter the boot menu.

Quote:

  • Turn the PC off.
  • Turn the PC on.
  • The PC screen displays the Lenovo logo.
  • Immediately and repeatedly press (Fn+) F2.

With systemctl reboot --firmware-setup from manjaro you should enter the uefi configuration

2 Likes

Nope doesn’t help because everytime I load into this Menu I mentioned before with those 4 options.

Nothing happens but this messages comes along (in the terminal):

“Cannot indicate to EFI to boot into setup mode: Firmware does not support boot into firmware.”

I read a little trick:

Hold SHIFT and the POWER button to completely shutdown the laptop. :smiley:

Then F2 and F12 should work.

Still same problem.

And don’t get me wrong, F2 and F12 work, the menu where I can choose between (Normal Startup, BIOS Setup, Boot menu, System recovery) displays… BUT if I select Boot menu or BIOS Setup nothing happens and the Notebook boots normally into Manjaro. So it seems like there is no option to get directly into one of those 4 options you always get the menu and can choose one option from there. For me every single option does the same thing -> Normal startup.

And I mean this would’nt be a big problem for now if I could somehow install another OS without using a USB-Device

Anyway it is not a problem of manjaro but rather a problem of the UEFI. Have a look here:

https://support.lenovo.com/pe/en/solutions/ht500216

There are 2 possibilities to enter the UEFI without windows.

And i believe you didn’t set the UEFI optimized for other OS

and it have to be in legacy mode i believe, because this UEFI is made for Windows:

1 Like

Ok let me explain:

The menu where you can select:

  • Normal Startup
  • BIOS Setup
  • Boot menu
  • System recovery

Have to be this, right?


But you need to press F12

to get here:

What is actually the boot menu.

1 Like

First of all thanks for your efforts!

Yes the menu has to be the one in the first picture.

Pressing (FN +) F12 does the exact same thing as F2. The Line “Press F2 to Setup. F12 to Boot Menu” doesn’t even show up I think.

And yes it seems that it has nothing to do with Manjaro specifically. It was the same with Linux Mint. With Linux Mint however I could select UEFI/BIOS Setup in the grub bootloader.

WIth Manjaro I only get this (maybe I can change that?)

What the grub bootloader looked like in Linux Mint:

I entered the BIOS Setup by choosing “System Setup”

% sudo update-grub                                                                                                                                                                          
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.7-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.7-x86_64.img
Found initrd fallback image: /boot/initramfs-5.7-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

Adding boot menu entry for UEFI Firmware Settings …

As you can see it worked for me.

Did you try sudo update-grub ?

1 Like

I tried it now:

% sudo upgrade-grub
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.7-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.7-x86_64.img
Found initrd fallback image: /boot/initramfs-5.7-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: Warnung: Unbekannter Gerätetyp nvme0n1.
done

“Warnung: Unbekannter Gerätetyp nvme0n1” basically translates to:
“Warning: Unknown device type nvme0n1” (my hard drive)

On top of everything I can’t connect to the internet right now for whatever reason…

Another thought: If the UEFI is in legacy mode the command systemctl reboot --firmware-setup will not work, neither the grub-efi.

But you can try a custom menu entry. According to this:
https://wiki.archlinux.org/index.php/GRUB#"Firmware_setup"_menu_entry_(UEFI_only)

You can add this (if not there):

### BEGIN /etc/grub.d/30_uefi-firmware ###
menuentry 'UEFI Firmware Settings' $menuentry_id_option 'uefi-firmware' {
        fwsetup
}
### END /etc/grub.d/30_uefi-firmware ###

to the file /boot/grub/grub.cfg

Then again:

sudo update-grub

1 Like

Sounds promising. However when I try to edit or delete the file I get the no permission warning.

yes you need root permissions:

sudo nano /boot/grub/grub.cfg

1 Like

I tried it with “sudo update-grub” after editing -> Same lines as before, and the new stuff you suggested got deleted

Without “sudo-update-grub” after editing the file -> “error: can’t find command ‘fwsetup’
Press any Key to continue…”