Lenovo ideapad 5i 14 intel graphic issue

Just got a new laptop and wanted to install Linux on it. Currently has win11 and all works ok (so i know the hardware is ok). Whenever I live boot to any live usb (fedora, manjaro, arcolinux, endeavour tested so far) the graphics glitches terribly and it’s even worse when moving the cursor. Screen tears, flickering random colours, completely black

I see some information about disabling PSR in the kernel but all the information seems you have to do this with the os already installed.

i do have a video which may help, if i can post here?

Any advice?

Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
bus-ID: 3-6:2 chip-ID: 13d3:56fb class-ID: fe01 serial:
Display: wayland server: X org compositor: gnome-shell driver:
loaded: i915 note: n/a (using device driver) - try sudo/root
resolution: <missing: xdpyinfo>
Message: Unable to show advanced data. Required tool glxinfo missing.

this output was from a live usb, i cannot even run through the installer because the screen glitches so bad, its even worse when moving the cursor.

Kernel: 5.15.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
Desktop: GNOME 41.2 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.0
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: LENOVO product: 82L3 v: IdeaPad 5 Pro 14ITL6
serial: Chassis: type: 10 v: IdeaPad 5 Pro 14ITL6
Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN
serial: UEFI: LENOVO v: GDCN60WW(V2.05)
date: 12/20/2021
ID-1: BAT1 charge: 27.4 Wh (48.5%) condition: 56.5/56.5 Wh (100.0%)
volts: 11.5 min: 11.5 model: Celxpert L20C3PF1 type: Li-ion
serial: status: Discharging cycles: 2
Info: quad core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
smt: enabled arch: Tiger Lake rev: 1 cache: L1: 320 KiB L2: 5 MiB L3: 8 MiB
Speed (MHz): avg: 751 high: 1146 min/max: 400/4200 cores: 1: 905 2: 623
3: 984 4: 597 5: 557 6: 614 7: 1146 8: 585 bogomips: 38720
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx

Hello and welcome :wink:

Maybe this helps you?

Of course you can try to disable psr aswell:

1 Like

Hi megavolt,
Thanks for all the info. I’ve seen a few bits like this (editing the kernel), but cannot see how to do it from a live usb or windows environment?
Last time I edited the grub file and saved it, I tried to run update-grub but the package was not found (cannot remember the exact error message)

Read the links… :no_mouth:

ah sorry, long day. booting into the live usb now to test :+1:

added intel_idle.max_cstate=1 i915.enable_dc=0 i915.enable_fbc=0 to GRUB_CMDLINE_LINUX_DEFAULT= and tried sudo update-grub but get error
/usr/bin/grub-probe: error: failed to get canonical path of ‘overlay’.
any help appreciated

You are about to write to the ISO Overlay. That is not possible…

Read again…

But you said:

So you need to edit the grub menu (the boot menu), when booting the ISO.

megavolt, thanks so much for this.
scrolled down to the boot option, edit the grub menu, added the psr=0 option then ctrl-x to boot, no graphics glitching at all,
legend :+1:

be back later to try a full install

1 Like

I’ve also got a Lenovo Ice Lake, but not touch screen; had trouble with the trackpad that was a precipitated by a kernel issue. I had to edit kernel parameters to blacklist the elants_i2c module.
But yea, good that you’re doing an install. You’ll get the glitches ironed out, I’m sure.

Will try given suggestions.
Have EliteBook G3 with intel graphics and same problems… Think they began from kernel 5.14 or even earlier one… A lot of workarounds to try to solve the problem, but can’t understand why these patches are not included in the kernel… Downloaded latest xfce edition, but getting frozen screen with washed colors and need to do hard shutdown.

The below fix by megavolt will fix the issue if your using a distro with a version of the linux kernel like Debian 11.
However, For Ubuntu 23.04 and Fedora 38 onwards and new build of Manjaro Or Arch Will work out of the box without any tweaking. (aside from being able to change refresh rate from 90Hz to a lower 60Hz if you have a high refresh rate panel)