LatteDock, Panels & Docks are not showing up

Hi, I have been using latte-dock for some time. However, after starting my system, the latte-dock dock was gone. I tried doing
latte-dock --replace
to no avail (the console just stood blank). I then tried removing and reinstalling with:
sudo pamac remove --no-save latte-dock
sudo pamac install latte-dock.
Additionally, I also tried
killall latte-dock
to force restart the process. I have also tried deleting ~/.config/latte/ but to no avail. All returned no results. However, I noted that the latte-dock process is running and that when I try to use KDE’s built-in “Add Panel” (when right-clicking on the desktop), I also cannot add that (meaning it doesn’t show up).

Any help? Thank you very much!

Hello how are you, I am sorry to inform you that Latte-Dock was abandoned by its developers and KDE Plasma adopted it. Therefore, it has stopped launching new versions for a few years and is exposed to constant errors. And it is already probable that the installation can even give problems due to the antiquity of the version. But there are alternatives like Plank and Cairo Dock.

Ok, thank you for the reply! I will see the alternatives you listed. This confuses me because it happened so sudden and the fact that now I can’t even add panels that are not coming from LatteDock (as mentioned in my post).

1 Like

I also like to add one more thing:

This post is also really relevant to my situation (in the inclusion of the media keys not working):

Ok, follow up post, I fixed it!

For some reason, I came across the output log of restarting KDE Plasma with killall plasmashell then plasmashell & showed that it was missing “lib-pipewire.” It seemed as though the previous reinstallation of manjaro-pulse over manjaro-pipewire broke it.

So I simply reinstalled manjaro-pipewire and removed manjaro-pulse, rebooted and all the docks came back!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.