Latte-dock not showing up and laptop sound buttons not working on startup

I recently did a fresh install of Manjaro on my laptop. I am using Plasma and the Git version of Latte-dock.
Every time I turn on the computer, Latte does not show up. If I hover the mouse over the region where Latte should appear and click the right button of the mouse, Latte’s menu shows up and I can change the Layout. When I do it, Latte shows up.
However, all sound buttons of the laptop (mute, volume up/down, and microphone mute) do not work. In order to make them work, I have to log out and log in again. Most of the times, doing so solves both problems, i.e., Latte shows up on the correct layout and the sound buttons do work;
but sometimes I have to repeat the procedure, that is, to log out and log in three or four times until everything works.
I tried to remove Latte and install the version existent in the Official Repositories, but the problem persists. I don’t know if the problem is related to Latte-dock or if there is something wrong with my installation (wrong order of starting up processes, for example) and the weird behaviour of Latte and the sound buttons are just consequence of it.
This is very annoying and inconvenient, because it takes much more time to start the laptop than it would take if everything was working fine.
Any clue on what might be causing these problems?

Here is some basic information about my system:

OS: Manjaro 20.1.1 Mikah
Kernel: x86_64 Linux 5.8.11-1-MANJARO
Packages: 1767
Shell: zsh 5.8
Resolution: 1920x1980
DE: KDE 5.74.0 / Plasma 5.19.5
WM: KWin
GTK Theme: macOS-Dark-6.0-beta-dark [GTK3]
Icon Theme: McMojave-circle-dark
Disk: 785G / 1,4T (60%)
CPU: Intel Core i7-2640M @ 4x 3.5GHz [50.0°C]
GPU: Mesa DRI Intel(R) HD Graphics 3000 (SNB GT2)
RAM: 4028MiB / 15895MiB

Basic info doesn’t help a lot… It’s better to just post the output of inxi -Fza

For example, your basic info doesn’t tell us what laptop you’re using, which could be useful to help with:

Thanks for your reply.
Here is the output of inxi -Fza:

System:
  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=7237cc4d-9ab7-410c-90c4-b8c90e2b10df rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 info: latte-dock wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 4180Q3U v: ThinkPad T420 serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: LENOVO model: 4180Q3U serial: <filter> UEFI [Legacy]: LENOVO 
  v: 83ET67WW (1.37 ) date: 11/28/2011 
Battery:
  ID-1: BAT0 charge: 34.9 Wh condition: 42.8/56.2 Wh (76%) volts: 12.5/10.8 
  model: SANYO 45N1001 type: Li-ion serial: <filter> status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i7-2640M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  L2 cache: 4096 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 22337 
  Speed: 797 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1294 2: 841 3: 1096 
  4: 1018 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Lenovo ThinkPad T420 driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0126 
  Device-2: Chicony integrated camera type: USB driver: uvcvideo bus ID: 1-1.6:5 
  chip ID: 04f2:b221 
  Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1980 s-dpi: 96 s-size: 506x522mm (19.9x20.6") 
  s-diag: 727mm (28.6") 
  Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 131 size: 310x170mm (12.2x6.7") 
  diag: 354mm (13.9") 
  Monitor-2: VGA1 res: 1920x1080 hz: 60 dpi: 96 size: 510x290mm (20.1x11.4") 
  diag: 587mm (23.1") 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2) v: 3.3 Mesa 20.1.8 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520 
  driver: e1000e v: 3.2.6-k port: 5080 bus ID: 00:19.0 chip ID: 8086:1502 
  IF: enp0s25 state: down mac: <filter> 
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel 
  port: efa0 bus ID: 03:00.0 chip ID: 8086:0085 
  IF: wlp3s0 state: up mac: <filter> 
  IF-ID-1: wwp0s29u1u4i6 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.36 TiB used: 784.24 GiB (56.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 3B6Q scheme: MBR 
  ID-2: /dev/sdb vendor: HGST (Hitachi) model: HTS541010A9E680 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm 
  serial: <filter> rev: A7G0 scheme: MBR 
Partition:
  ID-1: / raw size: 65.37 GiB size: 63.84 GiB (97.67%) used: 32.03 GiB (50.2%) 
  fs: ext4 dev: /dev/sda1 
  ID-2: /home raw size: 400.39 GiB size: 393.11 GiB (98.18%) 
  used: 171.37 GiB (43.6%) fs: ext4 dev: /dev/sda2 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 3185 
Info:
  Processes: 230 Uptime: 27m Memory: 15.52 GiB used: 3.11 GiB (20.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1768 
  pacman: 1761 lib: 395 flatpak: 0 snap: 7 Shell: Zsh v: 5.8 running in: konsole 
  inxi: 3.1.05

It might be important to know that my previous installation in this laptop was also Manjaro KDE with the GitHub version of Latte-dock (all kept updated), and I never saw this strange behaviour before. It only started after the recent fresh install of the distribution.

https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_T420#Media_Keys

Media Keys that Do Not work out of the box:

You must find a workaround and bind the keys yourself for the rest of them.

xbindkeys and xbindkeys_config-gtk2AUR can be a solution for media keys that are not working. This solution also allows you to rebind the ThinkVantage button and certain FN layer shortcuts (the blue logos on the keyboard).

Thanks for your reply and suggestions, but that information is not accurate.
I can state that all sound buttons work out of the box in ThinkPad T420. I have this laptop for more than one year, always running Manjaro KDE, and everything has worked fine until I recently reinstalled Manjaro.
Moreover, they do work after I log out and log in, as explained in the first message, without the need of any workaround, provided I change the layout of Latte-dock first. The problem is of different nature.