Latest update broke rofi and rofimenu

Hi,

Just a feedback about today’s update. Rofimenu only shows the favourites and rofi doesn’t work at all.
Also updated my laptop to see if it will affected and same thing happened there too.

2 Likes

Can you run them from terminal to see what output you are getting?

@airclay, seems to be issues incoming, ping me if you need some packages rebuilt.

When I ran
rofi -show run
got this output.

Mode run is not enabled. I have enabled it for now.
Please consider adding run to the list of enabled modi: modi: combi,run.

(process:26383): View-ERROR **: 00:25:36.664: Mode-switcher can only be added once to the layout.
zsh: trace trap (core dumped)  rofi -show run

When I ran just
rofi -show
only got

(process:27633): View-ERROR **: 00:28:40.513: Mode-switcher can only be added once to the layout.
zsh: trace trap (core dumped)  rofi -show

Running rofimenu via terminal does the same thing with Manjaro logo button.

Okay, seems that the rofi syntax has changed. @kainonergon, master of rofis, do you have working rofi configuration after the update?

1 Like

On my installation rofi works fine (with my own configuration), but rofimenu does not. I’ll try to investigate.

EDIT. rofimenu works OK when navigated with keyboard, but selection of modi with mouse doesn’t work or works with some glitches.

EDIT 2. I’ve found where rofi version 1.6.0 has a different behavior compared to 1.5.4. When you switch from custom modi to some other modi with mouse, version 1.6.0 selects the first entry. That doesn’t happen if modi is switched with keyboard. Version 1.5.4 works as expected in both cases so that no entry is selected.
I think it’s a bug.

EDIT 3. I’ve installed rofi-git from AUR (Version: 1.6.0-9-g6ba878e4) and found that it doesn’t have that issue. I suppose that bug is already corrected, so we should just wait for the next rofi release.

MORE. I also checked default rofi config from manjaro-bspwm-settings:

rofi -config /etc/skel/.config/rofi/config.rasi -show

It works but maybe needs some adjustments. Icons are smaller then with 1.5.4 version (theming change: add element-icon { size: 2.5ch ; } to config. Also mode-switcher is on and shows Exec ->. Maybe it should be explicitly set to be hidden in config.

2 Likes

I’ve adjusted rofimenu default theme on Github according to 1.6.0 theming changes.

3 Likes

This one works, thanks for checking. By the way, where can I find bspwm-settings? I assume it’s not bspwmrc.

Thank you very much!

@airclay we should make rofimenu call a global configuration file so that we can fox via normal pacman updates when it breaks. I’ll try to repackage this tonight.

1 Like

I think I’ll be able to use new rofi theming so that rofimenu has real icons in custom modi instead of font icons. Like this:
rofi-2020-09-12-2044-00000

3 Likes

I ment manjaro-bspwm-settings package.

Hi, on my system the /etc/skel/.config/rofi/config.rasi file gives the exact same error (Mode-switcher can only be added once to the layout.), any advice? I’m new around here, not sure if I need to make a new thread to address this

Rofi-scripts (including rofi-menu) now updated on all branches. Now we just need to debug the default theme in bspwm edition and move it to a global install location…

I’ve made a commit on Github so that rofimenu has icons in custom modi. Font icons remain only in modi names. Maybe some testing is needed. It works on my system with rofi-git, but has that mouse navigation glitch with version 1.6.0.

I’m now building overlay rofi from rofi.git for repos. I’ll update rofimenu again on the same upload

1 Like

Now uploading updated:

  • Rofi (from rofi-git)
  • rofi-scripts (rofimenu with icons)
  • manjaro-bspwm-settings (for improved rofi theming as suggested)

@airclay, sorry for messing with your edition, I hope this turns out fine :sweat_smile:

2 Likes

Hi. I got the updates but sadly the current situation still persists. Do I need to do something extra?

Yes, you need to copy the changed configuration files from skel to your $HOME

cp -r /etc/skel/.config/{rofi,rofimenu} ~/.config

Or something like that. That command should prompt you to override those files.

3 Likes

Thank you very much for the shortcut. :slight_smile:

Rofi is fixed now but rofimenu is still broken.

scrot

New rofimenu version requires new config files. So try to remove old ones. New config should be generated automatically.

EDIT. For some reason if font is set to Terminus 22px in rofimenu.rasi file the result is as in your screenshot. But it works OK with Terminus 24px or Terminus 18px.

So it seems that the default rofimenu config should be changed.

EDIT 2. Using genuine icons instead of font icons in custom modi requires new rofimenu.config file. Default one is generated on rofimenu start if ~/.config/rofimenu/rofimenu.config file is missing. So @airclay or @Chrysostomus, please, adjust rofimenu.config in manjaro-bspwm-settings to the new version.

4 Likes

I’ve changed the font as described and removed ~/.config/rofimenu/rofimenu.config & restarted but rofimenu is still showing as per @Mitsukuni’s screenshot (though with the nice new icons).

Do I need to remove any other configs? Or do I need to update the Terminus font somewhere other than ~/.config/rofimenu/rofimenu.rasi?

Thanks in advance for any guidance.