Latest update (01.01.2021) - where did kernel 5.7 go and how to bring it back?


I just installed the latest updates and found that there is no 5.7 kernel anymore in Manjaro Settings Manager. Kernel 5.7 was the only one that was at least somehow decent for my Tuxedo Aura 15. This is an AMD 4700U with vega graphics with a dual monitor setup.

ALL other kernel were having problems:

  • graphics crashing randomly
  • 2nd monitor disappearing (when switching inputs)
  • backlight problems

So 5.7 was ‘the thing’ with my setup. Stable without the problems mentioned above.

Is it possible to get back kernel 5.7 and how do I ‘pin’ it so that updates won’t remove it again?

I’l all for rolling releases - that is for apps - but not the kernel.

5.7 is EOL (End Of Life)

If your hardware doesn’t work best with newer Kernel, try the LTS one

I thing that is a bad idea, because Kernel and linux-firmware came sometime together and the firmware could cause errors when used with a kernel that has EOL status

LTS doesn’t support the latest amd hardware. I tried that already. In matter of fact I tried all the kernel that were available a week ago - and only 5.7 was working as it should.

So you are saying there is no way I can get a stable system? I really doubt that Manjaro will fix all the kernel problems with amd until monday when I need the system for work. What was the problem of leaving 5.7 in?

I tried 5.4 (LTS) just for kicks… The system boots - but there is no X… rebooted the system twice just in case.

Err… I wanted to upload a dmesg… Is there no way to attach files?

Can you please give a hint on how to install 5.7 and the matching linux-firmware? I really need the system ASAP.

Kernel 5.7 has been removed from the repos so unless you use/build a custom kernel like zen I don’t think you can. Looking at your hardware kernel 5.10 should work as should 5.4

As said:

  • tried 5.4 20 minutes ago it does not boot into X - black screen, I can only log on console. 5.4’s changelog is from 2019 - the system I have (Tuxedo Aura) was probably not even conceived on paper. AMD released those CPUs in 2020.
  • problems with 5.10: after resume from suspend there is no keyboard (can’t type)… each time I switch input on dual monitor setup 2nd screen either disappears or system crashes. I was running 5.10 when it was still rc one week ago and it was crashing twice a day - I don’t think there could have been that many changes in betweek. I expect it to crash at least twice a day.

What do you mean ‘like zen’?

There’s custom kernels like zen kernel and xanmod kernel which can be used on manjaro. I’ve never used them myself but you don’t have nvidia drivers to worry about so shouldn’t be too complicated

You should still have the old kernel packages in your local pacman cache and can downgrade from there, see:


I always check manually each upgrade beforehand for mesa or linux, because those “love” to break things…

Guess: a BIOS-problem?
The latest kernel 5.10.4-1 is more stable (at least on the testing-branch) - I run a Ryzen 7 3700X
with boot-param “acpi_enforce_resources=lax” and “noapic” to tame this horse.

I got at least linux57-5.7.19-2-x86_64.pkg.tar.zst back… though acording to the instructions I should also downgrade modules and headers… but I don’t have those packages in the cache… so I guess if I want to compile some dkms module it won’t work.

Is there no Manjaro archive - like Arch has?

Could someone from Manjaro check some backups and post the links to 5.7 related packages?

My first upgrade :wink: I guess I was too confident :wink:

Trying to restore kernel 5.7 is a meander and leads to nowhere. You could not update any package then without risking to break your system. The only chance you have is to find one of the kernels being currently supported as basis and then to eliminate the issues, step by step.

It needs to be said, unfortunately there is some hardware which is either no longer or not yet perfectly supported. The reason lies mostly in the sub-optimal hardware drivers, so it’s not really linked to the distribution. Newer hardware is getting more and more supported over time and some older hardware sometime won’t be supported anymore, that’s how it is, get used to it. :wink:

1 Like

I did not blame the distribution… but linux/drivers/hardware compatibility are known issues - drivers take years (like 5) to get proper support and then they are obsoleted :wink: So if for someone a specific kernel is working for any reason why don’t just keep it. 5.10 might not work on this hardware for years.

Also the attitude “we do software” and “kernel is as it is” leads nowhere - you can’t run software without a kernel. I did buy ‘linux supported’ hardware (i.e. per Tuxedos words) that should just work… in reality it works like all other hardware out there… if by chance the driver works, ok - otherwise you’re on your own.

Also I don’t understand how 5.4 LTS works just as it is - while 5.7 is a meander and leads to nowhere? When was 5.4 LTS last updated?

If you didn’t had modules or headers in the first place, you don’t need to downgrade them. I can’t find either of them in my cache as well.

Again, the decision if a kernel is maintained is done by the developers of the kernel, this has nothing to do with the distro. Blame the kernel developers if you think this helps… :rofl:

Is that so, did you try contacting tuxedo? I mean they provide official support for openSuse and Ubuntu and eventually those will update to 5.10 (which will be the next LTS). So I figure they will have an eye on this kernel. Maybe they can provide you with some kernel configs or other tips?

Blame certainly won’t help, though I’d really like to know who those developers are - maybe I can make a voodoo doll or something :wink: