Laptop Screen Brightness is Fixed to 100% on kernel 5.9

My laptop’s (Lenovo Legion Y520) screen backlight brightness adjustment doesn’t work with kernel 5.9.10-1. It’s fixed at 100% all the time. Slider moves but brightness doesn’t change.

Tried echo 500 > /sys/devices/pci0000:00/0000:00:02.0/drm/card1/card1-eDP-1/intel_backlight/brightness but it only makes the brightness slider change.Not the actual brightness.

No issues with LTS kernel or 5.8. But I game on this machine and having fsync makes a difference for me. So LTS kernel is not something I prefer. 5.8 is fine and I use it at the moment but it’s EOL now and I don’t want to spend a lot of time on it.

While I was looking around I found that on LTS and 5.8 max_brightness value is set to 7500 and brightness works as expected. But only in 5.9 max_brightness is 1023 and it doesn’t work.

I’m not sure if it’s the right place to open this thread but I wanted to report this issue somehow. And if there is a solution other then waiting for a kernel update, I would be appreciated if you let me know.

My inxi -Fxxz output:

System:    Kernel: 5.9.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: GNOME 3.38.1 tk: GTK 3.24.23 
           wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 80WK v: Lenovo Y520-15IKBN serial: <filter> Chassis: type: 10 
           v: Lenovo Y520-15IKBN serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40688 WIN serial: <filter> UEFI: LENOVO v: 4KCN45WW date: 01/11/2019 
Battery:   ID-1: BAT0 charge: 38.7 Wh condition: 38.7/45.0 Wh (86%) volts: 12.8/11.5 model: SMP L16M3P24 serial: <filter> 
           status: Full 
CPU:       Info: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817 
           Speed: 2800 MHz min/max: 800/2800 MHz Core speeds (MHz): 1: 2800 2: 2800 3: 2800 4: 2800 5: 2800 6: 2800 7: 2800 
           8: 2800 
Graphics:  Device-1: Intel HD Graphics 630 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b 
           Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Lenovo driver: nvidia v: 455.45.01 bus ID: 01:00.0 
           chip ID: 10de:1c8c 
           Device-3: Acer EasyCamera type: USB driver: uvcvideo bus ID: 1-6:4 chip ID: 5986:06b0 
           Display: x11 server: X.org 1.20.9 compositor: gnome-shell driver: modesetting,nvidia 
           alternate: fbdev,intel,nouveau,nv,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.2.2 direct render: Yes 
Audio:     Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 
           Sound Server: ALSA v: k5.9.10-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi v: kernel port: 4000 bus ID: 03:00.0 
           chip ID: 8086:3166 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Lenovo driver: r8169 v: kernel port: 3000 
           bus ID: 04:00.0 chip ID: 10ec:8168 
           IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 1.42 TiB (69.4%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000L2 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           serial: <filter> 
           ID-2: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB speed: 6.0 Gb/s serial: <filter> 
Partition: ID-1: / size: 116.18 GiB used: 84.07 GiB (72.4%) fs: ext4 dev: /dev/nvme0n1p7 
Swap:      ID-1: swap-1 type: partition size: 2.00 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 40.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 256 Uptime: 26m Memory: 15.53 GiB used: 1.87 GiB (12.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           alt: 9 clang: 11.0.0 Packages: 1753 pacman: 1719 flatpak: 31 snap: 3 Shell: Bash v: 5.0.18 
           running in: gnome-terminal inxi: 3.1.08
1 Like

Edit your grub settings and add the parameter i915.enable_dpcd_backlight=0,this is necessary for some reason in 5.9.

4 Likes

I will try it when I get back home tonight , thanks.

Some claim that 5.9.11 has the issue fixed. Currently in testing branch.

It worked for me, thanks!

1 Like

I’ll check it as soon as it’s on stable, Thanks! Also I can test it on testing if you need more testers, but I’m a bit busy nowadays so I can’t do it immediately

I switched to testing to test,It’s not working for me yet,I still need the parameter.

5.9.11 is in stable now and I tried it but it doesn’t solve the problem for me. I still need @XRaTiX 's workaround.

Same here.

Plus, on my Thinkpad T450, with 5.9.11 Kernel my display won’t shut down for inactivity

I also cannot currently adjust brightness on Lenovo Yoga 2 13, and editing grub settings also didn’t work.

System:    Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 
           wm: xfwm4 dm: LightDM Distro: Manjaro Linux

Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16

Did you run sudo update-grub after you edited etc/default/grub?

I got an error:

/etc/default/grub: line 52: i915.enable_dpcd_backlight=0: command not found

Line 52? Show how you have the grub file here

I also have the same issue and problems as Benny.

Figured it out by putting the parameter on line 6 in /etc/default/grub and then updating grub with the command sudo update-grub, and then reboot. Thanks.

GRUB_CMDLINE_LINUX="i915.enable_dpcd_backlight=0"
5 Likes

Worked for me, thank you!

Made an account to say that this worked for me too on a Dell 7250 with Intel graphics. Thanks!

will this work on my laptop which has Dual graphics. (Asus Zenbook pro duo)
Intel + Nvidia ?

It will probably. Mine has intel + nvidia too and it works for me. You can try it without permanently changing anything. In GRUB menu press e key and add that parameter at the end of the related line. If it breaks something don’t worry after you reboot, everything will turn back to default. If it works great. Just add it to your /etc/default/grub and do sudo update-grub and it will be permanent.

1 Like

thanks. I added at the end of this line below. i915.enable_dpcd_backlight=0
But it didn’t have any effect ! Please suggest

https://i.imgur.com/VAL08NT.jpg