Laptop overheating when in sleep mode

I’ve installed Manjaro on a Dell XPS 9720 laptop in dual boot with windows. Ever since installing, whenever I put the laptop in sleep (either with the gui buttons or command) the laptop starts heating up by a lot. I suspect this is due to some process not ending when sleeping, and it might be related to another annoying issue I can’t seem to fix: whenever I power off the system, it always hangs on three systemd-udevd processes not ending, and I have to turn it off manually with the power button (even with no USB devices connected. I’ve tried everything I could think of, like lowering udevd’s timeout to a really low value, but nothing so far seems to work. This makes my laptop almost unusable, since I travel a lot and even if I forget to power it off once when in my backpack the heat is enough to make me worried the battery is getting damaged. What could I try? Are there some pointers or suggestions to debug this? I haven’t been able to find anything. Thanks!

Here are my system’s informations:

  Kernel: 6.0.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.0-x86_64
    root=UUID=c0382431-3b04-4e3b-82d0-8eec3d9f6e2c rw ibt=off quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_wayland vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9720 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0W7GHH v: A00 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 03/08/2022
  ID-1: BAT0 charge: 74.0 Wh (100.0%) condition: 74.0/95.1 Wh (77.9%)
    volts: 12.9 min: 11.4 model: SMP DELL 01RR3YM type: Li-poly serial: <filter>
    status: full
  RAM: total: 31.04 GiB used: 6.37 GiB (20.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: 12th Gen Intel Core i9-12900HK bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x421
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2082 high: 2900 min/max: 400/6300:6400:3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 2900 2: 530 3: 538
    4: 2900 5: 2900 6: 2900 7: 480 8: 2900 9: 577 10: 2900 11: 2900 12: 552
    13: 672 14: 2900 15: 2900 16: 2900 17: 2900 18: 2900 19: 2900 20: 607
    bogomips: 116780
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
    f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap
    smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 515.76 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-10) arch: Ampere code: GAxxx process: TSMC n7
    (7nm) built: 2020-22 bus-ID: 0000:01:00.0 chip-ID: 10de:2520
    class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:2 chip-ID: 0c45:6a15 class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
    unloaded: nouveau alternate: fbdev,nv,vesa dri: iris gpu: i915,nvidia
    display-ID: 0
  Monitor-1: eDP-1 res: 2560x1600 size: N/A modes: N/A
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 22.1.7
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Sound API: ALSA v: k6.0.0-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.58 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:4
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 1.87 TiB used: 133.1 GiB (6.9%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SL08G size: 7.4 GiB block-size:
    physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: MBR
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC801 NVMe 2TB
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 51002141 temp: 44.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 976.56 GiB size: 960.16 GiB (98.32%) used: 133 GiB (13.9%)
    fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A
    uuid: c0382431-3b04-4e3b-82d0-8eec3d9f6e2c
  ID-2: /boot/efi raw-size: 200 MiB size: 196 MiB (98.00%) used: 99.5 MiB
    (50.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: ESP
    uuid: 2ADE-507B
  Alert: No swap data was found.
  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 256 MiB fs: vfat label: boot
    uuid: 7616-4FD8
  ID-2: /dev/mmcblk0p2 maj-min: 179:2 size: 7.15 GiB fs: ext4 label: rootfs
    uuid: 87b585d1-84c3-486a-8f3d-77cf16f84f30
  ID-3: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p3 maj-min: 259:3 size: 910.43 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-5: /dev/nvme0n1p4 maj-min: 259:4 size: 1.01 GiB fs: ntfs
    label: WINRETOOLS uuid: 0C5A195C5A1943BC
  ID-6: /dev/nvme0n1p5 maj-min: 259:5 size: 17.97 GiB fs: ntfs label: Image
    uuid: 761C19C11C197CF5
  ID-7: /dev/nvme0n1p6 maj-min: 259:6 size: 1.43 GiB fs: ntfs
    label: DELLSUPPORT uuid: A026A74726A71D72
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-6:2 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6a15 class-ID: 0e02
  Device-2: 1-9:3 info: Shenzhen Goodix USB2.0 MISC type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:63ac class-ID: ef00 serial: <filter>
  Device-3: 1-10:4 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-5: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-6: 6-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Use of uninitialized value $unit in concatenation (.) or string at /usr/bin/inxi line 24087.
Use of uninitialized value $value in concatenation (.) or string at /usr/bin/inxi line 24087.
  Src: /sys System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Power: 12v: N/A 5v: 5 3.3v: N/A vbat: N/A
  Processes: 561 Uptime: 1m wakeups: 184 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 alt: 11
  clang: 14.0.6 Packages: 1781 pm: pacman pkgs: 1759 libs: 362 tools: pamac
  pm: flatpak pkgs: 0 pm: snap pkgs: 22 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.22

it looks like its not even properly suspended …
post output from:
cat /sys/power/state
cat /sys/power/mem_sleep

First of all, thanks for the help!

cat /sys/power/state
freeze mem disk
cat /sys/power/mem_sleep

Let me know what else I can try!

open this file:
kate /etc/environment
and add there this line:
save it. it will disable the kwin/qt logs, so that logs are more readable for when we need them.

and it looks like your laptop doesnt support ‘deep’ suspend… so the overheating is probably because of nvidia …
but first check in your bios that AHCI is enabled - search under SATA/RAID options. If ahci was indeed disabled (you need to enable it), suspend your pc again and check if enabling AHCI helped.

AHCI was indeed disabled but enabling it doesn’t seem to help, the two outputs you asked for stayed the same and after some quick tries the laptop still heats up in sleep and when I opened the lid back up it almost looked like it was already on. I’ve also noticed that when in sleep the screen doesn’t completely go black, but stays on with a blinking _ at the top left corner. What else could I try?

post output from:
mhwd -l && mhwd -li

mhwd -l
> 0000:01:00.0 (0300:10de:2520) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
          video-nvidia            2021.11.04               false            PCI
    video-nvidia-470xx            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.11.04               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.11.04               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

❯ mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

so install this:
pamac build envycontrol
then run this:
sudo envycontrol -s integrated
it will prompt you for reboot, so do it. This disables nvidia card, so test if it helped and we can confirm that it is because of nvidia… also try with the 5.15 kernel.

Tried this and verified nvidia drivers aren’t running with nvidia-smi. The behavior is somehow worse, since clicking the sleep button completely freezes the system and the only way to get out of it is a hard reboot. Tried with 5.15 as well. Interestingly, it seems that if I let the PC go to sleep on its own due to inactivity the screen goes fully black without the blinking _ I described earlier. Any logs that can help? I’d also like to note that, if possible, I’d still like to keep nvidia drivers, since I regularly work with cuda and it’s one of the reasons why I got this laptop in the first place, so solutions that allow me to keep the proprietary drivers are appreciated. Thanks!

this was only for testing purposes… so you can uninstall it:
pamac remove envycontrol
then create this file:
kate /etc/modprobe.d/nvidia.conf
and add there these 2 lines:

options nvidia NVreg_EnableS0ixPowerManagement=1 NVreg_S0ixPowerManagementVideoMemoryThreshold=10000
options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

save the file;
reboot and also just to be sure verify in bios that AHCI is still enabled, and test

Thank you very much! You’ve been very kind, I really appreciate it. At first glance this seems to work, the screen blackens properly and the keyboard backlight goes off, which didn’t always happen before. I’ll do some more testing this evening and see if the laptop does overheat, but I’m hopeful it won’t.

If I could steal just a bit more of your time, do you also have some pointers on how I could fix my shutdown issue? I still have to long press my power button to power off because the system hangs on three systemd-udevd processes. Could it have something to do with the Warning: No installed USB configs! I got earlier from mhwd?

does this shutdown ‘freeze’ happens only when shuting down, or also when rebooting?

and these are not related to the issue, i and others have the same warning when they run mhwd -li, so dont pay attention to it…

Happens with both poweroff and reboot, also it seems like other XPS 9720s have this issue, at least according to this post from a while back, and subsequent kernel upgrades didn’t fix it.

Also the sleep doesn’t seem to be fixed after all. It works perfectly at times, but then other times it completely freezes the PC and I can only hard reset, so it seems a bit unstable

so open this file:
kate /etc/modprobe.d/nvidia.conf
and add this # to this line:

options nvidia NVreg_EnableS0ixPowerManagement=1 NVreg_S0ixPowerManagementVideoMemoryThreshold=10000
#options nvidia NVreg_PreserveVideoMemoryAllocations=1 NVreg_TemporaryFilePath=/var/tmp

save it and reboot and test. Before reboot provide logs:
journalctl -b0 -p4 --no-pager
journalctl -b-1 --no-pager | tail -30

and boot with the 6.0 kernel since you have new hardware

Logs are always helpful… (you can even heat your apartment with logs :crazy_face:)

As @brahma mentioned:

or even better a full log, so that one can investigate what exactly blocked the process.

journalctl --boot -1 --no-pager

Feel free to upload it somewhere and link it here. This looks like a well known issue.

The arch wiki has more on this machine. Since the firmware update utility seems unreliable it might be a good idea to manually check for firmware/bios updates. Dell XPS 17 (9720) - ArchWiki

WHAT are you doing ???
@brahma think twice !


Soo I re-enabled the drivers with sudo envycontrol -s hybrid and now neither Manjaro nor Windows are able to boot, so I kinda need some help here. Whooops!
Manjaro gets stuck at clean fliles/blocks, and windows gives me inaccessible boot device. I’m not too experienced with this so I need some pointers on how to troubleshoot this and avoid making thinks worse. Thanks!

Dual boot

Please note that changing from “RAID” to “AHCI” can break the default Windows installation and require a complete reinstall. Usually running windows own startup repair utility however fixes this issue in most cases. Another alternative is to follow this guide.

Dell XPS 17 (9720) - ArchWiki .

1 Like