Kyocera MFP won't scan with sane-airscan

Hi everyone, since I switch to Manjaro I can’t make my scanner working. It worked very easy and without problems on EndeavourOS before. Printing via Cups is fine.

My Notebook can find the scanner.

scanimage -L                                                                                                                                                                                 
device `kyocera_wc3:' is a Kyocera ECOSYS M5521cdn A4
device `airscan:w0:Kyocera ECOSYS M5521cdn' is a WSD Kyocera ECOSYS M5521cdn ip=, 2003:f3:9701:d400:217:c8ff:feb8:bc31

If I try to scan via sane-airscan I get the error.

scanimage --device 'airscan:w0:Kyocera ECOSYS M5521cdn' --format=tiff --output-file test.tiff --progress
scanimage: sane_start: Device busy

Today I also try the kyocera-sane package from AUR but it’s not working too. In this case my scanner starts scanning, but then abort.

scanimage --verbose --device 'kyocera_wc3:' --format=tiff --output-file test.tiff --progress                                                              
scanimage: sane_start: Document feeder out of documents

I hope someone can help. I spent some hours already with this problem, and I don’t have an idea what else I can do.

I found the solution in another thread Klick

I just install the metapackage scanner-supportfrom AUR and after a reboot I can scan without any problems.

On my system the package just adds the ipp-usb package. Everything else was already on my system installed. The ipp-usb package was already on my system before. My Scanner doesn’t work also, so I remove it, because I expect I don’t need it with my network scanner.

It is also interesting that the Airscan Protocol changes from WSD to eSCL after installing scanner-support.

scanimage -L                                                                                                                                                                                 
device `airscan:e0:Kyocera ECOSYS M5521cdn' is a eSCL Kyocera ECOSYS M5521cdn ip=

Finally, I don’t know what the metapackage scanner-support does different than manual installation or why it works now. But my problem is solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.