Krdc 24.02 + freedp 3.1 or 3.4 is not working

Manjaro Testing, current version. There was a problem after last updating.

  1. upgraded krdc (23.08.5-1 → 24.02.1-2)
  2. upgraded freerdp (2:2.11.4-1 → 2:3.4.0-5)
  3. It is impossible to select rdp protocol in the krdc settings (empty place)
  4. krdc rdp://user@host from console: QLibraryPrivate::loadPlugin failed on “/usr/lib/qt/plugins/krdc/”
  5. /usr/lib/qt/plugins/krdc/ is present.

any ideas??

Just for the sake of verifying I tested krdc and wasn’t able to use either - it depends on the version of freerdp installed and I have the package freerdp2 synced.

I believe it is an upstream kde issue - but I cannot be sure - but I would start by checking the to see if already reported.

I ran into issues with krdc a while back - created a script template for it.

My script stalled when the update came in unstable branch.

After some troubleshooting I found that we have two packages freerdp2 and freerdp.

Syncing the former restored my script functions by providing the usual xfreerdp and wlfreerdp binaries

I have freerdp working by using a script.

When you use Plasma and Wayland the wlfreerdp3 is deprecated and it is recommend to replace with sdl based client (I haven’t got that part myself yet).

The freerdp package does not provide wlfreerdp which is binary used on Wayland - it only provides the deprecated wlfreerdp3.

The solution to my issue was to sync the freerdp2 package - in addition to removing krdc and freerdp - which provides wlfreerdp and xfreerdp which is the binaries my script relies on.

And I rely on rdp for development tasks - so I am crippled when it is not working.


I tried to delete freerdp 3.4 and and installed freerdp2 2.11.5. Krdc is the same version 24.0.2.
This combination opens a window of the remote system, but TAB key inside remote window is not worked :frowning: (bug id=483638 in KDE bugs list)

Now then.

  1. Combination of new krdc 24.02.1 and freerdp3 3.1 or 3.4 doesn’t work.
  2. Combination of new krdc 24.02.1 and old freerdp2 (2.11.5 from testing repositories) works, but TAB key does not perform the function.
  3. Downgraded krdc from 24.02.1 to 23.08.5 with old freerdp2 is fully working.

I continue to monitor situation :slight_smile: