Konsole + tmux, rendering problems- horizontal stripes

Hi, I have a rendering problem in KDE Konsole terminal when using tmux with multiple panes. I’ve attached the photo because artifacts disappear when a screenshot is taken. Stripes appear after quick pane change or modifying large blocks in vim. They disappear after s second or two or after the next screen cursor movement. Their amount and placement are random. In general, it appears after operations in the terminal produce a lot of line changes. I’ve observed this effect only in Tmux inside Konsole emulator (I’ve checked on xterm and terminator and I haven’t noticed this effect). It worked well a month or two ago (I think I’ve updated Manjaro twice since then). I’ve read that it may be caused by screen scaling but I use 100%. It’s not making work impossible but it’s getting more and more annoying over time. One option is to switch terminal emulator but I like Konsole… Has anyone experienced something similar?

OS: Manjaro Linux x86_64 
Host: UX305UA 1.0 
Kernel: 5.14.10-1-MANJARO 
Uptime: 26 mins 
Packages: 1659 (pacman) 
Shell: zsh 5.8 
Resolution: 1920x1080 
DE: Plasma 5.22.5 
WM: KWin 
WM Theme: Freeze 
Theme: Breath [Plasma], Breath [GTK2/3] 
Icons: breath [Plasma], breath [GTK2/3] 
Terminal: tmux 
CPU: Intel i5-6200U (4) @ 2.800GHz 
GPU: Intel Skylake GT2 [HD Graphics 520] 
Memory: 3702MiB / 7853MiB 

tmux 3.2a
konsole 21.08.2
  Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
  root=UUID=053e926f-8ed5-40f2-90ea-17fef085167c rw quiet
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: ASUSTeK product: UX305UA v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: UX305UA v: 1.0 serial: <filter>
  UEFI: American Megatrends v: UX305UA.302 date: 04/18/2019
  ID-1: BAT0 charge: 32.1 Wh (98.5%) condition: 32.6/56.0 Wh (58.2%)
  volts: 11.3 min: 11.3 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
  status: Not charging cycles: 315
  RAM: total: 7.67 GiB used: 5.49 GiB (71.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: EA cache:
  L2: 3 MiB bogomips: 19204
  Speed: 700 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 700 2: 786 3: 732
  4: 785
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt
  xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: ASUSTeK driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:1916 class-ID: 0300
  Device-2: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  bus-ID: 1-5:2 chip-ID: 0bda:57cb class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: modesetting unloaded: vesa alternate: fbdev display-ID: :0
  screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 166 size: 293x165mm (11.5x6.5")
  diag: 336mm (13.2")
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
  chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: no
  Sound Server-5: PipeWire v: 0.3.38 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 02:00.0
  chip-ID: 8086:095a class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  IP v4: <filter> scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
  bus-ID: 1-8:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 157.11 GiB (65.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Micron model: M600 MTFDDAV256MBF
  size: 238.47 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: MA01 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 175.74 GiB size: 172.74 GiB (98.29%)
  used: 157.08 GiB (90.9%) fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A
  uuid: 053e926f-8ed5-40f2-90ea-17fef085167c
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
  used: 24.7 MiB (9.7%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: N/A
  uuid: 67AE-6FA8
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2.66 GiB used: 12.8 MiB (0.5%)
  priority: -2 dev: /dev/sda6 maj-min: 8:6 label: N/A
  uuid: 6cdd92c4-cca4-4ee1-9a22-47d72226ec03
  ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-2: /dev/sda3 maj-min: 8:3 size: 58.98 GiB fs: ntfs label: OS
  uuid: 987E6ACD7E6AA42A
  ID-3: /dev/sda4 maj-min: 8:4 size: 842 MiB fs: ntfs label: N/A
  uuid: EE906F46906F147D
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-5:2 info: Realtek USB2.0 HD UVC WebCam type: Video
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
  chip-ID: 0bda:57cb class-ID: 0e02 serial: <filter>
  Device-2: 1-8:3 info: Intel Bluetooth wireless interface type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 8087:0a2a class-ID: e001
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 41.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2800
  Processes: 319 Uptime: 2h 12m wakeups: 16118 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1659
  lib: 460 flatpak: 0 Shell: Zsh v: 5.8 running-in: tmux: inxi: 3.3.07
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 293mm x 165mm
   1920x1080     60.05*+  60.01    59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

Xorg and syslog do not produce anything interesting when the problem occurs.

Hi @mateusz28, and welcome!!

While I doubt I’ll be able to help you, please see How to provide good information as that’s very important.

Sorry, I’ve edited post.

Thank you!


BTW: Have you tried a different kernel?

I have 4.19 and 5.10 installed. The problem appears on both. After further research I’ve noticed that glitches appear also without tmux, they are just a bit harder to spot.

If you use fractional scaling - try resetting the scaling to 1 - then restart your system.

Global scale in Display Configuration is set to 100%.

Important discovery:
I always work with transparency disabled. I’ve enabled transparency (alt+shift+f12 to toggle desktop effects on) and strange lines disappeared. I can turn on desktop effects for now but I find them distracting and resources consuming when I’m using an external 2k display with my laptop. Can someone switch off desktop effects and try to reproduce the issue? For example using tmux in Konsole and calling from tmux cmdline (tmux prefix + “:” ) select-pane -t:.1 -P 'bg=black' then select-pane -t:.1 -P 'bg=white' and repeat last 2 steps several times.