Konsole Error in Manjaro Linux

I can not open up my Konsole terminal.
Whenever I try to open it, it shows the icon bouncing near my cursor and then it goes away and nothing comes up.

Welcome to the forum. :slight_smile:

Please read this very informative post below… :arrow_down:

Is your system fully up-to-date?

sudo pacman -Syyu 

I can not open the terminal, so I can not run any commands.

Drop to TTY with CTRL+ALT+F2, then do

sudo pacman -Syyu xterm

Then switch back with CTRL+ALT+F1
and launch xterm … it might work.

Heck … when you are done reboot… a successful update might just banish the issue.

1 Like

Press Ctrl+Alt+F2 to get to a character-mode virtual console, also referred to as a tty. Log in there and update your system. Let it finish and then reboot…

sudo systemctl reboot

Still not working

Still the same issue

Could we at least get some information about…

  • what hardware you’ve got;
  • when the problem started;
  • whether you’ve installed something from outside of the repository;
  • whether you’ve tried logging out and back in;
  • and so on?

See, we’d like to help, but our crystal ball is broken. :roll_eyes:

I got an Asus ZenBook 14 UX433FA.
I recently shifted from Windows to Manjaro.
I was facing some issues with my Linux prompt so I entered the command
echo "PS1='\u@\h \W\$ '" >> ~/.bashrc ; . ~/.bashrc
Nothing happened so I quit via Ctrl+C
Then I typed the command
export PS1="\u@\h"
I forgot to save it in the ~/.bashrc file
I closed the Konsole and couldn’t open it again.

What about editing your ~/.bashrc with an editor like kate or kwrite?

I haven’t tried that.
I don’t know what to do.

Well, try it then.

What do I need to do?
I am clueless.

Fire up KWrite from the system menu. Then click on File and choose "Open". In the field for the filename, type .bashrc and click OK.

Look for any weirdness in the file, and edit your prompt there if that is what you wanted to do in the first place.

I did remove the echo command I had added in the file yet I’m facing the same issue.
Can anyone share a sample .bashrc file so that I can compare it with mine?

I’m afraid I can’t help you there. My ~/.bashrc is based upon the one that came with 18.0.4 Illyria ─ which was in April 2019 ─ and I have heavily modified it. But you should be able to find a vanilla one under /etc/skel.

Open /etc/skel/.bashrc in Kwrite (or Kate), save it as ~/.bashrc ─ i.e. in your home directory ─ and change ownership of the file to yourself using the root actions add-on for Dolphin. Then log out and log in again and try opening a Konsole.

first try to move/rename the .kde4 folder. you should be able to get into plasma desktop and konsole should work. try to implement your customization step by step and you should know which part went wrong…

usually i do this by renaming the dots and start fresh if some customization breaks

You probably have your default .bashrc in /etc/skel

1 Like