Konsole doesn't allow character "a"

To start the update 2021-03-08 I started Konsole (CTRL-ALT T) and entered
$ pacman ...
but the character “a” was not taken so the text was
$ pcmn ...
I copied the word pacman from Kate and pasted it in, that worked. Update went fine, but still character “a” is not taken in Konsole, this means, pressing:

  • a → nothing
  • SHIFT-A → A
  • CAPS-LOCK a → A
  • CAPS-LOCK SHIFT a → nothing

How can I solve this? Thank you!

Are you using a for some kind of alias in bash?

Not on purpose and obviously not, I tried:
$ alias
alias cp=‘cp -i’
alias df=‘df -h’
alias egrep=‘egrep --colour=auto’
alias fgrep=‘fgrep --colour=auto’
alias free=‘free -m’
alias grep=‘grep --colour=auto’
alias ls=‘ls --color=auto’
alias more=‘less’
alias np=‘nano -w PKGBUILD’

In addition: I can start yakuake from pacman, not from Konsole or start-menu; also yakuake has the same issue with the “a”.

Check your Konsole and Yakuake shortcuts – maybe a has some action assigned?

Thank you Tomek: All shortcuts with CTRL, ALT or similar

This sounds like a keyboard defect. Open a simple text editor or create a test file. Does typing the a work ?
Go to tty and try the a.

I’ve found the issue and it has been my mistake: Adding a modification to /etc/inputrc a had a mis-typing. A new line started with “also …” as I forgot the # to mark it as a comment.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.