Keyboard not working (USB Boot)

I’m trying to run manjaro-kde-21.2.6 on an HP Envy (15-aq005na), booting from USB.

Using an external keyboard works without issue. The internal keyboard works fine in GRUB, but there is seemingly zero input from the internal keyboard once manjaro has loaded.

I plugged the same USB into another laptop and the internal keyboard works fine. I had this exact issue trying to run LMDE 4, 5 and LM 20.3 - except with LM the touchpad wasn’t working either, in manjaro the touchpad functions fine.

I’ve tried both open and proprietary. As well as enabling/disabling legacy mode in BIOS.

Manjaro was loaded onto a USB using rufus with partition: MBR, target system: BIOS or UEFI.

This is my first attempt at using linux altogether, so I’m not 100% sure on what logs to offer without being requested.

Thank you very much

provide formated (click 3x this icon: </>) output of this:
inxi -Fazy
and also install the following kernels (system settings/ kernel):
reboot, and try booting with each one, and check your keyboard

1 Like
    ~  inxi -Fazy                                                                                     ✔ 
  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC
    misobasedir=manjaro misolabel=MANJARO_KDE_2126 quiet systemd.show_status=1
    apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP ENVY x360 Convertible
    v: Type1ProductConfigId serial: <superuser required> Chassis: type: 31
    serial: <superuser required>
  Mobo: HP model: 81AC v: 53.27 serial: <superuser required> UEFI: Insyde
    v: F.23 date: 01/03/2017
  ID-1: BAT0 charge: 1.9 Wh (6.4%) condition: 29.7/29.7 Wh (100.0%)
    volts: 16.4 min: 15.4 model: 313-54-41 MB04055XL type: Li-ion
    serial: <filter> status: charging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: Intel Core i7-6560U bits: 64 type: MT MCP arch: Skylake
    family: 6 model-id: 0x4E (78) stepping: 3 microcode: 0xEC
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 607 high: 617 min/max: 400/3200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 617 2: 614 3: 600 4: 600
    bogomips: 17605
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Graphics 540 vendor: Hewlett-Packard driver: i915
    v: kernel ports: active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:1926 class-ID: 0300
  Device-2: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD
    type: USB driver: uvcvideo bus-ID: 1-4:3 chip-ID: 05c8:0800 class-ID: 0e02
    serial: <filter>
  Device-3: Cheng Uei Precision Industry (Foxlink) HP IR Camera type: USB
    driver: uvcvideo bus-ID: 1-8:6 chip-ID: 05c8:0801 class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: LG Display 0x052f built: 2016 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Iris Graphics 540 (SKL GT3)
    v: 4.6 Mesa 21.3.8 direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
    chip-ID: 8086:9d70 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 01:00.0 chip-ID: 8086:095a class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-6:5 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 29.45 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda maj-min: 8:0 type: USB vendor: Patriot model: N/A
    size: 29.45 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No partition data found.
  Alert: No swap data was found.
  System Temperatures: cpu: 37.0 C pch: 31.0 C mobo: 30.0 C
  Fan Speeds (RPM): N/A
  Processes: 205 Uptime: 4m wakeups: 3 Memory: 7.66 GiB used: 2.28 GiB (29.8%)
  Init: systemd v: 250 tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1
  Packages: pacman: 1230 lib: 334 flatpak: 0 Shell: Zsh v: 5.8.1 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.15
    ~  lsusb                                                                                          ✔ 
Bus 002 Device 003: ID 13fe:5200 Kingston Technology Company Inc. DataTraveler R3.0
Bus 002 Device 002: ID 05e3:0626 Genesys Logic, Inc. Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 05c8:0801 Cheng Uei Precision Industry Co., Ltd (Foxlink) HP IR Camera
Bus 001 Device 005: ID 8087:0a2a Intel Corp. Bluetooth wireless interface
Bus 001 Device 003: ID 05c8:0800 Cheng Uei Precision Industry Co., Ltd (Foxlink) HP TrueVision HD
Bus 001 Device 007: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 004: ID 258a:0016 BY Tech Usb Gaming Keyboard
Bus 001 Device 002: ID 05e3:0610 Genesys Logic, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    ~  lspci                                                                                          ✔ 
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Iris Graphics 540 (rev 0a)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 09)
00:13.0 Non-VGA unclassified device: Intel Corporation Sunrise Point-LP Integrated Sensor Hub (rev 21)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #4 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.7 Non-Essential Instrumentation [1300]: Intel Corporation Device 9d26 (rev 21)
01:00.0 Network controller: Intel Corporation Wireless 7265 (rev 61)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)

Much appreciated, I will try install the kernels and report back.

It seems only one kernel is available. I’m guessing this is either anomalous, or I need to download them via konsole - I will investigate this now.

that is no normal… try running this command:
pamac update

@brahma You seem to have misunderstood the OP: they are booting from usb.

One cannot change the kernel for usb boot via package management.

You can try downloading another ISO with another kernel, latest stable announcement post has several minimal isos for each DE featuring 5.15, 5.10 or 5.4 kernel:

Look at the bottom below the Download Now button.

1 Like

yes you are correct, didnt notice it…

Thank you everyone for your help.

I installed Manjaro on an external sata SSD from a USB live boot. This HP Envy I’m working with had some issues, I couldn’t get it to boot from the HDD, or SSD (both operate fine independently when checked on another device) with windows or linux. So I think the HP has issue reading from internal drives. This is my friends computer, I was given it as a ‘play’ computer, due to it being faulty, which I decided I’d start my linux journey on. Prior to the internal drive failures, the keyboard and touch pad were working fine. Obviously this device is having some hardware issues, but given the keyboard works fine in BIOS and manjaro GRUB, I thought I may be able to solve it.

I tried kernels:

Ensuring all were running, not just installed and restarted / checked the keypad with each trial. No success unfortunately. Interestingly the touchpad couldn’t move the cursor on 5.10, but it worked fine with all other kernels. When I tried mint (20.2, LMDE 4 & 5) the touchpad nor keyboard worked either.

So. I’m currently running manjaro installed on an external sata SSD, kernel 5.15.32-1. Touchpad is moving the cursor, no feedback from keyboard but on a live boot the keyboard works in GRUB. When I boot installed manjaro I get /dev/sda2: clean, 285112/7798784 files, 3015368/31181161 blocks, before showing the login screen.

/dev/sda2: clean, 285112/7798784 files, 3015368/31181161 blocks - this message is normal, so ignore it…
go to etc/mkinitcpio.conf and post the line HOOKS=" … " here

1 Like
HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems fsck"

really have no idea… you could try putting in /etc/default/grub and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the " " quotes this paramater: acpi=off - dont delete anything from the line, just add it there…
run this:
sudo update-grub
reboot and check

I ran the grub update and now I actually have grub when booting manjaro, a nicer feel than the files and blocks message. Thanks for that.

acpi=off didn’t fix the HP keyboard, unfortunately, despite the keyboard still working in grub. Interestingly acpi=offdisabled my internal keyboard on my acer predator too. I deleted this and now the predator keyboard is back to working.

No worries at all, your help is greatly appreciated. I’m going to proceed my linux journey using my predator, booting manjaro (installed) from an external ssd. I don’t know much, at all, of what you wrote/suggested so my next steps are to learn about what you offered.

Thank you very much.

that acpi off was a one solution i found that one had with the exact same pc as you, and it did work for him … you can search for internal keyboard not working linux manjaro arch ubuntu

This is a wild guess, since the laptop could have some issues it might be a interesting experiment to disable as much as possible in the BIOS. This thread on HP’s site seems a solution for one type of machine where disabling integrated sensors enabled the keyboard.