Keyboard layout not getting set on Vim1

My 2nd comment is regarding the keyboard layout (I use French layout because I live in France).
During 1st boot after system flashing, I was asked to choose my layout and all went well until I needed to reboot and enter the credentials of my newly created account. The GUI showed me a dialog in the middle of the screen to enter my password, no indication whatsoever regarding the currently selected keyboard layout (you may Ask, why bother… ), and no possibility to see what I was typing. The invisible problem was that the kbd layout was not the one I told the installer during the previous session: after a few failed tentative to enter my password, I finally typed it as if my layout was English, that finally allowed me to enter manjaro xfce for the 1st time , the annoying truth is that the expected layout was I fact fully set and used, but only after that GUI login before!
I suggest that you explicitely show what is the current kbd layout and allow him to fix it if it’s wrong (my case), I hate to compare linux guis with ms windows, but this is what they do, and I think it is the proper way to offer a good ux!

This is something related to the SDDM theme we use.
We use the Breath2 SDDM theme, which is maintained by @bogdancovaciu. Maybe he knows what we need to do to get it to show? I know the default SDDM theme shows the layout.

A better fix should simply be to let the installer app set up the kbd layout to whatever the user has chosen and make it active and effective before asking for the very 1st user input

It should do that though.
It uses loadkeys $KEYMAP right after the prompt where you choose a layout, when the system first boots.

The issue is not during the 1st boot session, it is during all the next ones and when the user is to enter his passwd, one workaround I have applied was to prevent manjaro from asking me any password ! It works , but an average user would not even want to find a solution himself

Sounds like the keymap is not getting correctly to the file then.

What’s the output of localectl?

My situation might be a bit unique, I use a French kbd, but I want my system to talk to me in English…

It needs to be added to /usr/share/sddm/scripts/Xsetup
Something like this, what i use in my case:

setxkbmap -model pc105 -layout us,ro,es -option grp:alt_shift_toggle

So it should be generated at install, or edited manually by the user.
More about this here
and here

With this, any sddm theme should show the keyboard layout at login, including our Breath2.
Hope this helps. :slight_smile:

The setup script uses localectl set-keymap $KEYMAP to set the system keymap for future boots.

From the localectl help file:

 set-keymap MAP [MAP]     Set console and X11 keyboard mappings

Is that not enough for it to work with SDDM? Then maybe a bug should be opened at the sddm project.

1 Like

It seems not enough and probably KDE Developers would have more to say or suggest about this. Still looking into it, but my progress is slow in this regards.

1 Like

The gui is xfce here, and not KDE :sneezing_face: :woozy_face:

Ah okay. So it’s something with LightDM then.

Sorry I cannot get access to my SBC anymore, none of my mice and kbd can work on my vim1 SBC anymore… Even when booting from sdcard… Does manjaro accept by default any incoming ssh session ?

Yes. SSH is enabled by default,

1 Like

using ssh, I can get this…
[raxy@vim1jaro ~]$ localectl
System Locale: LANG=en_GB.UTF-8
VC Keymap: azerty
X11 Layout: n/a

I hope it can help to , at least, qualify the context…

by the way, @Strit , a quick look at the dmesg of the freshly booted sbc shows a bunch of errors,
maybe we should open another topic to comment them ?

This looks to be the issue.

Thanks for pointing that out. I was replying to something @Strit mentioned and how i do it on KDE Plasma Desktop. I have no clue about ARM but i felt compelled to reply. :slight_smile:

So be it, but what to do next ?