Keyboard and mouse settings impersistent between reboots


I’m sorry in advance but I’m somewhat new to linux. About 5 months ago I updated my system and I think in the process KDE updated as when I rebooted I was greeted by a new splashscreen and various other things. I noticed that my keyboard and mouse settings were unreconfigurable. I did some research and came to the conclusion it was a bug with KDE. Recently, I updated KDE again and this issue wasn’t resolved, which leads me to believe it might be an issue with my system. During this time I’ve updated to several kernels hoping that might change things, however nothing has come to fruition.

As it stands, when I reboot I have to open up system settings and move the mouse sensitivity down, hit apply, then move it back to where I want it for the desired sensitivity to apply. That seems to temporarily fix the mouse. For the keyboard, no amount of fiddling with the settings changes my input delay. I’ve recently found editing the delay with xset makes it useable, but I’d really like to fix the underlying issue. It also appears that passing -ardelay and -arinterval to xserverrc doesn’t address the issue either.

Thank you

Hi, rootzero!
Welcome to community!

Try to clean cache: [Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice - #2 by philm (the KDE Plasma shows visual graphical errors section).

If not helped, consider to check this: [How to] Help a new forum member solve problems

In the system settings → Startup and Shutdown → Desktop Session, make sure it does not restart with an empty session.

1 Like

Welcome to the forum!

A while ago, I had similar problems in Plasma. In my case, it was the keyboard repeat rate and delay that wouldn’t persist across logins, a no longer working compose key, and the behavior of the numeric keypad.

Below is the link to my post on how I fixed things. Maybe you’ll find some inspiration in it. :wink:

Thank you for your suggestion, however nothing in your post worked.

You do have to log out after making the changes and log back in. Have you done that?

Yes, I even rebooted.

Well, it was worth a try. But I’m surprised the modification for the keyboard repeat rate didn’t work, because it most certainly does here.

A thought that occured to me is that I’m using nvidia-settings to configure my monitor layout. Might that be interfering with something?

Not to my knowledge, but one never knows. :thinking:

I am currently doing this. It still doesn’t save my mouse and keyboard configurations.

Thank you for the suggestions, but none of those fixed my issue.

I have solved the issues. For some reason, the keyboard daemon wasn’t starting upon login. Enabling it fixed my issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.