Kernel wont start

I recently installed Linux Mint Cinnamon 20 on top of Manjaro KDE 20 and i had to partition my drives and a gave Mint 56GB and Manjaro was left with about 423GB.
The system boots into Mint fine but however when i try to boot into Manjaro it fails. It gives the error:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
CPU: 1 PID: 1 Comm: swapper/0 Not tainted 5.7.14-1-Manjaro #1
Hardware name: Hewlette-Packard HP 255 G3 Notebook PC/21F7, BIOS F.48 04/16/2018
Call Trace
? rest_init+0xbf/0xbf
Kernel Offset: 0xbe00000 from 0xffffffff81000000 (relocation range: 0xffffffff-0xfffffffbfffffff)
---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0) ]---

Use a Manjaro live ISO, boot into it in the same mode as your install (BIOS or UEFI) and enter

sudo manjaro-chroot -a

Select the Manjaro install, if only one line is offered enter: 1


parted -l
lsblk -f
ls -la /boot
efibootmgr -v

Copy the output here to the forum. Then leave chroot and terminal by


This allows us to determine how to re-install the grub bootloader from Manjaro. manjaro can boot Mint but Mint cannot (easily) boot Manjaro. Therefore best procedure is to re-install grub from Manjaro and then to enter sudo update grub to have the option to boot both OS from Manjaro’s grub menu.

1 Like

output of parted -l

Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                  Flags
 1      1049kB  538MB   537MB   fat32                                 msftdata
 2      538MB   13.1GB  12.6GB  linux-swap(v1)                        swap
 3      13.1GB  444GB   431GB   ext4
 4      444GB   444GB   537MB   fat32           EFI System Partition  boot, esp
 5      444GB   500GB   55.9GB  ext4

Model: Generic Flash Disk (scsi)
Disk /dev/sdb: 16.4GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 2      3120MB  3124MB  4194kB  primary               esp

output of lsblk -f

|-sda1                          510.7M     0% /boot/efi
|-sda3                            6.1G    93% /

output of ls -la /boot

total 94492
drwxr-xr-x  5 root root     4096 Aug 20 19:58 .
drwxr-xr-x 17 root root     4096 Sep  1 12:05 ..
drwxr-xr-x  3 root root     4096 Jan  1  1970 efi
drwxr-xr-x  5 root root     4096 Aug 20 19:59 grub
-rw-r--r--  1 root root 30835186 Aug 20 19:57 initramfs-5.6-x86_64-fallback.img
-rw-r--r--  1 root root  9127403 Aug 20 19:56 initramfs-5.6-x86_64.img
-rw-r--r--  1 root root 30982431 Aug 20 19:58 initramfs-5.7-x86_64-fallback.img
-rw-r--r--  1 root root  9128007 Aug 20 19:58 initramfs-5.7-x86_64.img
-rw-r--r--  1 root root  3161088 Jun 16 19:50 intel-ucode.img
-rw-r--r--  1 root root       21 Jun 18 00:24 linux56-x86_64.kver
-rw-r--r--  1 root root       21 Aug  7 12:11 linux57-x86_64.kver
drwxr-xr-x  2 root root     4096 Jun  6 10:03 memtest86+
-rw-r--r--  1 root root  6795040 Jul 21 01:29 vmlinuz-5.6-x86_64
-rw-r--r--  1 root root  6680800 Aug 20 19:56 vmlinuz-5.7-x86_64

output of efibootmgr -v

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 0003,0000,3000,0001,2001,2002,2003
Boot0000* ubuntu        HD(4,GPT,24bcaf0e-df38-4b79-9fbe-43319de95511,0x33a6e800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* EFI HDD Device (TOSHIBA MQ01ABD050V -63)      PciRoot(0x0)/Pci(0x11,0x0)/Ata(0,0,0)/HD(1,GPT,6574a687-1ca8-ad48-accf-5d795d3f18c6,0x800,0x100000)RC
Boot0002* USB Hard Drive (UEFI) - Generic Flash Disk    PciRoot(0x0)/Pci(0x12,0x2)/USB(0,0)/HD(1,MBR,0x0,0x5cf8f0,0x2000)RC
Boot0003* USB Entry for Windows To Go   UsbClass(ffff,ffff,255,255)....&@.G...C..6.
Boot0009* Internal Hard Disk or Solid State Disk        RC
Boot000A* Internal Hard Disk or Solid State Disk        RC
Boot2001* USB Drive (UEFI)      RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)      RC
Boot3000* Internal Hard Disk or Solid State Disk        RC
Boot3001* Internal Hard Disk or Solid State Disk        RC
Boot3002* Internal Hard Disk or Solid State Disk        RC
Boot3004* Internal Hard Disk or Solid State Disk        RC
Boot3005* Internal Hard Disk or Solid State Disk        RC

OK, chroot into your system again and then enter

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck
update grub

Afterwards, reboot into your firmware and select the Manjaro entry to start from it. Now you should see both OS in the grub menu.

I did the grub-install command successfully but when updating the grub an error occurred.

But I dont think that matters coz when i checked in KDE Partition Manager /dev/sdb1 belongs to the bootable USB drive that um using

The error is still there even after updating grub

This is normal as the USB stick was still plugged in - no problem.

Did you find the boot entry of Manjaro in the firmware?

Can you describe the new situation a bit more clear? If everything has been done right you should see the Manjaro grub menu after booting - yes or no?

Also, you need to boot without the USB stick being plugged, preferably.

The error is still there even after updating grub

No at startup it displays the Mint boot menu not the Manjaro one.
And yes during grub-update the boot entry for Manjaro was successfully found.

You need to boot into your UEFI firmware. There is usual a config table you select the device to boot from. After successful re-install of grub from Manjaro you should see an entry with name “Manjaro” in it. make this your primary boot device and boot into it.

I used the Advanced Manjaro entry on the boot menu and from there i selected the fallback kernel and the system has successfully booted. Is there anything I can do now being in the system so that next time the default kernel should work

One step after the other.

  1. Have you changed the firmware primary boot device to Manjaro?
  2. Why did you use the advanced options?
  3. What is displayed when the (Manjaro?) grub menu appears?
  4. If Linux Manjaro appears on top, can you boot into it?
  5. Do you see an entry for Linux Mint?
  6. Can you use this entry to boot into Mint?

Questions over questions…

  1. No the default is still Mint
  2. Just experimenting
    3 & 4. If I use the Manjaro menu it still fails to boot
    5 &6 Yes the entry for Mint is there and i can still boot

When i got into the system i lauched the Kernel settings and it did not list any kernels as installed so i think i just have to install one here

It could be that you have to change the boot flag. It’s currently set for sda4 but for Manjaro you use sda1. You could run a live ISO again, start GParted and change the boot flag to have it set on sda1 and removed on sda4. For the esp flag you can do the same.

??? How can you the system without a kernel being installed ???

Um using a fallback kernel. Whenever Manjaro updates a kernel it keeps a fallback kernel just in case something goes wrong with the installed one

OK, then you can indeed install a kernel. Chroot again like described above and enter

mhwd-kernel -i linux54
mkinitcpio -P
depmod -a

I have the same problem, but it started differently…
I was doing an update from the GUI when my battery went empty (now I know why they ask you on the phone to plug it in before updating)
Now my systems seems to be in a rather inconsistent state.
Trying reinstall a kernel from a live-system in a chroot with
mhwd-kernel -i linux54
gives me the error that on trying to synchronize package databases that it cannot lock any of the databases:
error: failed to update core (unable to lock database)
error: failed to update extra (unable to lock database)
error: failed to update community (unable to lock database)
error: failed to update multilib (unable to lock database)

Now I am … lost
Thanks for any help

Found help in the Wiki.
Had to delete the lock for the databases inside the chroot.
Sorry for the noise.
System up and running


I have had kernel panic with both manjaro and slackware this week, and my search brought me here, where I really enjoyed reading TheWizard`s posts. Searching for solutions is painful work and it was refreshing to have some soft nice humor around.

I had faced this problem a couple years ago when I first tried Manjaro. and with the help of the venerable Goh Lip (hope I am not misspelling it) I solved it by chrooting in Manjaro from some Manjaro media and installing /updating grub, which gave me the bonus of a nicer-looking booting visual.

I have also “solved” it , or went around it, by editing a 40_custom file at /etc/grub.d, in the case of the distros I had booting in different cases.

I understand the custom.grub way is the more elegant one, but I wonder whether it can be used as a once for all with 2 distros.

Thanks for the good time I had reading the thread, which by the way I found way above the average in pedagogical terms - that is the subject I am best at.

Edit: Ooops! seems you had already answered my question here:
“Manjaro - Kernel Panics and Other Tips for Arch-based Distros”